aboutsummaryrefslogtreecommitdiff
path: root/x11/workrave/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-06-13 13:25:07 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-06-13 13:25:07 +0000
commitfd271750bdf49f827951ba9da9e1cf56c7f6780f (patch)
tree62aab58ce69fea3a44ef5720cd0cce678cf70bde /x11/workrave/Makefile
parent99c87c92d4f3152559ef6f633b0cdd63aa9b44e1 (diff)
Notes
Diffstat (limited to 'x11/workrave/Makefile')
-rw-r--r--x11/workrave/Makefile29
1 files changed, 22 insertions, 7 deletions
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index bb991e3c3aa4..0dce65907c9f 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -14,20 +14,35 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= infofarmer@FreeBSD.org
COMMENT= A Gnome RSI prevention tool
-LIB_DEPENDS= gnomeuimm-2.6.1:${PORTSDIR}/x11-toolkits/libgnomeuimm26 \
- gnet-2.0.0:${PORTSDIR}/net/gnet2
+.if !defined(WITHOUT_GNOME)
+LIB_DEPENDS= gnomeuimm-2.6.1:${PORTSDIR}/x11-toolkits/libgnomeuimm26
+.else
+LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
+.endif
+.if !defined(WITHOUT_NETWORK)
+LIB_DEPENDS+= gnet-2.0.0:${PORTSDIR}/net/gnet2
+.endif
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GETTEXT= yes
-USE_GNOME= gnomeprefix gnomehack intlhack gnomepanel gconf2 intltool
+USE_GNOME= gnomeprefix gnomehack intlhack gconf2 intltool
+.if !defined(WITHOUT_GNOME)
+USE_GNOME+= gnomepanel
+.endif
USE_GCC= 3.4
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-CONFIGURE_ARGS= --datadir=${PREFIX}/share/gnome/workrave \
- --enable-gconf \
- --enable-gnome \
- --enable-exercises
+CONFIGURE_ARGS= --enable-gconf
+.if defined(WITHOUT_GNOME)
+CONFIGURE_ARGS+=--disable-gnome
+PLIST_SUB= GNOME="@comment "
+.else
+PLIST_SUB= GNOME=""
+.endif
+.if defined(WITHOUT_NETWORK)
+CONFIGURE_ARGS+=--disable-distribution
+.endif
.include <bsd.port.mk>