aboutsummaryrefslogtreecommitdiff
path: root/x11/workrave
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2011-05-31 00:28:59 +0000
committerDavid Thiel <lx@FreeBSD.org>2011-05-31 00:28:59 +0000
commit9acc6e08b3308d2b8ed99fc83e80d27bc22446af (patch)
tree6bb5252cc87ffcc50a5be651d390e082cc80b86a /x11/workrave
parentc08b12802987b888ef0f358ac54e20e3146b20c1 (diff)
downloadports-9acc6e08b3308d2b8ed99fc83e80d27bc22446af.tar.gz
ports-9acc6e08b3308d2b8ed99fc83e80d27bc22446af.zip
Notes
Diffstat (limited to 'x11/workrave')
-rw-r--r--x11/workrave/Makefile24
-rw-r--r--x11/workrave/distinfo4
-rw-r--r--x11/workrave/files/patch-System.cc22
-rw-r--r--x11/workrave/pkg-plist11
4 files changed, 29 insertions, 32 deletions
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index 3dab7ab2b0aa..7a2f57a527a8 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= workrave
-PORTVERSION= 1.9.1
-PORTREVISION= 4
+PORTVERSION= 1.9.4
CATEGORIES= x11 gnome
MASTER_SITES= SF
@@ -19,11 +18,12 @@ BUILD_DEPENDS= gdome-config:${PORTSDIR}/textproc/gdome2
OPTIONS= GNOME "Build with Gnome support" off \
NETWORK "Build with network support" off
+INSTALLS_ICONS= yes
DESKTOP_ENTRIES= "Workrave" "An RSI prevention tool" \
"${DATADIR}/images/workrave-icon-small.png" \
"workrave" \
"Application;Utility;" \
- false
+ ${FALSE}
USE_XORG= x11 xmu recordproto xtst xext
USE_GMAKE= yes
@@ -31,10 +31,9 @@ MAKE_JOBS_SAFE= yes
USE_GNOME= gnomeprefix gnomehack intlhack gconf2 intltool
USE_GSTREAMER= good
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include `pkg-config --cflags libgnomeui-2.0`" \
- LDFLAGS="-L${LOCALBASE}/lib" \
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
LIBS="`pkg-config --libs libgnomeui-2.0`"
-CONFIGURE_ARGS= --enable-gconf
+CONFIGURE_ARGS= --enable-gconf --disable-pulse
.include <bsd.port.pre.mk>
LIB_DEPENDS+= gdome.8:${PORTSDIR}/textproc/gdome2
@@ -63,17 +62,4 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|#include <sigc++\/compatibility\.h>||g ; \
- s|SigC::Signal|sigc::signal|g ; \
- s|SigC::slot_class|sigc::mem_fun|g ; \
- s|SigC::Connection|sigc::connection|g ; \
- s|SigC::Slot|sigc::slot|g ; \
- s|SigC::Object|sigc::trackable|g ; \
- s|SigC::slot|sigc::mem_fun|g' \
- ${WRKSRC}/frontend/gtkmm/src/*.* \
- ${WRKSRC}/frontend/plugin/*/gtkmm/src/*.*
- @${REINPLACE_CMD} -e 's|Gtk::HButtonBox|Gtk::ButtonBox|g' \
- ${WRKSRC}/frontend/plugin/exercises/gtkmm/src/ExercisesPanel.*
-
.include <bsd.port.post.mk>
diff --git a/x11/workrave/distinfo b/x11/workrave/distinfo
index 623a920be9c4..b881194f4a74 100644
--- a/x11/workrave/distinfo
+++ b/x11/workrave/distinfo
@@ -1,2 +1,2 @@
-SHA256 (workrave-1.9.1.tar.gz) = 5c23af4b36fc6dd27b0f1b58373868d925fb91ec9ff40b7c7bbcec52a1b28ab9
-SIZE (workrave-1.9.1.tar.gz) = 6594737
+SHA256 (workrave-1.9.4.tar.gz) = ce1efa57a37192029c4dcbe8a0ac2b893b2286c42828f19b0fb86867cbbcde1a
+SIZE (workrave-1.9.4.tar.gz) = 6748495
diff --git a/x11/workrave/files/patch-System.cc b/x11/workrave/files/patch-System.cc
index 1340f1253b0f..fea794968e28 100644
--- a/x11/workrave/files/patch-System.cc
+++ b/x11/workrave/files/patch-System.cc
@@ -1,12 +1,20 @@
---- frontend/common/src/System.cc.old 2010-03-25 11:16:41.000000000 -0700
-+++ frontend/common/src/System.cc 2010-03-25 11:16:55.000000000 -0700
-@@ -41,9 +41,6 @@
+--- frontend/common/src/System.cc.old 2011-05-17 11:54:41.000000000 -0500
++++ frontend/common/src/System.cc 2011-05-17 11:55:13.000000000 -0500
+@@ -41,15 +41,12 @@
#include <X11/Xproto.h>
#include <X11/Xlib.h>
#include <X11/Xutil.h>
--#endif
--
--#if defined(HAVE_UNIX)
- #include <sys/wait.h>
++#include <sys/wait.h>
+ #ifdef HAVE_APP_GTK
+ #include <gdk/gdkx.h>
+ #endif
#endif
+-#if defined(HAVE_UNIX)
+-#include <sys/wait.h>
+-#endif
+-
+ #ifdef PLATFORM_OS_WIN32
+ #include <shlobj.h>
+ #include <shldisp.h>
+
diff --git a/x11/workrave/pkg-plist b/x11/workrave/pkg-plist
index 91f962b7e008..a4c57f6b3414 100644
--- a/x11/workrave/pkg-plist
+++ b/x11/workrave/pkg-plist
@@ -3,8 +3,12 @@ bin/workrave
%%GNOME%%libdata/bonobo/servers/Workrave-Control.server
%%GNOME%%libexec/workrave-applet
%%GNOME%%share/gnome-2.0/ui/GNOME_WorkraveApplet.xml
-share/pixmaps/workrave/workrave.xpm
-share/pixmaps/workrave/workrave-icon-huge.png
+share/dbus-1/services/org.workrave.Workrave.service
+share/locale/ga/LC_MESSAGES/workrave.mo
+share/locale/ko/LC_MESSAGES/workrave.mo
+share/locale/te/LC_MESSAGES/workrave.mo
+share/icons/hicolor/48x48/apps/workrave-icon-huge.png
+share/icons/hicolor/scalable/apps/workrave-sheep.svg
share/sounds/workrave/subtle/break-ignored.wav
share/sounds/workrave/subtle/break-prelude.wav
share/sounds/workrave/subtle/daily-limit.wav
@@ -27,7 +31,7 @@ share/sounds/workrave/default/micro-break-started.wav
share/sounds/workrave/default/rest-break-ended.wav
share/sounds/workrave/default/rest-break-started.wav
share/sounds/workrave/default/soundtheme
-%%DATADIR%%/images/workrave.xpm
+share/workrave/images/workrave.xpm
%%DATADIR%%/exercises/backward-shoulder-stretch.png
%%DATADIR%%/exercises/chair-pushup-1.png
%%DATADIR%%/exercises/chair-pushup-2.png
@@ -105,4 +109,3 @@ share/sounds/workrave/default/soundtheme
@dirrm share/sounds/workrave/default
@dirrm share/sounds/workrave/subtle
@dirrm share/sounds/workrave
-@dirrm share/pixmaps/workrave