aboutsummaryrefslogtreecommitdiff
path: root/x11/workrave
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-08-04 19:06:00 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-08-04 19:06:00 +0000
commit5b9cf509a468ebbd99da26a6426ac87b107083ff (patch)
treef07e04341d2d406663c1d5e7e1bae8d2bbe94a8b /x11/workrave
parenta7636e91f168bf27b061e4224e8c0133fde0db4b (diff)
downloadports-5b9cf509a468ebbd99da26a6426ac87b107083ff.tar.gz
ports-5b9cf509a468ebbd99da26a6426ac87b107083ff.zip
Notes
Diffstat (limited to 'x11/workrave')
-rw-r--r--x11/workrave/Makefile69
-rw-r--r--x11/workrave/distinfo5
-rw-r--r--x11/workrave/files/patch-System.cc20
-rw-r--r--x11/workrave/files/patch-backend__include__ICore.hh10
-rw-r--r--x11/workrave/files/patch-backend_include_ICore.hh11
-rw-r--r--x11/workrave/files/patch-backends__src__unix__Makefile.in11
-rw-r--r--x11/workrave/files/patch-common_src_Locale.cc27
-rw-r--r--x11/workrave/files/patch-configure39
-rw-r--r--x11/workrave/files/patch-configure.ac97
-rw-r--r--x11/workrave/files/patch-frontend__common__src__Makefile.in11
-rw-r--r--x11/workrave/files/patch-frontend_common_src_ScreenLockCommandline.cc11
-rw-r--r--x11/workrave/pkg-descr6
-rw-r--r--x11/workrave/pkg-plist16
13 files changed, 205 insertions, 128 deletions
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index 76717b526612..ca177e2fb5d1 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -2,46 +2,67 @@
# $FreeBSD$
PORTNAME= workrave
-PORTVERSION= 1.10.1
-PORTREVISION= 2
-CATEGORIES= x11 gnome
-MASTER_SITES= SF
+PORTVERSION= 1.10.15
+CATEGORIES= x11
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= t@tobik.me
COMMENT= RSI prevention tool
LICENSE= GPLv3+
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cheetah>0:devel/py-cheetah
LIB_DEPENDS= libgdome.so:textproc/gdome2
-USES= gettext gmake pathfix pkgconfig python:2.7
-USE_XORG= recordproto x11 xext xmu xscrnsaver xtst
-USE_GNOME= intlhack gconf2 gtkmm24
+USES= autoreconf:build gettext gmake libtool pathfix pkgconfig
+USE_XORG= ice recordproto sm x11 xext xmu xscrnsaver xtst
+USE_GNOME= intltool intlhack introspection gtkmm30
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules --enable-gconf --disable-gnome3 \
+CONFIGURE_ARGS= --disable-silent-rules \
+ --disable-gsettings \
+ --disable-pulse \
+ --disable-gconf \
+ --disable-mate \
+ --disable-gnome2 \
+ --disable-gnome3 \
+ --disable-xfce \
--disable-indicator
INSTALLS_ICONS= yes
+USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
+USE_GITHUB= yes
+GH_ACCOUNT= rcaelers
+GH_TAGNAME= v${PORTVERSION:S/./_/g}
-OPTIONS_DEFINE= GNOME GSTREAMER PULSEAUDIO
-OPTIONS_DEFAULT= GSTREAMER
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= DBUS DISTRIBUTION GSTREAMER
+OPTIONS_DEFAULT= DBUS GSTREAMER
OPTIONS_SUB= yes
-GNOME_USE= gnome=gnomepanel
-GNOME_LIB_DEPENDS= libgnomeuimm-2.6.so:x11-toolkits/libgnomeuimm26
-GNOME_CONFIGURE_ENABLE= gnome2
-GSTREAMER_USE= gstreamer=good
+DISTRIBUTION_DESC= Build with networking support
+
+DBUS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cheetah>0:devel/py-cheetah
+DBUS_CONFIGURE_ENABLE= dbus
+DBUS_USES= python:2.7
+
+DISTRIBUTION_CONFIGURE_ENABLE= distribution
+
+GSTREAMER_LIB_DEPENDS= libgstreamer-1.0.so:multimedia/gstreamer1
GSTREAMER_CONFIGURE_ENABLE= gstreamer
-PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
-PULSEAUDIO_CONFIGURE_ENABLE= pulse
+GSTREAMER_USE= gstreamer1=good
+# Remove gnome-shell cinnamon subdirs from build, so it doesn't install
+# unused files
post-patch:
- @${REINPLACE_CMD} -e \
- '/if test/s|==|=|' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
- 's| gnome-shell$$||' ${WRKSRC}/frontend/applets/Makefile.in
+ @${REINPLACE_CMD} -e 's| gnome-shell cinnamon | |' \
+ ${WRKSRC}/frontend/applets/Makefile.am
+
+# Run bundled autogen.sh instead of relying on USES=autoreconf which
+# leads to errors like
+# config.status: error: po/Makefile.in.in was not created by intltoolize.
+pre-configure:
+ @cd ${WRKSRC} && ./autogen.sh
.include <bsd.port.mk>
diff --git a/x11/workrave/distinfo b/x11/workrave/distinfo
index d7280830917c..5c21199d9fbc 100644
--- a/x11/workrave/distinfo
+++ b/x11/workrave/distinfo
@@ -1,2 +1,3 @@
-SHA256 (workrave-1.10.1.tar.gz) = 6ef89aebd278e27d3b73896485e7d8aaef415e7d18318d3bb7ba0d0507bd48de
-SIZE (workrave-1.10.1.tar.gz) = 6800197
+TIMESTAMP = 1469179894
+SHA256 (rcaelers-workrave-1.10.15-v1_10_15_GH0.tar.gz) = fa05bedbb32baae9d22ef2b1ac25e90bc9f1363ce588b396190b0240559f471c
+SIZE (rcaelers-workrave-1.10.15-v1_10_15_GH0.tar.gz) = 6375380
diff --git a/x11/workrave/files/patch-System.cc b/x11/workrave/files/patch-System.cc
deleted file mode 100644
index fea794968e28..000000000000
--- a/x11/workrave/files/patch-System.cc
+++ /dev/null
@@ -1,20 +0,0 @@
---- frontend/common/src/System.cc.old 2011-05-17 11:54:41.000000000 -0500
-+++ frontend/common/src/System.cc 2011-05-17 11:55:13.000000000 -0500
-@@ -41,15 +41,12 @@
- #include <X11/Xproto.h>
- #include <X11/Xlib.h>
- #include <X11/Xutil.h>
-+#include <sys/wait.h>
- #ifdef HAVE_APP_GTK
- #include <gdk/gdkx.h>
- #endif
- #endif
-
--#if defined(HAVE_UNIX)
--#include <sys/wait.h>
--#endif
--
- #ifdef PLATFORM_OS_WIN32
- #include <shlobj.h>
- #include <shldisp.h>
-
diff --git a/x11/workrave/files/patch-backend__include__ICore.hh b/x11/workrave/files/patch-backend__include__ICore.hh
deleted file mode 100644
index 176eedc63f69..000000000000
--- a/x11/workrave/files/patch-backend__include__ICore.hh
+++ /dev/null
@@ -1,10 +0,0 @@
---- backend/include/ICore.hh.orig 2010-12-05 21:01:31.000000000 +0300
-+++ backend/include/ICore.hh 2014-05-17 03:18:53.674936521 +0400
-@@ -21,6 +21,7 @@
- #define ICORE_HH
-
- #include <string>
-+#include <ctime>
-
- #include "enum.h"
-
diff --git a/x11/workrave/files/patch-backend_include_ICore.hh b/x11/workrave/files/patch-backend_include_ICore.hh
new file mode 100644
index 000000000000..eb3893c0864e
--- /dev/null
+++ b/x11/workrave/files/patch-backend_include_ICore.hh
@@ -0,0 +1,11 @@
+This is needed for compiling on FreeBSD >= 11.0.
+--- backend/include/ICore.hh.orig 2016-08-03 13:08:26 UTC
++++ backend/include/ICore.hh
+@@ -21,6 +21,7 @@
+ #define ICORE_HH
+
+ #include <string>
++#include <ctime>
+
+ #include "enum.h"
+
diff --git a/x11/workrave/files/patch-backends__src__unix__Makefile.in b/x11/workrave/files/patch-backends__src__unix__Makefile.in
deleted file mode 100644
index 52b14b116aa9..000000000000
--- a/x11/workrave/files/patch-backends__src__unix__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- backend/src/unix/Makefile.in.orig
-+++ backend/src/unix/Makefile.in
-@@ -388,7 +388,7 @@
- -DWORKRAVE_PKGDATADIR="\"${pkgdatadir}\"" \
- -D_XOPEN_SOURCE=600 \
- @WR_COMMON_INCLUDES@ \
-- @GLIB_CFLAGS@ @GTK_CFLAGS@ @GCONF_CFLAGS@
-+ @GLIB_CFLAGS@ @GTK_CFLAGS@ @GCONF_CFLAGS@ @GNOME2_CFLAGS@
-
- EXTRA_DIST = $(wildcard $(srcdir)/*.cc) $(wildcard $(srcdir)/*.rc)\
- $(wildcard $(srcdir)/*.hh) $(wildcard $(srcdir)/*.h) $(wildcard $(srcdir)/*.icc)
diff --git a/x11/workrave/files/patch-common_src_Locale.cc b/x11/workrave/files/patch-common_src_Locale.cc
new file mode 100644
index 000000000000..d13fd32da71c
--- /dev/null
+++ b/x11/workrave/files/patch-common_src_Locale.cc
@@ -0,0 +1,27 @@
+--- common/src/Locale.cc.orig 2016-05-11 16:14:20 UTC
++++ common/src/Locale.cc
+@@ -258,22 +258,8 @@ Locale::get_week_start()
+
+ #ifdef PLATFORM_OS_UNIX
+ union { unsigned int word; char *string; } langinfo;
+- gint week_1stday = 0;
+- gint first_weekday = 1;
+- guint week_origin;
+-
+- langinfo.string = nl_langinfo(_NL_TIME_FIRST_WEEKDAY);
+- first_weekday = langinfo.string[0];
+- langinfo.string = nl_langinfo(_NL_TIME_WEEK_1STDAY);
+- week_origin = langinfo.word;
+- if (week_origin == 19971130) /* Sunday */
+- week_1stday = 0;
+- else if (week_origin == 19971201) /* Monday */
+- week_1stday = 1;
+- else
+- g_warning ("Unknown value of _NL_TIME_WEEK_1STDAY.\n");
+-
+- week_start = (week_1stday + first_weekday - 1) % 7;
++ langinfo.string = nl_langinfo(DAY_1);
++ week_start = langinfo.string[0];
+ #endif
+
+ return week_start;
diff --git a/x11/workrave/files/patch-configure b/x11/workrave/files/patch-configure
deleted file mode 100644
index 0596b2241f71..000000000000
--- a/x11/workrave/files/patch-configure
+++ /dev/null
@@ -1,39 +0,0 @@
---- configure.orig
-+++ configure
-@@ -19237,36 +19237,6 @@
- enable_monitors="${enable_monitors}x11events"
- fi
-
-- loop=${enable_monitors},
--
-- while echo $loop | grep \, &> /dev/null
-- do
-- monitor=${loop%%\,*}
-- loop=${loop#*\,}
--
-- case "$monitor" in
-- record)
-- if test "x$have_xrecord" != "xyes" ; then
-- as_fn_error $? "record activity monitor not supported." "$LINENO" 5
-- fi
-- ;;
--
-- x11events)
-- ;;
--
-- screensaver)
-- if test "x$have_xscreensaver" != "xyes" ; then
-- as_fn_error $? "screensaver activity monitor not supported." "$LINENO" 5
-- fi
-- ;;
--
-- *)
-- as_fn_error $? "unknown activity monitor: $monitor" "$LINENO" 5
-- ;;
--
-- esac
-- done
--
-
- cat >>confdefs.h <<_ACEOF
- #define HAVE_MONITORS "$enable_monitors"
diff --git a/x11/workrave/files/patch-configure.ac b/x11/workrave/files/patch-configure.ac
new file mode 100644
index 000000000000..d3c181c4f945
--- /dev/null
+++ b/x11/workrave/files/patch-configure.ac
@@ -0,0 +1,97 @@
+--- configure.ac.orig 2016-05-11 16:14:20 UTC
++++ configure.ac
+@@ -417,8 +417,7 @@ then
+ with_cxx11=no
+ # Enable C++11 std if gtkmm >= 3.18.0
+ PKG_CHECK_MODULES(GTKMM, gtkmm-3.0 >= 3.18.0,
+- [ AX_CXX_COMPILE_STDCXX_11([noext])
+- with_cxx11=yes
++ [ with_cxx11=yes
+ ],
+ []
+ )
+@@ -447,36 +446,6 @@ then
+ enable_monitors="${enable_monitors}x11events"
+ fi
+
+- loop=${enable_monitors},
+-
+- while echo $loop | grep \, &> /dev/null
+- do
+- monitor=${loop%%\,*}
+- loop=${loop#*\,}
+-
+- case "$monitor" in
+- record)
+- if test "x$have_xrecord" != "xyes" ; then
+- AC_MSG_ERROR([record activity monitor not supported.])
+- fi
+- ;;
+-
+- x11events)
+- ;;
+-
+- screensaver)
+- if test "x$have_xscreensaver" != "xyes" ; then
+- AC_MSG_ERROR([screensaver activity monitor not supported.])
+- fi
+- ;;
+-
+- *)
+- AC_MSG_ERROR([unknown activity monitor: $monitor])
+- ;;
+-
+- esac
+- done
+-
+ AC_DEFINE_UNQUOTED(HAVE_MONITORS, "$enable_monitors", "Enabled activity monitors")
+
+ fi
+@@ -815,21 +784,11 @@ dnl
+ dnl GConf
+ dnl
+
++dnl Do not want
+ config_gconf=no
+-
+-if test "x$enable_gconf" != "xno" -a "x$config_gnome3" != "xyes"
+-then
+- PKG_CHECK_MODULES([GCONF],
+- [gconf-2.0 >= 2.31.1],
+- [config_gconf=yes
+- AC_DEFINE([HAVE_GCONF], , [Define if GConf is available])],
+- [if test "x$enable_gconf" = "xyes"; then
+- AC_MSG_ERROR([GConf development headers not found.])
+- fi])
+-fi
+-
+-AM_CONDITIONAL(HAVE_GCONF, test "x$config_gconf" = "xyes")
+-
++AC_SUBST([GCONF_CFLAGS], [])
++AC_SUBST([GCONF_LIBS], [])
++AM_CONDITIONAL(HAVE_GCONF, false)
+
+ dnl
+ dnl XML
+@@ -892,13 +851,6 @@ config_gstreamer=no
+
+ if test "x$enable_gstreamer" != "xno";
+ then
+- PKG_CHECK_MODULES([GSTREAMER],
+- [gstreamer-0.10],
+- [config_gstreamer=yes
+- AC_DEFINE(HAVE_GSTREAMER, 1, [Use GStreamer for playing sounds])], [ ])
+-
+- if test "x$config_gstreamer" != "xyes";
+- then
+ PKG_CHECK_MODULES([GSTREAMER],
+ [gstreamer-1.0],
+ [config_gstreamer=yes
+@@ -906,7 +858,6 @@ then
+ [if test "x$enable_gstreamer" = "xyes"; then
+ AC_MSG_ERROR([GStreamer development headers not found.])
+ fi])
+- fi
+ fi
+
+
diff --git a/x11/workrave/files/patch-frontend__common__src__Makefile.in b/x11/workrave/files/patch-frontend__common__src__Makefile.in
deleted file mode 100644
index 6d40ee1213bc..000000000000
--- a/x11/workrave/files/patch-frontend__common__src__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- frontend/common/src/Makefile.in.orig
-+++ frontend/common/src/Makefile.in
-@@ -418,7 +418,7 @@
- -I$(top_srcdir)/frontend/common/src/win32 \
- -I$(top_srcdir)/frontend/common/src/osx \
- @WR_COMMON_INCLUDES@ @WR_BACKEND_INCLUDES@ @PULSE_CFLAGS@ \
-- @GTK_CFLAGS@ @GLIB_CFLAGS@ @GSTREAMER_CFLAGS@ \
-+ @GTK_CFLAGS@ @GLIB_CFLAGS@ @GSTREAMER_CFLAGS@ @GNOME2_CFLAGS@ \
- -I$(top_srcdir)/common/win32/harpoon/include
-
- all: all-recursive
diff --git a/x11/workrave/files/patch-frontend_common_src_ScreenLockCommandline.cc b/x11/workrave/files/patch-frontend_common_src_ScreenLockCommandline.cc
new file mode 100644
index 000000000000..2dc8d2d70cee
--- /dev/null
+++ b/x11/workrave/files/patch-frontend_common_src_ScreenLockCommandline.cc
@@ -0,0 +1,11 @@
+--- frontend/common/src/ScreenLockCommandline.cc.orig 2016-05-11 16:14:20 UTC
++++ frontend/common/src/ScreenLockCommandline.cc
+@@ -27,6 +27,8 @@
+ #include <glib.h>
+ #endif
+
++#include <sys/wait.h>
++
+ #include "ScreenLockCommandline.hh"
+ #include "debug.hh"
+
diff --git a/x11/workrave/pkg-descr b/x11/workrave/pkg-descr
index 938a817991c4..ed9051b47cf5 100644
--- a/x11/workrave/pkg-descr
+++ b/x11/workrave/pkg-descr
@@ -1,10 +1,6 @@
Workrave is a program that assists in the recovery and prevention of
-Repetitive Strain Injury (RSI). The program frequently alerts you to
+Repetitive Strain Injury (RSI). The program frequently alerts you to
take micro-pauses, rest breaks and restricts you to your daily limit.
These can be customized and it stops the counter when you stop.
-The program can be run distributed on one or more PCs. All connected
-PCs share the same timing information. When you switch computers, you
-will still be asked to pause on time.
-
WWW: http://www.workrave.org/
diff --git a/x11/workrave/pkg-plist b/x11/workrave/pkg-plist
index a7cd05704abf..f2b3b1da6049 100644
--- a/x11/workrave/pkg-plist
+++ b/x11/workrave/pkg-plist
@@ -1,9 +1,13 @@
-%%NO_GNOME%%bin/workrave
-%%GNOME%%libdata/bonobo/servers/Workrave-Applet.server
-%%GNOME%%libexec/workrave-applet
-%%NO_GNOME%%share/applications/workrave.desktop
-%%NO_GNOME%%share/dbus-1/services/org.workrave.Workrave.service
-%%GNOME%%share/gnome-2.0/ui/GNOME_WorkraveApplet.xml
+bin/workrave
+lib/girepository-1.0/Workrave-1.0.typelib
+lib/libworkrave-private-1.0.a
+lib/libworkrave-private-1.0.so
+lib/libworkrave-private-1.0.so.0
+lib/libworkrave-private-1.0.so.0.0.0
+share/appdata/workrave.appdata.xml
+share/applications/workrave.desktop
+%%DBUS%%share/dbus-1/services/org.workrave.Workrave.service
+share/gir-1.0/Workrave-1.0.gir
share/icons/hicolor/128x128/apps/workrave.png
share/icons/hicolor/16x16/apps/workrave.png
share/icons/hicolor/24x24/apps/workrave.png