aboutsummaryrefslogtreecommitdiff
path: root/x11/x3270/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-12-16 09:07:41 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-12-16 09:07:41 +0000
commit8f7fc644d0bc1ef983242ff7ba0a4d6d0541e7de (patch)
tree1b64d7bdfdcb873fda3a3a25c78180d63c329f2b /x11/x3270/Makefile
parent11fc19071e9986aabbd4b9458e8faf017cdbaf5a (diff)
Notes
Diffstat (limited to 'x11/x3270/Makefile')
-rw-r--r--x11/x3270/Makefile33
1 files changed, 15 insertions, 18 deletions
diff --git a/x11/x3270/Makefile b/x11/x3270/Makefile
index 7a9007715d04..61f45afce783 100644
--- a/x11/x3270/Makefile
+++ b/x11/x3270/Makefile
@@ -6,23 +6,30 @@
#
PORTNAME= x3270
-PORTVERSION= 3.1.1.6
-CATEGORIES= x11
-MASTER_SITES= ${MASTER_SITE_XCONTRIB}
-MASTER_SITE_SUBDIR= applications
+PORTVERSION= 3.3.2p1
+CATEGORIES= x11 net
+MASTER_SITES= http://x3270.bgp.nu/download/
+EXTRACT_SUFX= .tgz
+DISTFILES= ${PORTNAME}-332p1${EXTRACT_SUFX}
-MAINTAINER= onatan@gmail.com
+MAINTAINER= Yonatan@xpert.com
COMMENT= 3270 Terminal emulator
BUILD_DEPENDS= bdftopcf:${X_CLIENTS_PORT}
RUN_DEPENDS= mkfontdir:${X_CLIENTS_PORT}
USE_IMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --without-pr3287 --with-fontdir=local --disable-dbcs
+.if defined(WITHOUT_OPENSSL)
+CONFIGURE_ARGS+= --disable-ssl
+.else
+USE_OPENSSL= yes
+.endif
-WRKSRC= ${WRKDIR}/x3270-3.1.1
-MAN1= x3270.1 x3270if.1 x3270-script.1 ibm_hosts.1
+WRKSRC= ${WRKDIR}/x3270-3.3
+MAN1= x3270.1
MANCOMPRESSED= yes
-USE_REINPLACE= yes
pre-install:
.if !exists(${X11BASE}/lib/X11/fonts/local)
@@ -33,14 +40,4 @@ pre-install:
@${ECHO} "*********************************************************"
.endif
-#
-# This patch is to make sure that mkversion.sh can be ran on FreeBSD 4-STABLE
-# which will get $(CLIENTENVSETUP) in its CC macro.
-#
-post-configure:
- ${REINPLACE_CMD} \
- -e 's,sh \./mkversion\.sh $$(CC),$$(CLIENTENVSETUP) sh ./mkversion.sh %%CC%%,' \
- -e 's,%%CC%%,${CC},' \
- ${WRKSRC}/Makefile
-
.include <bsd.port.mk>