aboutsummaryrefslogtreecommitdiff
path: root/x11/x3270
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
commit932db7c46c9a269808dfa67ea02746b350c194d8 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /x11/x3270
parentb9b5e71f19dfde1a969d42e0660cc786432b3500 (diff)
downloadports-932db7c46c9a269808dfa67ea02746b350c194d8.tar.gz
ports-932db7c46c9a269808dfa67ea02746b350c194d8.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Notes
Notes: svn path=/head/; revision=321957
Diffstat (limited to 'x11/x3270')
-rw-r--r--x11/x3270/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/x11/x3270/Makefile b/x11/x3270/Makefile
index 221fdbf4206c..a11fd4264aff 100644
--- a/x11/x3270/Makefile
+++ b/x11/x3270/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: x3270
-# Date created: 31 January 1995
-# Whom: janek
-#
+# Created by: janek
# $FreeBSD$
-#
PORTNAME= x3270
PORTVERSION= 3.3.10
@@ -18,8 +14,7 @@ BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
-USE_IMAKE= yes
-USES= iconv
+USES= iconv imake:env
USE_XORG= ice sm x11 xaw xext xmu xt
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-fontdir=${PREFIX}/lib/X11/fonts/local --disable-dbcs