aboutsummaryrefslogtreecommitdiff
path: root/x11/xautomation
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-09-24 22:45:30 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-09-24 22:45:30 +0000
commit3f70906f3764bc22c45fbffa40ff2e0f7dfb09e6 (patch)
tree696d5e8cf6ec3659b1d8f7b4d8f21cc973635ba2 /x11/xautomation
parent45394914a51934f09364705e7534bdcf9bff237a (diff)
downloadports-3f70906f3764bc22c45fbffa40ff2e0f7dfb09e6.tar.gz
ports-3f70906f3764bc22c45fbffa40ff2e0f7dfb09e6.zip
Notes
Diffstat (limited to 'x11/xautomation')
-rw-r--r--x11/xautomation/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/x11/xautomation/Makefile b/x11/xautomation/Makefile
index cb4c04d4b557..54fe524d7381 100644
--- a/x11/xautomation/Makefile
+++ b/x11/xautomation/Makefile
@@ -6,10 +6,12 @@ PORTVERSION= 1.07
CATEGORIES= x11
MASTER_SITES= http://hoopajoo.net/static/projects/
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Control X from the command line for scripts
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LICENSE= GPLv2
+
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
USE_XORG= xtst
GNU_CONFIGURE= yes
@@ -23,5 +25,17 @@ MAN1= pat2ppm.1 patextract.1 png2pat.1 rgb2pat.1 \
visgrep.1 xmousepos.1 xte.1
MAN7= xautomation.7
+PORTDOCS= AUTHORS ChangeLog README
+
+OPTIONS_DEFINE= DOCS
+
NO_STAGE= yes
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>