aboutsummaryrefslogtreecommitdiff
path: root/x11/xbanner
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>1999-01-20 08:18:57 +0000
committerSeiichirou Hiraoka <flathill@FreeBSD.org>1999-01-20 08:18:57 +0000
commit7fe2cd9939a366c2ac6a612e03c6b42e07da7c68 (patch)
tree646f41e8dfa5e82b1a056ad7b5c1ba9a63a4f895 /x11/xbanner
parentf27be325bdd031ee5e715c1a75814b8e56e5eec8 (diff)
downloadports-7fe2cd9939a366c2ac6a612e03c6b42e07da7c68.tar.gz
ports-7fe2cd9939a366c2ac6a612e03c6b42e07da7c68.zip
Notes
Diffstat (limited to 'x11/xbanner')
-rw-r--r--x11/xbanner/Makefile32
-rw-r--r--x11/xbanner/distinfo1
-rw-r--r--x11/xbanner/files/patch-aa110
-rw-r--r--x11/xbanner/files/patch-ab19
-rw-r--r--x11/xbanner/pkg-comment1
-rw-r--r--x11/xbanner/pkg-descr12
-rw-r--r--x11/xbanner/pkg-plist25
7 files changed, 200 insertions, 0 deletions
diff --git a/x11/xbanner/Makefile b/x11/xbanner/Makefile
new file mode 100644
index 000000000000..5bb522fffeb1
--- /dev/null
+++ b/x11/xbanner/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: xbanner
+# Version required: 1.31
+# Date created: 13 Jan 1999
+# Whom: giffunip@asme.org
+#
+# $Id: Exp $
+#
+
+DISTNAME= XBanner1.31
+PKGNAME= xbanner-1.31
+CATEGORIES= x11
+MASTER_SITES= ftp://physics.fullerton.edu/pub/Linux/XBanner/ \
+ ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR=X11/xutils
+
+MAINTAINER= ports@FreeBSD.ORG
+
+USE_X_PREFIX= yes
+#USE_IMAKE= yes
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/samples/XBanner.ad \
+ $(X11BASE)/lib/X11/app-defaults/XBanner
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/XBanner
+ $(CP) ${WRKSRC}/QuickStart ${PREFIX}/share/doc/XBanner
+ ${CP} ${WRKSRC}/docs/* ${PREFIX}/share/doc/XBanner
+ ${MKDIR} ${PREFIX}/share/examples/XBanner
+ $(CP) ${WRKSRC}/samples/_other_ideas/* ${PREFIX}/share/examples/XBanner
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/xbanner/distinfo b/x11/xbanner/distinfo
new file mode 100644
index 000000000000..fc7a8e34ddba
--- /dev/null
+++ b/x11/xbanner/distinfo
@@ -0,0 +1 @@
+MD5 (XBanner1.31.tar.gz) = 4baae32c84e126b9bf5f3576c4e3242d
diff --git a/x11/xbanner/files/patch-aa b/x11/xbanner/files/patch-aa
new file mode 100644
index 000000000000..fa54317e5496
--- /dev/null
+++ b/x11/xbanner/files/patch-aa
@@ -0,0 +1,110 @@
+*** Makefile.orig Mon May 12 10:55:59 1997
+--- Makefile Tue Jan 19 22:27:09 1999
+***************
+*** 6,30 ****
+
+ .SUFFIXES: .c .o
+
+! CC =gcc
+ RM =rm
+ LN =ln
+! INSTALL =install
+ CP =cp
+ TAR =tar
+ GZIP =gzip
+
+ # Binary directory for make install
+! BINDIR =/usr/local/bin/X11
+
+ # Library directories for Linux
+! XLIBDIR =/usr/X11R6/lib
+
+ # Include directory for gcc (if you get X11/Xlib.h: file not found)
+! #INCDIR =-I/usr/X11R6/include
+
+ # Library directories for the Ultrix (probably most Unixes)
+! #XLIBDIR =/usr/lib/X11
+
+ # Comment out the following line if you do not have the XPM library.
+ XPM =-DHAS_XPM
+--- 6,30 ----
+
+ .SUFFIXES: .c .o
+
+! CC ?=gcc
+ RM =rm
+ LN =ln
+! INSTALL ?=install
+ CP =cp
+ TAR =tar
+ GZIP =gzip
+
+ # Binary directory for make install
+! BINDIR =$(PREFIX)/libexec
+
+ # Library directories for Linux
+! XLIBDIR =$(X11BASE)/lib
+
+ # Include directory for gcc (if you get X11/Xlib.h: file not found)
+! INCDIR =-I$(X11BASE)/include
+
+ # Library directories for the Ultrix (probably most Unixes)
+! XLIBDIR =$(X11BASE)/lib
+
+ # Comment out the following line if you do not have the XPM library.
+ XPM =-DHAS_XPM
+***************
+*** 34,40 ****
+ $(CC) $(INCDIR) $(CFLAGS) $(XPM) -c $*.c
+
+ # Linux CFLAGS (actually generic gcc)
+! CFLAGS=-Wall -O2
+
+ # Want static binaries?
+ #CFLAGS=-Wall -O2 -static
+--- 34,40 ----
+ $(CC) $(INCDIR) $(CFLAGS) $(XPM) -c $*.c
+
+ # Linux CFLAGS (actually generic gcc)
+! CFLAGS+= -O2
+
+ # Want static binaries?
+ #CFLAGS=-Wall -O2 -static
+***************
+*** 48,54 ****
+ # Most Linux users won't be troubled by this. Actually almost nobody will
+ # be troubled by this. It just might save me a couple of emails...
+ # Just change it to wherever your libX11.a resides.
+! LDFLAGS=-L$(XLIBDIR)
+
+ all: xbanner freetemp random_effect xb_check
+
+--- 48,54 ----
+ # Most Linux users won't be troubled by this. Actually almost nobody will
+ # be troubled by this. It just might save me a couple of emails...
+ # Just change it to wherever your libX11.a resides.
+! LDFLAGS+=-L$(XLIBDIR)
+
+ all: xbanner freetemp random_effect xb_check
+
+***************
+*** 71,79 ****
+ $(CC) $(CFLAGS) -o xb_check xb_check.o
+
+ install: freetemp xbanner xb_check
+! $(INSTALL) --strip --mode "0755" --owner root --group bin freetemp $(BINDIR)/freetemp
+! $(INSTALL) --strip --mode "0755" --owner root --group bin xbanner $(BINDIR)/xbanner
+! $(INSTALL) --strip --mode "0755" --owner root --group bin xb_check $(BINDIR)/xb_check
+
+ strip: exe
+ strip xbanner freetemp xb_check random_effect
+--- 71,79 ----
+ $(CC) $(CFLAGS) -o xb_check xb_check.o
+
+ install: freetemp xbanner xb_check
+! $(INSTALL) -cs -g bin -m "0755" -o root freetemp $(BINDIR)/freetemp
+! $(INSTALL) -cs -g bin -m "0755" -o root xbanner $(BINDIR)/xbanner
+! $(INSTALL) -cs -g bin -m "0755" -o root xb_check $(BINDIR)/xb_check
+
+ strip: exe
+ strip xbanner freetemp xb_check random_effect
diff --git a/x11/xbanner/files/patch-ab b/x11/xbanner/files/patch-ab
new file mode 100644
index 000000000000..ea2ecff0a56e
--- /dev/null
+++ b/x11/xbanner/files/patch-ab
@@ -0,0 +1,19 @@
+*** xb_check.c.orig Mon Jan 18 23:27:31 1999
+--- xb_check.c Mon Jan 18 23:31:08 1999
+***************
+*** 145,151 ****
+ }
+
+ /* boolean that checks if a string is numeric */
+! int isnumber(char *s)
+ {
+ if(atoi(s)==0 && *s!='0')
+ return 0;
+--- 145,151 ----
+ }
+
+ /* boolean that checks if a string is numeric */
+! int isnumb(char *s)
+ {
+ if(atoi(s)==0 && *s!='0')
+ return 0;
diff --git a/x11/xbanner/pkg-comment b/x11/xbanner/pkg-comment
new file mode 100644
index 000000000000..181be4a0c9ba
--- /dev/null
+++ b/x11/xbanner/pkg-comment
@@ -0,0 +1 @@
+make your XDM login screen look beautiful
diff --git a/x11/xbanner/pkg-descr b/x11/xbanner/pkg-descr
new file mode 100644
index 000000000000..d9418b037980
--- /dev/null
+++ b/x11/xbanner/pkg-descr
@@ -0,0 +1,12 @@
+The purpose of XBanner is to make the XDM login screen beautiful, as opposed
+to the dull and gray login screen that the vanilla XDM gives. The idea came
+from Digital's login screen which displays the Digital logo nicely. I use
+Linux and wanted to run XDM, but XDM's login screen was such a boring thing,
+so I wrote XBanner!
+
+Amit Margalit
+27 Bar-Ilan st. Apt#10
+Ra'anana, 43700
+ISRAEL
+
+Email - amitm@netvision.net.il
diff --git a/x11/xbanner/pkg-plist b/x11/xbanner/pkg-plist
new file mode 100644
index 000000000000..db009efd85fe
--- /dev/null
+++ b/x11/xbanner/pkg-plist
@@ -0,0 +1,25 @@
+libexec/freetemp
+libexec/xbanner
+libexec/xb_check
+share/doc/XBanner/COPYING-2.0
+share/doc/XBanner/Changes.txt
+share/doc/XBanner/Credits.txt
+share/doc/XBanner/QuickStart
+share/doc/XBanner/README.DEC_Ultrix
+share/doc/XBanner/README.DEC_Unix
+share/doc/XBanner/README.Debian
+share/doc/XBanner/Resource_Reference.html
+share/doc/XBanner/XBanner_Users_Manual.html
+share/doc/XBanner/email.gif
+share/doc/XBanner/fonttips.html
+share/doc/XBanner/index.html
+share/doc/XBanner/red_line.gif
+share/doc/XBanner/rnd_doc.html
+share/doc/XBanner/stars.gif
+share/doc/XBanner/xb_check.html
+share/examples/XBanner/00_My_Comments
+share/examples/XBanner/Evgeny_Stambulchik
+share/examples/XBanner/FatText_Sky
+share/examples/XBanner/FgGrad_Idea_2
+share/examples/XBanner/Just_an_Idea
+share/examples/XBanner/My_Home_Setup.tar