aboutsummaryrefslogtreecommitdiff
path: root/x11/xbindkeys/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-05 01:57:50 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-05 01:57:50 +0000
commit09eadbd1194edc9f9fb94365a3f1d2a793748112 (patch)
treec5d10c0c17b7849d0e14d0909de5cefd71744daa /x11/xbindkeys/Makefile
parentc309bdfc224d99c54d33614dedfc4c6fbde4db32 (diff)
downloadports-09eadbd1194edc9f9fb94365a3f1d2a793748112.tar.gz
ports-09eadbd1194edc9f9fb94365a3f1d2a793748112.zip
Notes
Diffstat (limited to 'x11/xbindkeys/Makefile')
-rw-r--r--x11/xbindkeys/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/x11/xbindkeys/Makefile b/x11/xbindkeys/Makefile
index 310c8b3f7fc1..733371b09e17 100644
--- a/x11/xbindkeys/Makefile
+++ b/x11/xbindkeys/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= xbindkeys
-PORTVERSION= 1.6.5
+PORTVERSION= 1.7.0
CATEGORIES= x11
MASTER_SITES= http://hocwp.free.fr/xbindkeys/
@@ -16,8 +16,8 @@ COMMENT= Allows you to launch shell commands under X with your keyboard
USE_XLIB= yes
USE_REINPLACE= yes
+USE_GNOME= gnometarget
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= xbindkeys.1
@@ -32,12 +32,19 @@ CONFIGURE_ARGS+= --disable-tk
PLIST_SUB+= WITH_GUI="@comment "
.endif
+.if defined(WITH_GUILE)
+LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
+CONFIGURE_ENV+= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+.else
+CONFIGURE_ARGS+= --disable-guile
+.endif
+
pre-everything::
-.if !defined(WITH_GUI)
@${ECHO_MSG} ""
@${ECHO_MSG} " Define WITH_GUI to install xbindkeys_show (requires Tk)"
+ @${ECHO_MSG} " Define WITH_GUILE to allow guile configuration file style"
@${ECHO_MSG} ""
-.endif
post-patch:
@${REINPLACE_CMD} -e 's| wish | ${WISH} |g' ${WRKSRC}/xbindkeys_show