aboutsummaryrefslogtreecommitdiff
path: root/x11/xcb-util-cursor/Makefile
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-08-07 23:39:28 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-08-07 23:39:28 +0000
commit8dad23a925f0017e4d29d43de6f7da708d0af565 (patch)
tree150b13183791093176332deeb3c20ef659ad2efb /x11/xcb-util-cursor/Makefile
parent9142267090fa352b0de3013b2f0e15c4d685c858 (diff)
Add a new port xcb-util-cursor, XCB replacement for libXcursor.
Notes
Notes: svn path=/head/; revision=324373
Diffstat (limited to 'x11/xcb-util-cursor/Makefile')
-rw-r--r--x11/xcb-util-cursor/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11/xcb-util-cursor/Makefile b/x11/xcb-util-cursor/Makefile
new file mode 100644
index 000000000000..c82962b7895d
--- /dev/null
+++ b/x11/xcb-util-cursor/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= xcb-util-cursor
+PORTVERSION= 0.0.99
+CATEGORIES= x11
+MASTER_SITES= http://xcb.freedesktop.org/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= XCB cursor library
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcb-util.pc:${PORTSDIR}/x11/xcb-util \
+ ${LOCALBASE}/libdata/pkgconfig/xcb-renderutil.pc:${PORTSDIR}/x11/xcb-util-renderutil \
+ ${LOCALBASE}/libdata/pkgconfig/xcb-image.pc:${PORTSDIR}/x11/xcb-util-image
+
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcb-util.pc:${PORTSDIR}/x11/xcb-util \
+ ${LOCALBASE}/libdata/pkgconfig/xcb-renderutil.pc:${PORTSDIR}/x11/xcb-util-renderutil \
+ ${LOCALBASE}/libdata/pkgconfig/xcb-image.pc:${PORTSDIR}/x11/xcb-util-image
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_XORG= xcb xorg-macros
+
+GNU_CONFIGURE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|$${libdir}/pkgconfig|$${prefix}/libdata/pkgconfig|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>