aboutsummaryrefslogtreecommitdiff
path: root/x11/xcb-util-keysyms
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2012-01-15 12:46:11 +0000
committerRenato Botelho <garga@FreeBSD.org>2012-01-15 12:46:11 +0000
commit26782807ea43e2c206b1913146bae222638a7a25 (patch)
tree907d65f8a6a2956c487c9ebe0b8208501790549a /x11/xcb-util-keysyms
parent17a205e830c33ab5786168a8bcbc8ec7312e6e41 (diff)
downloadports-26782807ea43e2c206b1913146bae222638a7a25.tar.gz
ports-26782807ea43e2c206b1913146bae222638a7a25.zip
Notes
Diffstat (limited to 'x11/xcb-util-keysyms')
-rw-r--r--x11/xcb-util-keysyms/Makefile34
-rw-r--r--x11/xcb-util-keysyms/distinfo2
-rw-r--r--x11/xcb-util-keysyms/pkg-descr11
-rw-r--r--x11/xcb-util-keysyms/pkg-plist7
4 files changed, 54 insertions, 0 deletions
diff --git a/x11/xcb-util-keysyms/Makefile b/x11/xcb-util-keysyms/Makefile
new file mode 100644
index 000000000000..570871dbc322
--- /dev/null
+++ b/x11/xcb-util-keysyms/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xcb-util-keysyms
+# Date created: 2011-12-16
+# Whom: garga
+#
+# $FreeBSD$
+#
+
+PORTNAME= xcb-util-keysyms
+PORTVERSION= 0.3.8
+CATEGORIES= x11
+MASTER_SITES= http://xcb.freedesktop.org/dist/
+
+MAINTAINER= garga@FreeBSD.org
+COMMENT= Standard X key constants and conversion to/from keycodes
+
+LIB_DEPENDS= xcb.2:${PORTSDIR}/x11/libxcb \
+ xcb-util.0:${PORTSDIR}/x11/xcb-util
+#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+#USE_XORG= xau xdmcp
+#USE_AUTOTOOLS= libtool
+
+GNU_CONFIGURE= yes
+#CONFIGURE_ENV= GPERF="${LOCALBASE}/bin/gperf"
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|$${libdir}/pkgconfig|$${prefix}/libdata/pkgconfig|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/x11/xcb-util-keysyms/distinfo b/x11/xcb-util-keysyms/distinfo
new file mode 100644
index 000000000000..1c82d88491de
--- /dev/null
+++ b/x11/xcb-util-keysyms/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xcb-util-keysyms-0.3.8.tar.bz2) = 913d32f7afe380c580da7636ee13f2728790237bb5c03def536363f552686121
+SIZE (xcb-util-keysyms-0.3.8.tar.bz2) = 252726
diff --git a/x11/xcb-util-keysyms/pkg-descr b/x11/xcb-util-keysyms/pkg-descr
new file mode 100644
index 000000000000..cd1882d987fe
--- /dev/null
+++ b/x11/xcb-util-keysyms/pkg-descr
@@ -0,0 +1,11 @@
+The xcb-util module provides a number of libraries which sit on top of
+libxcb, the core X protocol library, and some of the extension
+libraries. These experimental libraries provide convenience functions
+and interfaces which make the raw X protocol more usable. Some of the
+libraries also provide client-side code which is not strictly part of
+the X protocol but which have traditionally been provided by Xlib.
+
+Keysyms module is the Starndard X key constants and conversions to/from
+keycodes.
+
+WWW: http://xcb.freedesktop.org/
diff --git a/x11/xcb-util-keysyms/pkg-plist b/x11/xcb-util-keysyms/pkg-plist
new file mode 100644
index 000000000000..995a2e51e97e
--- /dev/null
+++ b/x11/xcb-util-keysyms/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+include/xcb/xcb_keysyms.h
+lib/libxcb-keysyms.so.1
+lib/libxcb-keysyms.so
+lib/libxcb-keysyms.la
+lib/libxcb-keysyms.a
+libdata/pkgconfig/xcb-keysyms.pc