aboutsummaryrefslogtreecommitdiff
path: root/x11/xcb-util-renderutil
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2012-01-15 12:46:11 +0000
committerRenato Botelho <garga@FreeBSD.org>2012-01-15 12:46:11 +0000
commit26782807ea43e2c206b1913146bae222638a7a25 (patch)
tree907d65f8a6a2956c487c9ebe0b8208501790549a /x11/xcb-util-renderutil
parent17a205e830c33ab5786168a8bcbc8ec7312e6e41 (diff)
Notes
Diffstat (limited to 'x11/xcb-util-renderutil')
-rw-r--r--x11/xcb-util-renderutil/Makefile34
-rw-r--r--x11/xcb-util-renderutil/distinfo2
-rw-r--r--x11/xcb-util-renderutil/pkg-descr10
-rw-r--r--x11/xcb-util-renderutil/pkg-plist7
4 files changed, 53 insertions, 0 deletions
diff --git a/x11/xcb-util-renderutil/Makefile b/x11/xcb-util-renderutil/Makefile
new file mode 100644
index 000000000000..8acdd8e97696
--- /dev/null
+++ b/x11/xcb-util-renderutil/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xcb-util-renderutil
+# Date created: 2011-12-16
+# Whom: garga
+#
+# $FreeBSD$
+#
+
+PORTNAME= xcb-util-renderutil
+PORTVERSION= 0.3.8
+CATEGORIES= x11
+MASTER_SITES= http://xcb.freedesktop.org/dist/
+
+MAINTAINER= garga@FreeBSD.org
+COMMENT= Convenience functions for the Render extension
+
+LIB_DEPENDS= xcb.2:${PORTSDIR}/x11/libxcb \
+ xcb-util.0:${PORTSDIR}/x11/xcb-util
+#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+#USE_XORG= xau xdmcp
+#USE_AUTOTOOLS= libtool
+
+GNU_CONFIGURE= yes
+#CONFIGURE_ENV= GPERF="${LOCALBASE}/bin/gperf"
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|$${libdir}/pkgconfig|$${prefix}/libdata/pkgconfig|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/x11/xcb-util-renderutil/distinfo b/x11/xcb-util-renderutil/distinfo
new file mode 100644
index 000000000000..17e452dfc8e9
--- /dev/null
+++ b/x11/xcb-util-renderutil/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xcb-util-renderutil-0.3.8.tar.bz2) = 9789a5c55728fa7bae374d9fdf1c61095869bdc68561911760879095644c7452
+SIZE (xcb-util-renderutil-0.3.8.tar.bz2) = 257492
diff --git a/x11/xcb-util-renderutil/pkg-descr b/x11/xcb-util-renderutil/pkg-descr
new file mode 100644
index 000000000000..e36d33bfc20f
--- /dev/null
+++ b/x11/xcb-util-renderutil/pkg-descr
@@ -0,0 +1,10 @@
+The xcb-util module provides a number of libraries which sit on top of
+libxcb, the core X protocol library, and some of the extension
+libraries. These experimental libraries provide convenience functions
+and interfaces which make the raw X protocol more usable. Some of the
+libraries also provide client-side code which is not strictly part of
+the X protocol but which have traditionally been provided by Xlib.
+
+Renderutil module s Convenience functions for the Render extension.
+
+WWW: http://xcb.freedesktop.org/
diff --git a/x11/xcb-util-renderutil/pkg-plist b/x11/xcb-util-renderutil/pkg-plist
new file mode 100644
index 000000000000..3c68e1416357
--- /dev/null
+++ b/x11/xcb-util-renderutil/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+include/xcb/xcb_renderutil.h
+lib/libxcb-render-util.so.0
+lib/libxcb-render-util.so
+lib/libxcb-render-util.la
+lib/libxcb-render-util.a
+libdata/pkgconfig/xcb-renderutil.pc