aboutsummaryrefslogtreecommitdiff
path: root/x11/xcb-util
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-10-28 02:28:58 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-10-28 02:28:58 +0000
commit3acbc0614dfc0018048a3df52a2e3b74fe185bb8 (patch)
tree561206d4b777f3bffc1c7750dfc814a29c227528 /x11/xcb-util
parent325f5ca19943bfc0f6b346ddd1880cd533ff1f14 (diff)
downloadports-3acbc0614dfc0018048a3df52a2e3b74fe185bb8.tar.gz
ports-3acbc0614dfc0018048a3df52a2e3b74fe185bb8.zip
Notes
Diffstat (limited to 'x11/xcb-util')
-rw-r--r--x11/xcb-util/Makefile1
-rw-r--r--x11/xcb-util/files/patch-icccm-icccm.c20
2 files changed, 21 insertions, 0 deletions
diff --git a/x11/xcb-util/Makefile b/x11/xcb-util/Makefile
index e36864bf491f..ef89f3d7e8cc 100644
--- a/x11/xcb-util/Makefile
+++ b/x11/xcb-util/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xcb-util
PORTVERSION= 0.3.6
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://xcb.freedesktop.org/dist/
diff --git a/x11/xcb-util/files/patch-icccm-icccm.c b/x11/xcb-util/files/patch-icccm-icccm.c
new file mode 100644
index 000000000000..508c26a1f030
--- /dev/null
+++ b/x11/xcb-util/files/patch-icccm-icccm.c
@@ -0,0 +1,20 @@
+--- icccm/icccm.c.orig 2009-08-24 11:47:36.000000000 +0300
++++ icccm/icccm.c 2009-10-21 21:01:52.000000000 +0300
+@@ -627,15 +627,13 @@
+ xcb_get_wm_hints_from_reply(xcb_wm_hints_t *hints,
+ xcb_get_property_reply_t *reply)
+ {
+- if(!reply)
++ if(!reply || reply->type != WM_HINTS || reply->format != 32)
+ return 0;
+
+ int length = xcb_get_property_value_length(reply);
+ int num_elem = length / (reply->format / 8);
+
+- if (reply->type != WM_HINTS
+- || reply->format != 32
+- || num_elem < XCB_NUM_WM_HINTS_ELEMENTS - 1)
++ if(num_elem < XCB_NUM_WM_HINTS_ELEMENTS - 1)
+ return 0;
+
+ memcpy(hints, (xcb_size_hints_t *) xcb_get_property_value(reply), length);