aboutsummaryrefslogtreecommitdiff
path: root/x11/xcm/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2017-08-02 22:31:11 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2017-08-02 22:31:11 +0000
commite615cf2b482b2c052ecc26154204c8ebe045391d (patch)
tree1308b3974e0327a43c8a5164996293019d913b71 /x11/xcm/Makefile
parent00b8d8ca998cb55bf891d546a17a52eba1df24aa (diff)
Notes
Diffstat (limited to 'x11/xcm/Makefile')
-rw-r--r--x11/xcm/Makefile23
1 files changed, 17 insertions, 6 deletions
diff --git a/x11/xcm/Makefile b/x11/xcm/Makefile
index bd5c04f0790d..5d9c0cd17a12 100644
--- a/x11/xcm/Makefile
+++ b/x11/xcm/Makefile
@@ -1,22 +1,33 @@
# $FreeBSD$
PORTNAME= xcm
-PORTVERSION= 0.5.3
+PORTVERSION= 0.5.4
CATEGORIES= x11
-MASTER_SITES= SF/oyranos/Xcm
MAINTAINER= bsam@FreeBSD.org
COMMENT= X Color Management tools
-LIB_DEPENDS= libXcm.so:x11/libXcm
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/docs/COPYING
+
+LIB_DEPENDS= libXcm.so:x11/libXcm \
+ libOyranos.so:graphics/oyranos
+
+USE_GITHUB= yes
+GH_ACCOUNT= oyranos-cms
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --mandir=${PREFIX}/man
+USES= pkgconfig
+USE_XORG= x11 xfixes xmu xt
-XORG_CAT= app
# xcm should be added to XORG_MODULES at /usr/ports/Mk/bsd.xorg.mk
# and LIB_DEPENDS is replaced by the following line:
#USE_XORG= xcm
-PLIST_FILES= bin/xcm bin/xcmedid bin/xcmevents man/man1/xcm.1.gz \
+PLIST_FILES= bin/xcm bin/xcmedid bin/xcmevents bin/xcmhextobin \
+ man/man1/xcm.1.gz \
man/man1/xcmddc.1.gz man/man1/xcmedid.1.gz \
- man/man1/xcmevents.1.gz
+ man/man1/xcmevents.1.gz man/man1/xcmhextobin.1.gz
+PORTDOCS= *
.include <bsd.port.mk>