aboutsummaryrefslogtreecommitdiff
path: root/x11/xdialog/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-01-08 23:26:48 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-01-08 23:26:48 +0000
commite5020479d7db52353c1b2630984aa74e6487ca55 (patch)
tree2f90ab7ef29c797276b686c4ca66cdc89ce8e975 /x11/xdialog/Makefile
parentf29bf497e5fbe0b1c9864cebd3780b3a167c1170 (diff)
Notes
Diffstat (limited to 'x11/xdialog/Makefile')
-rw-r--r--x11/xdialog/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11/xdialog/Makefile b/x11/xdialog/Makefile
new file mode 100644
index 000000000000..a4a753c92392
--- /dev/null
+++ b/x11/xdialog/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: xdialog
+# Date created: Jan 8, 2001
+# Whom: Ying-Chieh Liao <ijliao@csie.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xdialog
+PORTVERSION= 1.5.0
+CATEGORIES= x11
+MASTER_SITES= http://xdialog.free.fr/
+DISTNAME= ${PORTNAME:S/x/X/}-${PORTVERSION}
+
+MAINTAINER= ijliao@csie.nctu.edu.tw
+
+USE_BZIP2= yes
+USE_GTK= yes
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+.if defined(NOPORTDOCS)
+NODOCS= "@comment "
+.endif
+
+PLIST_SUB= NOPORTDOCS=${NODOCS}
+
+.if defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${PREFIX}/share/${PORTNAME}
+ ${CP} ${WRKSRC}/html/* ${PREFIX}/share/${PORTNAME}
+.endif
+
+.include <bsd.port.mk>