aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-screensaver
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2018-11-26 14:08:20 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2018-11-26 14:08:20 +0000
commit2eaa31ec1d34d850f172713ee2a2275d2a482848 (patch)
tree403e68c043b537d5dca8e5252b9fb97068645256 /x11/xfce4-screensaver
parente2e875bfb436bc95f57211438ec3cfa580567f64 (diff)
downloadports-2eaa31ec1d34d850f172713ee2a2275d2a482848.tar.gz
ports-2eaa31ec1d34d850f172713ee2a2275d2a482848.zip
Notes
Diffstat (limited to 'x11/xfce4-screensaver')
-rw-r--r--x11/xfce4-screensaver/Makefile80
-rw-r--r--x11/xfce4-screensaver/distinfo3
-rw-r--r--x11/xfce4-screensaver/files/xfce-screensaver.pam2
-rw-r--r--x11/xfce4-screensaver/pkg-descr6
-rw-r--r--x11/xfce4-screensaver/pkg-plist41
5 files changed, 132 insertions, 0 deletions
diff --git a/x11/xfce4-screensaver/Makefile b/x11/xfce4-screensaver/Makefile
new file mode 100644
index 000000000000..0e7d37feee70
--- /dev/null
+++ b/x11/xfce4-screensaver/Makefile
@@ -0,0 +1,80 @@
+# $FreeBSD$
+
+PORTNAME= xfce4-screensaver
+PORTVERSION= 0.1.3
+CATEGORIES= x11 xfce
+#MASTER_SITES= XFCE/src/apps/${PORTNAME}/${PORTVERSION:R}
+#DIST_SUBDIR= xfce4
+
+MAINTAINER= xfce@FreeBSD.org
+COMMENT= Xfce 4 screen saver and locker
+
+LICENSE= GPLv2 LGPL20
+LICENSE_COMB= dual
+LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
+LICENSE_FILE_LGPL20= ${WRKSRC}/COPYING.LIB
+
+BUILD_DEPENDS= xdt-autogen:devel/xfce4-dev-tools
+LIB_DEPENDS= libdbus-1.so:devel/dbus \
+ libdbus-glib-1.so:devel/dbus-glib \
+ libnotify.so:devel/libnotify \
+ libstartup-notification-1.so:x11/startup-notification \
+ libxklavier.so:x11/libxklavier
+
+USES= gettext-tools gmake pkgconfig tar:bzip2 xfce:gtk3
+USE_GL= gl
+USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 intltool
+USE_XFCE= garcon libexo libutil
+USE_XORG= ice sm x11 xext xrandr xscrnsaver xxf86vm
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-xscreensaverdir=${XSCREENSAVER_DIR} \
+ --with-xscreensaverhackdir=${LOCALBASE}/bin/xscreensaver-hacks \
+ --with-console-kit=yes \
+ --with-systemd=no \
+ --enable-maintainer-mode
+
+XSCREENSAVER_DIR= ${LOCALBASE}/share/xscreensaver/config
+SCREENSAVER_DIR= share/applications/screensavers
+
+USE_GITHUB= yes
+GH_ACCOUNT= xfce-mirror
+GH_TAGNAME= cb0d647
+
+OPTIONS_DEFINE= NLS PAM XSCREENSAVER
+OPTIONS_DEFAULT=PAM
+PAM_DESC= Pluggable Authentication Module support
+XSCREENSAVER_DESC= Use xscreensaver hacks
+
+OPTIONS_SUB= yes
+
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext-runtime
+
+PAM_RUN_DEPENDS= pam_helper:security/pam_helper
+PAM_CONFIGURE_ON= --enable-authentication-scheme=helper \
+ --with-passwd-helper=${LOCALBASE}/bin/pam_helper
+PAM_CONFIGURE_OFF= --disable-pam
+
+XSCREENSAVER_RUN_DEPENDS= xscreensaver-gnome-hacks>=0:x11/xscreensaver-gnome-hacks
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug=yes
+.endif
+
+pre-configure:
+ (cd ${WRKSRC} && ./autogen.sh)
+
+post-patch-PAM-on:
+ @${REINPLACE_CMD} -e 's|/etc/pam.d|${PREFIX}/etc/pam.d|g' \
+ ${WRKSRC}/src/gs-auth-pam.c
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${SCREENSAVER_DIR}
+
+post-install-PAM-on:
+ ${INSTALL_DATA} ${FILESDIR}/xfce-screensaver.pam ${STAGEDIR}${PREFIX}/etc/pam.d/xfce-screensaver
+
+.include <bsd.port.post.mk>
diff --git a/x11/xfce4-screensaver/distinfo b/x11/xfce4-screensaver/distinfo
new file mode 100644
index 000000000000..b554b1aa1216
--- /dev/null
+++ b/x11/xfce4-screensaver/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1542973955
+SHA256 (xfce-mirror-xfce4-screensaver-0.1.3-cb0d647_GH0.tar.gz) = 5d415cd35f168ae1b2366403cf942c55470764df258b4ff7867f45a03b2ec672
+SIZE (xfce-mirror-xfce4-screensaver-0.1.3-cb0d647_GH0.tar.gz) = 278447
diff --git a/x11/xfce4-screensaver/files/xfce-screensaver.pam b/x11/xfce4-screensaver/files/xfce-screensaver.pam
new file mode 100644
index 000000000000..7b277e6edfee
--- /dev/null
+++ b/x11/xfce4-screensaver/files/xfce-screensaver.pam
@@ -0,0 +1,2 @@
+auth include system
+account include system
diff --git a/x11/xfce4-screensaver/pkg-descr b/x11/xfce4-screensaver/pkg-descr
new file mode 100644
index 000000000000..14edc8702261
--- /dev/null
+++ b/x11/xfce4-screensaver/pkg-descr
@@ -0,0 +1,6 @@
+xfce4-screensaver is a screen saver and locker that aims to have
+simple, sane, secure defaults and be well integrated with the desktop.
+
+This is a beta version, not recommended for production machines.
+
+WWW: https://git.xfce.org/apps/xfce4-screensaver/about/
diff --git a/x11/xfce4-screensaver/pkg-plist b/x11/xfce4-screensaver/pkg-plist
new file mode 100644
index 000000000000..30e2c007c022
--- /dev/null
+++ b/x11/xfce4-screensaver/pkg-plist
@@ -0,0 +1,41 @@
+bin/xfce4-screensaver
+bin/xfce4-screensaver-command
+bin/xfce4-screensaver-preferences
+%%PAM%%etc/pam.d/xfce-screensaver
+etc/xdg/autostart/xfce4-screensaver.desktop
+etc/xdg/menus/xfce4-screensavers.menu
+libdata/pkgconfig/xfce4-screensaver.pc
+libexec/xfce4-screensaver-dialog
+libexec/xfce4-screensaver-gl-helper
+libexec/xfce4-screensaver/floaters
+libexec/xfce4-screensaver/popsquares
+libexec/xfce4-screensaver/slideshow
+man/man1/xfce4-screensaver-command.1.gz
+man/man1/xfce4-screensaver-preferences.1.gz
+man/man1/xfce4-screensaver.1.gz
+share/applications/screensavers/personal-slideshow.desktop
+share/applications/screensavers/popsquares.desktop
+share/applications/screensavers/xfce-floaters.desktop
+share/applications/xfce4-screensaver-preferences.desktop
+share/dbus-1/services/org.xfce.ScreenSaver.service
+share/desktop-directories/xfce4-screensaver.directory
+%%NLS%%share/locale/bg/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/da/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/de/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/it/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfce4-screensaver.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfce4-screensaver.mo
+share/pixmaps/xfce-logo-white.svg