aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-taskmanager
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2017-02-12 17:00:38 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2017-02-12 17:00:38 +0000
commitaa4b09a04dd1287cd1a29dc0b2594c05fac95e2c (patch)
tree9cdca47616b70c3528370c4382f70ba3f5258e2d /x11/xfce4-taskmanager
parent25ea7cceab81d01f7d5495daacab5c1cbce57f8b (diff)
downloadports-aa4b09a04dd1287cd1a29dc0b2594c05fac95e2c.tar.gz
ports-aa4b09a04dd1287cd1a29dc0b2594c05fac95e2c.zip
- Update to 1.2.0
Notes
Notes: svn path=/head/; revision=433953
Diffstat (limited to 'x11/xfce4-taskmanager')
-rw-r--r--x11/xfce4-taskmanager/Makefile24
-rw-r--r--x11/xfce4-taskmanager/distinfo5
-rw-r--r--x11/xfce4-taskmanager/files/patch-data_icons_16x16_Makefile.in11
-rw-r--r--x11/xfce4-taskmanager/files/patch-src_process-window.c11
-rw-r--r--x11/xfce4-taskmanager/pkg-plist3
5 files changed, 35 insertions, 19 deletions
diff --git a/x11/xfce4-taskmanager/Makefile b/x11/xfce4-taskmanager/Makefile
index 50b9a4173521..d564de143ba5 100644
--- a/x11/xfce4-taskmanager/Makefile
+++ b/x11/xfce4-taskmanager/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xfce4-taskmanager
-PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTVERSION= 1.2.0
CATEGORIES= x11 xfce
MASTER_SITES= XFCE/src/apps/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
@@ -15,21 +14,12 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-USES= gettext gmake pkgconfig tar:bzip2
-USE_GNOME= gtk20 glib20 cairo intltool intlhack
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+USES= gettext gmake localbase pkgconfig tar:bzip2
+USE_GNOME= gtk20 gtk30 glib20 cairo gdkpixbuf2 intltool libwnck3
+USE_XORG= ice sm x11 xmu xt
-OPTIONS_DEFINE= GTK3
-GTK3_USE= gnome=gtk30,libwnck3
-GTK3_CONFIGURE_ON= --enable-gtk3 --enable-wnck3 --disable-wnck
-GTK3_USE_OFF= gnome=libwnck
-GTK3_CONFIGURE_OFF= --enable-wnck --disable-wnck3
-
-CONFIGURE_ARGS+= --disable-gksu
-
-post-patch:
- @${REINPLACE_CMD} -e 's|prefix)/$$(DATADIRNAME)|datadir)|' \
- ${WRKSRC}/po/Makefile.in.in
+CONFIGURE_ARGS+= --disable-gksu \
+ --enable-gtk3 --enable-wnck3 \
+ --disable-wnck
.include <bsd.port.mk>
diff --git a/x11/xfce4-taskmanager/distinfo b/x11/xfce4-taskmanager/distinfo
index be5c4b967bde..67862759061d 100644
--- a/x11/xfce4-taskmanager/distinfo
+++ b/x11/xfce4-taskmanager/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xfce4/xfce4-taskmanager-1.1.0.tar.bz2) = 2e1eb161f966cbfbd68bd029fb59115bc5ab0c0704cb500d20e7d73967e59ecb
-SIZE (xfce4/xfce4-taskmanager-1.1.0.tar.bz2) = 365866
+TIMESTAMP = 1486910944
+SHA256 (xfce4/xfce4-taskmanager-1.2.0.tar.bz2) = 5746d473ad428b13db7c05cfcbc8099fbea13da6be26d3a9359bcb4de971ba69
+SIZE (xfce4/xfce4-taskmanager-1.2.0.tar.bz2) = 435276
diff --git a/x11/xfce4-taskmanager/files/patch-data_icons_16x16_Makefile.in b/x11/xfce4-taskmanager/files/patch-data_icons_16x16_Makefile.in
new file mode 100644
index 000000000000..c107fe111fe2
--- /dev/null
+++ b/x11/xfce4-taskmanager/files/patch-data_icons_16x16_Makefile.in
@@ -0,0 +1,11 @@
+--- data/icons/16x16/Makefile.in.orig 2017-02-12 11:22:36 UTC
++++ data/icons/16x16/Makefile.in
+@@ -336,7 +336,7 @@ target_vendor = @target_vendor@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-iconsdir = $(datadir)/icons/hicolor/16x16/apps
++iconsdir = $(datadir)/icons/hicolor/16x16/actions
+ icons_DATA = xc_crosshair.png
+ EXTRA_DIST = $(icons_DATA)
+ all: all-am
diff --git a/x11/xfce4-taskmanager/files/patch-src_process-window.c b/x11/xfce4-taskmanager/files/patch-src_process-window.c
new file mode 100644
index 000000000000..88e37dffdb8d
--- /dev/null
+++ b/x11/xfce4-taskmanager/files/patch-src_process-window.c
@@ -0,0 +1,11 @@
+--- src/process-window.c.orig 2017-02-08 22:08:25 UTC
++++ src/process-window.c
+@@ -247,7 +247,7 @@ xtm_process_window_init (XtmProcessWindo
+ window->settings_button = xtm_settings_tool_button_new ();
+ gtk_toolbar_insert (GTK_TOOLBAR (window->toolbar), GTK_TOOL_ITEM (window->settings_button), 1);
+
+- icon = gtk_image_new_from_icon_name ("xc_crosshair", GTK_ICON_SIZE_LARGE_TOOLBAR);
++ icon = gtk_image_new_from_icon_name ("dialog-information", GTK_ICON_SIZE_LARGE_TOOLBAR);
+ xwininfo = gtk_tool_button_new (icon, _("Identify Window"));
+ gtk_widget_set_tooltip_text (GTK_WIDGET (xwininfo), _("Identify an open window by clicking on it."));
+ gtk_toolbar_insert (GTK_TOOLBAR (window->toolbar), GTK_TOOL_ITEM (xwininfo), 2);
diff --git a/x11/xfce4-taskmanager/pkg-plist b/x11/xfce4-taskmanager/pkg-plist
index 29c1f9d9b209..29c3be96d30b 100644
--- a/x11/xfce4-taskmanager/pkg-plist
+++ b/x11/xfce4-taskmanager/pkg-plist
@@ -1,5 +1,8 @@
bin/xfce4-taskmanager
share/applications/xfce4-taskmanager.desktop
+share/icons/hicolor/16x16/actions/xc_crosshair.png
+share/icons/hicolor/24x24/actions/xc_crosshair.png
+share/icons/hicolor/scalable/actions/xc_crosshair.svg
share/locale/ar/LC_MESSAGES/xfce4-taskmanager.mo
share/locale/ast/LC_MESSAGES/xfce4-taskmanager.mo
share/locale/be/LC_MESSAGES/xfce4-taskmanager.mo