aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-terminal
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2016-10-31 17:07:19 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2016-10-31 17:07:19 +0000
commitbb90ff81e7133a6adf05edcd42ca3817b3e16e0a (patch)
treecce161c7b40ca232fec1b3d3d3fafead5a6418d9 /x11/xfce4-terminal
parent5bea5caa17b00b4c7b3a0fa0b95a71867d395f00 (diff)
downloadports-bb90ff81e7133a6adf05edcd42ca3817b3e16e0a.tar.gz
ports-bb90ff81e7133a6adf05edcd42ca3817b3e16e0a.zip
Notes
Diffstat (limited to 'x11/xfce4-terminal')
-rw-r--r--x11/xfce4-terminal/Makefile2
-rw-r--r--x11/xfce4-terminal/distinfo6
-rw-r--r--x11/xfce4-terminal/files/patch-terminal_terminal-screen.c58
3 files changed, 62 insertions, 4 deletions
diff --git a/x11/xfce4-terminal/Makefile b/x11/xfce4-terminal/Makefile
index cfb317263473..e7dfc49af4ab 100644
--- a/x11/xfce4-terminal/Makefile
+++ b/x11/xfce4-terminal/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xfce4-terminal
-PORTVERSION= 0.8.0
+PORTVERSION= 0.8.1
CATEGORIES= x11 xfce
MASTER_SITES= XFCE/src/apps/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
diff --git a/x11/xfce4-terminal/distinfo b/x11/xfce4-terminal/distinfo
index 1bc866d3620c..fcd63ae3bc3f 100644
--- a/x11/xfce4-terminal/distinfo
+++ b/x11/xfce4-terminal/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1476710906
-SHA256 (xfce4/xfce4-terminal-0.8.0.tar.bz2) = e915c05a3d07b66d153e1ba8614f904f9c12b2dd8372b27d24c0d339743d5b0a
-SIZE (xfce4/xfce4-terminal-0.8.0.tar.bz2) = 868612
+TIMESTAMP = 1477933186
+SHA256 (xfce4/xfce4-terminal-0.8.1.tar.bz2) = ddfe53a89d315a4a9170ca6d2cee2d33145bd63630062b2e867fb3a5fcde5fdf
+SIZE (xfce4/xfce4-terminal-0.8.1.tar.bz2) = 871184
diff --git a/x11/xfce4-terminal/files/patch-terminal_terminal-screen.c b/x11/xfce4-terminal/files/patch-terminal_terminal-screen.c
new file mode 100644
index 000000000000..7da770984e8c
--- /dev/null
+++ b/x11/xfce4-terminal/files/patch-terminal_terminal-screen.c
@@ -0,0 +1,58 @@
+Revert commit, because default size is not anymore enabled.
+
+--- terminal/terminal-screen.c.orig 2016-10-25 16:07:56 UTC
++++ terminal/terminal-screen.c
+@@ -1673,47 +1673,31 @@ terminal_screen_get_geometry (TerminalSc
+ *
+ * I don't like this way, but its required to work-around a Gtk+
+ * bug (maybe also caused by a Vte bug, not sure).
+- *
+- * Code borrowed from gnome-terminal (terminal_window_update_geometry).
+ **/
+ void
+ terminal_screen_set_window_geometry_hints (TerminalScreen *screen,
+ GtkWindow *window)
+ {
+ GdkGeometry hints;
+- GtkRequisition vbox_request;
+- GtkAllocation toplevel_allocation, vbox_allocation;
+ glong char_width, char_height;
+- glong grid_width, grid_height;
+- glong chrome_width, chrome_height;
+- gint csd_width, csd_height;
++ gint xpad, ypad;
+
+ terminal_return_if_fail (TERMINAL_IS_SCREEN (screen));
+ terminal_return_if_fail (VTE_IS_TERMINAL (screen->terminal));
+ terminal_return_if_fail (gtk_widget_get_realized (screen));
+ terminal_return_if_fail (gtk_widget_get_realized (window));
+
+- terminal_screen_get_geometry (screen, &char_width, &char_height, NULL, NULL);
+- terminal_screen_get_size (screen, &grid_width, &grid_height);
+-
+- gtk_widget_get_preferred_size (TERMINAL_WINDOW (window)->vbox, NULL, &vbox_request);
+- chrome_width = vbox_request.width - (char_width * grid_width);
+- chrome_height = vbox_request.height - (char_height * grid_height);
+-
+- gtk_widget_get_allocation (TERMINAL_WINDOW (window)->vbox, &vbox_allocation);
+- gtk_widget_get_allocation (GTK_WIDGET (window), &toplevel_allocation);
+- csd_width = toplevel_allocation.width - vbox_allocation.width;
+- csd_height = toplevel_allocation.height - vbox_allocation.height;
++ terminal_screen_get_geometry (screen, &char_width, &char_height, &xpad, &ypad);
+
+- hints.base_width = chrome_width + csd_width;
+- hints.base_height = chrome_height + csd_height;
++ hints.base_width = xpad;
++ hints.base_height = ypad;
+ hints.width_inc = char_width;
+ hints.height_inc = char_height;
+ hints.min_width = hints.base_width + hints.width_inc * 4;
+ hints.min_height = hints.base_height + hints.height_inc * 2;
+
+- gtk_window_set_geometry_hints (window,
+- NULL,
++ gtk_window_set_geometry_hints (GTK_WINDOW (window),
++ screen->terminal,
+ &hints,
+ GDK_HINT_RESIZE_INC
+ | GDK_HINT_MIN_SIZE