aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-verve-plugin
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-01-27 04:40:30 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-01-27 04:40:30 +0000
commit80349fd810b48f6b6b9e3498d61bc682af7452ee (patch)
treebb9fa2400a29b18666735095ddb467e041c1d103 /x11/xfce4-verve-plugin
parent2d2f4b45f024d16032a0740a9be75df5b7ea2c61 (diff)
downloadports-80349fd810b48f6b6b9e3498d61bc682af7452ee.tar.gz
ports-80349fd810b48f6b6b9e3498d61bc682af7452ee.zip
Notes
Diffstat (limited to 'x11/xfce4-verve-plugin')
-rw-r--r--x11/xfce4-verve-plugin/Makefile42
-rw-r--r--x11/xfce4-verve-plugin/distinfo4
-rw-r--r--x11/xfce4-verve-plugin/files/patch-configure11
-rw-r--r--x11/xfce4-verve-plugin/pkg-descr2
-rw-r--r--x11/xfce4-verve-plugin/pkg-plist16
5 files changed, 40 insertions, 35 deletions
diff --git a/x11/xfce4-verve-plugin/Makefile b/x11/xfce4-verve-plugin/Makefile
index e17d8ea738f8..2abd3ab56906 100644
--- a/x11/xfce4-verve-plugin/Makefile
+++ b/x11/xfce4-verve-plugin/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= verve-plugin
-PORTVERSION= 1.0.0
-PORTREVISION= 10
+PORTVERSION= 1.0.1
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=src/panel-plugins/${PKGNAMEPREFIX}${PORTNAME}/${PORTVERSION:R}
@@ -12,38 +11,23 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
-COMMENT= Command line plugin for Xfce4
+COMMENT= Command line plugin for the Xfce Desktop
LICENSE= GPLv2
-LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
GNU_CONFIGURE= yes
-USES= gmake libtool pathfix pkgconfig tar:bzip2
+USES= gmake libtool pkgconfig tar:bzip2
USE_GNOME= glib20 intltool intlhack
-USE_XFCE= configenv panel libexo libgui libutil
-
-OPTIONS_DEFINE= NLS DBUS
-OPTIONS_DEFAULT= NLS DBUS
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+=--enable-nls
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
-CONFIGURE_ARGS+=--enable-dbus
-PLIST_SUB+= DBUS=""
-.else
-CONFIGURE_ARGS+=--disable-dbus
-PLIST_SUB+= DBUS="@comment "
-.endif
+USE_XFCE= configenv libexo libmenu libutil panel
+
+CONFIGURE_ARGS=--enable-dbus
+
+OPTIONS_DEFINE= NLS
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
+OPTIONS_SUB= yes
.include <bsd.port.mk>
diff --git a/x11/xfce4-verve-plugin/distinfo b/x11/xfce4-verve-plugin/distinfo
index 6df137da362e..f04c4adf461e 100644
--- a/x11/xfce4-verve-plugin/distinfo
+++ b/x11/xfce4-verve-plugin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/xfce4-verve-plugin-1.0.0.tar.bz2) = d011a47ed3b075afdb9673342537fae5deeedc7834daf64b95bc0b541545f1a3
-SIZE (xfce4/xfce4-verve-plugin-1.0.0.tar.bz2) = 324945
+SHA256 (xfce4/xfce4-verve-plugin-1.0.1.tar.bz2) = 3b9c847ef4b10259137e4c8d1baa4a05486b35d3ff01ded3c00a8669c7dc9bf8
+SIZE (xfce4/xfce4-verve-plugin-1.0.1.tar.bz2) = 325191
diff --git a/x11/xfce4-verve-plugin/files/patch-configure b/x11/xfce4-verve-plugin/files/patch-configure
new file mode 100644
index 000000000000..763cf6d8a401
--- /dev/null
+++ b/x11/xfce4-verve-plugin/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2015-01-26 21:05:44.000000000 +0100
++++ configure 2015-01-26 23:11:21.000000000 +0100
+@@ -13172,7 +13172,7 @@
+
+ fi
+ fi
+- USE_NLS=yes
++ #USE_NLS=yes
+
+
+ gt_cv_have_gettext=no
diff --git a/x11/xfce4-verve-plugin/pkg-descr b/x11/xfce4-verve-plugin/pkg-descr
index c64d11094dae..4d2daef18111 100644
--- a/x11/xfce4-verve-plugin/pkg-descr
+++ b/x11/xfce4-verve-plugin/pkg-descr
@@ -7,4 +7,4 @@ It supports several nice features, such as:
* Focus grabbing via D-BUS (so you can bind a shortcut to it)
* Custom input field width
-WWW: http://goodies.xfce.org/projects/panel-plugins/verve-plugin
+WWW: http://goodies.xfce.org/projects/panel-plugins/xfce4-verve-plugin
diff --git a/x11/xfce4-verve-plugin/pkg-plist b/x11/xfce4-verve-plugin/pkg-plist
index 98aeed1bb9bb..0a7a06f48058 100644
--- a/x11/xfce4-verve-plugin/pkg-plist
+++ b/x11/xfce4-verve-plugin/pkg-plist
@@ -1,12 +1,14 @@
-%%DBUS%%bin/verve-focus
-libexec/xfce4/panel-plugins/xfce4-verve-plugin
+bin/verve-focus
+lib/xfce4/panel/plugins/libverve.so
%%NLS%%share/locale/ar/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/ast/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/ca/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/cs/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/da/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/de/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/el/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/en_AU/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/eo/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/es/LC_MESSAGES/xfce4-verve-plugin.mo
@@ -14,21 +16,29 @@ libexec/xfce4/panel-plugins/xfce4-verve-plugin
%%NLS%%share/locale/fi/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/fr/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/gl/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/hu/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/id/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/is/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/it/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/ja/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/lv/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/nb/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/nl/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/oc/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/pa/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/pl/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/pt/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/ro/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/ru/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/sq/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/sv/LC_MESSAGES/xfce4-verve-plugin.mo
+%%NLS%%share/locale/th/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/tr/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/ug/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/uk/LC_MESSAGES/xfce4-verve-plugin.mo
@@ -37,4 +47,4 @@ libexec/xfce4/panel-plugins/xfce4-verve-plugin
%%NLS%%share/locale/vi/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfce4-verve-plugin.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfce4-verve-plugin.mo
-share/xfce4/panel-plugins/xfce4-verve-plugin.desktop
+share/xfce4/panel/plugins/xfce4-verve-plugin.desktop