aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-whiskermenu-plugin
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-09-21 21:34:28 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-09-21 21:34:28 +0000
commitb65beb26da6941b6ddfb72026f8f92ee713ca924 (patch)
tree158e669b76ac708492f278b1b222809cd961fb4b /x11/xfce4-whiskermenu-plugin
parent8da03a0429b1dc2f4503518435f45ffb9c325b6a (diff)
downloadports-b65beb26da6941b6ddfb72026f8f92ee713ca924.tar.gz
ports-b65beb26da6941b6ddfb72026f8f92ee713ca924.zip
Notes
Diffstat (limited to 'x11/xfce4-whiskermenu-plugin')
-rw-r--r--x11/xfce4-whiskermenu-plugin/Makefile5
-rw-r--r--x11/xfce4-whiskermenu-plugin/distinfo4
-rw-r--r--x11/xfce4-whiskermenu-plugin/files/patch-panel-plugin_settings.cpp11
3 files changed, 15 insertions, 5 deletions
diff --git a/x11/xfce4-whiskermenu-plugin/Makefile b/x11/xfce4-whiskermenu-plugin/Makefile
index 1abec55a6586..190504d39161 100644
--- a/x11/xfce4-whiskermenu-plugin/Makefile
+++ b/x11/xfce4-whiskermenu-plugin/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xfce4-whiskermenu-plugin
-PORTVERSION= 1.5.0
-PORTREVISION= 1
+PORTVERSION= 1.5.1
CATEGORIES= x11 xfce
MASTER_SITES= XFCE/src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
@@ -16,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= pkgconfig cmake gettext xfce tar:bzip2
+USES= cmake gettext pkgconfig tar:bzip2 xfce
USE_GNOME= gtk20
USE_XFCE= panel
INSTALLS_ICONS= yes
diff --git a/x11/xfce4-whiskermenu-plugin/distinfo b/x11/xfce4-whiskermenu-plugin/distinfo
index 58867812ec60..e97482da9a52 100644
--- a/x11/xfce4-whiskermenu-plugin/distinfo
+++ b/x11/xfce4-whiskermenu-plugin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/xfce4-whiskermenu-plugin-1.5.0.tar.bz2) = da82bdbc899a9935b560323aac9037d44f37fb110509b80ec293196722671851
-SIZE (xfce4/xfce4-whiskermenu-plugin-1.5.0.tar.bz2) = 145549
+SHA256 (xfce4/xfce4-whiskermenu-plugin-1.5.1.tar.bz2) = 1c7650562322867513370ab575536b67aa3712329bb60a0c91a0a70e23a8945a
+SIZE (xfce4/xfce4-whiskermenu-plugin-1.5.1.tar.bz2) = 148050
diff --git a/x11/xfce4-whiskermenu-plugin/files/patch-panel-plugin_settings.cpp b/x11/xfce4-whiskermenu-plugin/files/patch-panel-plugin_settings.cpp
new file mode 100644
index 000000000000..b1809266ce1b
--- /dev/null
+++ b/x11/xfce4-whiskermenu-plugin/files/patch-panel-plugin_settings.cpp
@@ -0,0 +1,11 @@
+--- panel-plugin/settings.cpp.orig 2015-03-08 09:15:22 UTC
++++ panel-plugin/settings.cpp
+@@ -148,6 +148,8 @@ void Settings::load(char* file)
+ {
+ if (!file)
+ {
++ command[CommandProfile]->set_shown(false);
++ command[CommandMenuEditor]->set_shown(false);
+ return;
+ }
+