aboutsummaryrefslogtreecommitdiff
path: root/x11/xinit
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2011-09-22 13:51:54 +0000
committerEitan Adler <eadler@FreeBSD.org>2011-09-22 13:51:54 +0000
commit05a4bd4ab2a977a5598474f9c8df8e4e16b1b67f (patch)
tree901e0f3589c05a04638e25b8ea01f3e0f3eb594f /x11/xinit
parentabdec19d38d6f1e58e3cb18eecd96d181efdd048 (diff)
downloadports-05a4bd4ab2a977a5598474f9c8df8e4e16b1b67f.tar.gz
ports-05a4bd4ab2a977a5598474f9c8df8e4e16b1b67f.zip
Notes
Diffstat (limited to 'x11/xinit')
-rw-r--r--x11/xinit/Makefile7
-rw-r--r--x11/xinit/distinfo4
-rw-r--r--x11/xinit/files/patch-xinit.c15
3 files changed, 21 insertions, 5 deletions
diff --git a/x11/xinit/Makefile b/x11/xinit/Makefile
index 16ec0d9dd419..7b92be23ab24 100644
--- a/x11/xinit/Makefile
+++ b/x11/xinit/Makefile
@@ -6,13 +6,14 @@
#
PORTNAME= xinit
-PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTVERSION= 1.3.1
CATEGORIES= x11
MAINTAINER= x11@FreeBSD.org
COMMENT= X Window System initializer
+LICENSE= MIT
+
XORG_CAT= app
USE_XORG= x11
@@ -23,6 +24,6 @@ MAN1= startx.1 xinit.1
post-patch:
@${REINPLACE_CMD} -e 's|hexdump|/usr/bin/hexdump|' ${WRKSRC}/startx.cpp
- @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/xinit.man
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/man/xinit.man
.include <bsd.port.mk>
diff --git a/x11/xinit/distinfo b/x11/xinit/distinfo
index 74e631c2e139..9c363d13e8f3 100644
--- a/x11/xinit/distinfo
+++ b/x11/xinit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/app/xinit-1.2.0.tar.bz2) = ab61663a4421753132d4aac97a873ed20697c4761cb434640f48f350fb65087f
-SIZE (xorg/app/xinit-1.2.0.tar.bz2) = 136781
+SHA256 (xorg/app/xinit-1.3.1.tar.bz2) = c7468dfae94bdb42785d79623c27156dc4bf379d8372992830482cb04d8439b0
+SIZE (xorg/app/xinit-1.3.1.tar.bz2) = 147067
diff --git a/x11/xinit/files/patch-xinit.c b/x11/xinit/files/patch-xinit.c
new file mode 100644
index 000000000000..abe8803b8282
--- /dev/null
+++ b/x11/xinit/files/patch-xinit.c
@@ -0,0 +1,15 @@
+--- xinit.c.orig 2011-04-26 07:03:42.000000000 +0200
++++ xinit.c 2011-08-06 22:14:03.000000000 +0200
+@@ -49,10 +49,10 @@
+ #endif
+
+ /* For PRIO_PROCESS and setpriority() */
+-#ifdef __DragonFly__
++#if defined(__DragonFly__) || defined(__FreeBSD__)
+ #include <sys/time.h>
+ #include <sys/resource.h>
+-#endif /* __DragonFly__ */
++#endif
+
+ #include <stdlib.h>
+