aboutsummaryrefslogtreecommitdiff
path: root/x11/xloadimage
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2017-10-02 04:01:10 +0000
committerAlex Kozlov <ak@FreeBSD.org>2017-10-02 04:01:10 +0000
commit31c987cab6aeec5ab096d06528ec5a85980b82cb (patch)
tree34755b6f50ee2d7dfabbf49b12dcad855dbe39ac /x11/xloadimage
parentd09cf8392374b6d9503751852a6578ad3c91e03b (diff)
downloadports-31c987cab6aeec5ab096d06528ec5a85980b82cb.tar.gz
ports-31c987cab6aeec5ab096d06528ec5a85980b82cb.zip
Notes
Diffstat (limited to 'x11/xloadimage')
-rw-r--r--x11/xloadimage/Makefile11
-rw-r--r--x11/xloadimage/distinfo6
-rw-r--r--x11/xloadimage/files/patch-Makefile.in2
3 files changed, 12 insertions, 7 deletions
diff --git a/x11/xloadimage/Makefile b/x11/xloadimage/Makefile
index d6af1b4342b8..7fe2f0e7af63 100644
--- a/x11/xloadimage/Makefile
+++ b/x11/xloadimage/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= xloadimage
-PORTVERSION= 4.1.21
-PORTREVISION= 1
+PORTVERSION= 4.1.24
CATEGORIES= x11 graphics
MASTER_SITES= DEBIAN_POOL
DISTNAME= ${PORTNAME}.${VERSION}
DISTFILES= ${DISTNAME:S/./_/}.orig${EXTRACT_SUFX} \
- ${DISTNAME:S/./_/}-${REVISION}.debian.tar.gz
+ ${DISTNAME:S/./_/}-${REVISION}.debian.tar.xz
MAINTAINER= ak@FreeBSD.org
COMMENT= X11 Image Loading Utility
@@ -21,6 +20,9 @@ LIB_DEPENDS= libpng.so:graphics/png \
CONFLICTS_INSTALL= xli-*
EXTRA_PATCHES= ${WRKDIR}/debian/patches/*.patch
+IGNORE_PATCHES= 07_SYSPATHFILE.patch 24_libtiff5.patch \
+ 25_hardening-flags.patch 26_uufilter-implicit-declaration.patch \
+ 30_libtiff5.patch 31_reproducible-build.patch
PATCH_STRIP= -p1
VERSION= ${PORTVERSION:R}
@@ -33,6 +35,9 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+pre-patch:
+ @${RM} ${IGNORE_PATCHES:S,^,${WRKDIR}/debian/patches/,}
+
post-patch:
@${CHMOD} a+rx ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|TIFFHeader|TIFFHeaderClassic|g' \
diff --git a/x11/xloadimage/distinfo b/x11/xloadimage/distinfo
index c332075d516c..b8dda097e81a 100644
--- a/x11/xloadimage/distinfo
+++ b/x11/xloadimage/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1465187272
+TIMESTAMP = 1506910724
SHA256 (xloadimage_4.1.orig.tar.gz) = 400bc7d84dcfb3265a7a1ce51819679dc3adaeda231514bd89b0f932b78ff5c4
SIZE (xloadimage_4.1.orig.tar.gz) = 596021
-SHA256 (xloadimage_4.1-21.debian.tar.gz) = 4a15879f501462f1e45f3f8064a67b46362826c44bab5827e5dc051cd5c0a49f
-SIZE (xloadimage_4.1-21.debian.tar.gz) = 76415
+SHA256 (xloadimage_4.1-24.debian.tar.xz) = 3f5332fbca08e6c1d2ecad2f4ddeed5390273b4607921b0e2d8385eb75b1ed85
+SIZE (xloadimage_4.1-24.debian.tar.xz) = 69684
diff --git a/x11/xloadimage/files/patch-Makefile.in b/x11/xloadimage/files/patch-Makefile.in
index 0f222a117774..582102647eda 100644
--- a/x11/xloadimage/files/patch-Makefile.in
+++ b/x11/xloadimage/files/patch-Makefile.in
@@ -6,7 +6,7 @@
+prefix = @prefix@
CC = @CC@
--DEFS = @DEFS@ -DSYSPATHFILE=\"/etc/X11/Xloadimage\"
+-DEFS = @DEFS@
-CFLAGS = @CFLAGS@
+DEFS = @DEFS@ -DSYSPATHFILE=\"@sysconfdir@/xloadimagerc\"
+CFLAGS = @CFLAGS@ @CPPFLAGS@ @X_CFLAGS@