aboutsummaryrefslogtreecommitdiff
path: root/x11/xmangekyou
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-03 22:21:54 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-03 22:21:54 +0000
commit6e5f6f489d455d7584c7660e183603db0c54b97c (patch)
tree03eb128a3a7fce7c6818ca0ca0b9e8ee2aee8c00 /x11/xmangekyou
parentbe508d8be428d628b7a4251dcb06c3acbe3061bc (diff)
Notes
Diffstat (limited to 'x11/xmangekyou')
-rw-r--r--x11/xmangekyou/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/x11/xmangekyou/Makefile b/x11/xmangekyou/Makefile
index d3fa2ae48d1d..7d656b699edc 100644
--- a/x11/xmangekyou/Makefile
+++ b/x11/xmangekyou/Makefile
@@ -13,13 +13,13 @@ COMMENT= Kaleidoscope on X
USE_XORG= x11 xpm xaw
ALL_TARGET= xmangekyou
-MANCOMPRESSED= yes
-MAN1= xmangekyou.1
PORTDOCS= COPYRIGHT.euc HISTORY.euc README.euc
-PLIST_FILES= bin/xmangekyou lib/X11/XMangekyou/animation.dat
+PLIST_FILES= bin/xmangekyou lib/X11/XMangekyou/animation.dat \
+ man/man1/xmangekyou.1.gz
PLIST_DIRS= lib/X11/XMangekyou
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
@@ -30,13 +30,13 @@ post-patch:
s|-L/usr/X11R6/|-L$${LOCALBASE}/|g' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/xmangekyou ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/xmangekyou.1.gz ${MANPREFIX}/man/man1
- @${MKDIR} ${PREFIX}/lib/X11/XMangekyou
- ${INSTALL_DATA} ${WRKSRC}/animation.dat ${PREFIX}/lib/X11/XMangekyou
+ ${INSTALL_PROGRAM} ${WRKSRC}/xmangekyou ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xmangekyou.1.gz ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/XMangekyou
+ ${INSTALL_DATA} ${WRKSRC}/animation.dat ${STAGEDIR}${PREFIX}/lib/X11/XMangekyou
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.euc ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.euc ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>