aboutsummaryrefslogtreecommitdiff
path: root/x11/xmascot
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-15 10:32:22 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-15 10:32:22 +0000
commit83b4c7ea737d7766fed5938149e4055df21c3308 (patch)
tree91959cf23c2fe3dafbbf1828459943a5654304d5 /x11/xmascot
parent862f8cf6d442e34d0559b4411658b98aae76d1e2 (diff)
downloadports-83b4c7ea737d7766fed5938149e4055df21c3308.tar.gz
ports-83b4c7ea737d7766fed5938149e4055df21c3308.zip
In modern world of parallel builds and our new bmake(1) imake's popular
MakeSubdirs() macro becomes very unsafe, as it hooks the subdirectories' build commands to the "all" target, along with main program executable. If MakeSubdirs() was used to build a dependency of the main program, it is highly likely that parallel build (-jX) will fail; and that's what's happening to this port here. To remedy the problem, use NamedTargetSubdirs() instead; also make sure that correct make(1) implementation would be used for sub-makes (ignore bogus "MAKE = make" set by imake in generated Makefiles). While here, improve wording and formatting in the port description. Reported by: marino
Notes
Notes: svn path=/head/; revision=324756
Diffstat (limited to 'x11/xmascot')
-rw-r--r--x11/xmascot/Makefile12
-rw-r--r--x11/xmascot/pkg-descr31
2 files changed, 26 insertions, 17 deletions
diff --git a/x11/xmascot/Makefile b/x11/xmascot/Makefile
index 530e5717eaea..abf332e88e27 100644
--- a/x11/xmascot/Makefile
+++ b/x11/xmascot/Makefile
@@ -13,10 +13,18 @@ COMMENT= Moving mascot on your X11 screen
USES= imake
USE_XORG= ice sm x11 xaw xext xmu xpm xt
+MAKE_ARGS= MAKE="${MAKE_CMD}"
+
MAN1= xmascot.1
+# Unbreak parallel (-jX) builds: do not use unsafe MakeSubdirs() macro
+post-patch:
+ @${REINPLACE_CMD} -e 's/MakeSubdirs(/Named&$$(IMAGELIB),/' \
+ ${WRKSRC}/Imakefile
+
post-install:
- -@${MKDIR} ${PREFIX}/lib/X11/ja_JP.EUC/app-defaults
- ${CP} ${PREFIX}/lib/X11/ja_JP.eucJP/app-defaults/XMascot ${PREFIX}/lib/X11/ja_JP.EUC/app-defaults/
+ @${MKDIR} ${PREFIX}/lib/X11/ja_JP.EUC/app-defaults
+ ${INSTALL_DATA} ${PREFIX}/lib/X11/ja_JP.eucJP/app-defaults/XMascot \
+ ${PREFIX}/lib/X11/ja_JP.EUC/app-defaults
.include <bsd.port.mk>
diff --git a/x11/xmascot/pkg-descr b/x11/xmascot/pkg-descr
index 0b9aa8207388..5390323d3868 100644
--- a/x11/xmascot/pkg-descr
+++ b/x11/xmascot/pkg-descr
@@ -1,22 +1,23 @@
-XMascot displays a moving mascot on your X11 screen. XMascot has
-the following options,
+XMascot displays a moving mascot on your X11 screen. XMascot has the
+following options:
- -Moving pretty mascot moving
- -Strectch stretch as you like
- -Talking mascot talks with extract command and data
- -Alarm mascot may make some actions at time you define
- -BIFF mascot may let you know arriving a mail.
+ - Moving pretty mascot moving
+ - Stretch stretch it as you like
+ - Talking mascot talks with extract command and data
+ - Alarm mascot may make some actions at defined time
+ - BIFF mascot may let you know arriving a mail
XMascot supports these image formats:
-MAG *.mag 16 colors and 256 colors
-TIFF *.tif 16 colors and 256 colors, in raw or lzw
-PPM *.ppm 256 level color , in raw
-PGM *.pgm 256 level gray scale, in raw
-PBM *.pbm 2 level monocrome, in raw
-PNM *.pnm PPM, PGM, or PBM
+ - MAG (*.mag) 16 colors and 256 colors
+ - TIFF (*.tif) 16 colors and 256 colors, in raw or lzw
+ - PPM (*.ppm) 256 level color, in raw
+ - PGM (*.pgm) 256 level gray scale, in raw
+ - PBM (*.pbm) 2 level monochrome, in raw
+ - PNM (*.pnm) PPM, PGM, or PBM
-XMascot distinguishes images from their suffix and can load other image formats
-when {suffix}topnm, *topgm, or *topbm commands are found in your system.
+XMascot distinguishes images from their suffix and can load other image
+formats when corresponding *topnm, *topgm, or *topbm commands are found
+in your system.
WWW: http://cclub-flying.dsl.gr.jp/products/xmascot/