aboutsummaryrefslogtreecommitdiff
path: root/x11/xmotd/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-08-28 07:13:10 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-08-28 07:13:10 +0000
commit02bb9957d90309685bc1a41cc0225f09b195d6c7 (patch)
tree706621a770172333f391c49f65621ddc7a80f9fe /x11/xmotd/Makefile
parentc5fa7bc46d4bbd84db96c7149c89bd491a245a20 (diff)
add xmotd 1.16
A message-of-the-day browser for X11 and dumb-terminals PR: 24713 Submitted by: Matthew West <mwest@uct.ac.za>
Notes
Notes: svn path=/head/; revision=47006
Diffstat (limited to 'x11/xmotd/Makefile')
-rw-r--r--x11/xmotd/Makefile60
1 files changed, 60 insertions, 0 deletions
diff --git a/x11/xmotd/Makefile b/x11/xmotd/Makefile
new file mode 100644
index 000000000000..aa896fd2c994
--- /dev/null
+++ b/x11/xmotd/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: xmotd
+# Date created: 29 January 2001
+# Whom: Matthew West <mwest@uct.ac.za>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmotd
+PORTVERSION= 1.16
+CATEGORIES= x11
+MASTER_SITES= http://www.ee.ryerson.ca/~elf/pub/
+
+MAINTAINER= mwest@uct.ac.za
+
+USE_IMAKE= yes
+NO_INSTALL_MANPAGES= yes
+XFREE86_HTML_MAN= no
+
+MAN8= xmotd.8
+
+.if defined(USE_HTML)
+MAKE_ARGS+= -DHAVE_HTML
+.endif
+
+.if defined(USE_MOTIF)
+MAKE_ARGS+= -DMOTIF
+.endif
+
+pre-fetch:
+ @${ECHO} ""
+ @${ECHO} "You may use the following build options:"
+ @${ECHO} ""
+ @${ECHO} " USE_HTML=yes uses HTML widget instead of ASCII text"
+ @${ECHO} " USE_MOTIF=yes uses Motif widget library"
+ @${ECHO} " USE_XPM=yes allows colour XPM pixmaps"
+ @${ECHO} ""
+
+post-extract:
+ @${TOUCH} ${WRKSRC}/xmotd.man
+
+post-patch:
+ @${PERL} -pi -e 's:/usr/local/bin/::g' ${WRKSRC}/xmotd.8
+.for file in libhtmlw/HTML-PSformat.c main.c textmode.c xmotd.c
+ @${PERL} -pi -e 's:malloc.h:stdlib.h:' ${WRKSRC}/${file}
+.endfor
+.if defined(USE_HTML)
+ @${PERL} -pi.orig -e 's:XCOMM #define HAVE_HTML:#define HAVE_HTML:g' ${WRKSRC}/Imakefile
+.endif
+.if defined (USE_MOTIF)
+ @${PERL} -pi.orig -e 's:XCOMM #define MOTIF:#define MOTIF:g' ${WRKSRC}/Imakefile
+.endif
+.if defined(USE_XPM)
+ @${PERL} -pi.orig -e 's:XCOMM #define HAVE_XPM:#define HAVE_XPM:g' ${WRKSRC}/Imakefile
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xmotd ${X11BASE}/bin/xmotd
+ ${INSTALL_MAN} ${WRKSRC}/xmotd.8 ${MANPREFIX}/man/man8
+
+.include <bsd.port.mk>