aboutsummaryrefslogtreecommitdiff
path: root/x11/xnee/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-06-08 01:38:29 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-06-08 01:38:29 +0000
commit4d48dbe60057650a36ff90a25acafc4cff7a695d (patch)
tree5bcfa632763df632b2116c60ee5a53c0674ec677 /x11/xnee/Makefile
parent5e80422bb1cde308e1567aef8f69675861c675ec (diff)
Notes
Diffstat (limited to 'x11/xnee/Makefile')
-rw-r--r--x11/xnee/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/x11/xnee/Makefile b/x11/xnee/Makefile
index 2debf7ea4a4a..bc9d27cd763d 100644
--- a/x11/xnee/Makefile
+++ b/x11/xnee/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= xnee
-PORTVERSION= 1.0.6
+PORTVERSION= 1.07
CATEGORIES= x11
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
@@ -18,17 +18,17 @@ BUILD_DEPENDS= texi2html:${PORTSDIR}/textproc/texi2html
USE_X_PREFIX= yes
USE_PERL5= yes
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= xnee.1
post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's| -g | @CFLAGS@ |g'
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
+ 's| -g | \@CFLAGS\@ |g ; \
+ s|-lpthread|${PTHREAD_LIBS:S/"//g}|g'
post-install:
- ${INSTALL_MAN} ${WRKSRC}/doc/xnee.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/xnee/doc/xnee.1 ${MANPREFIX}/man/man1
.include <bsd.port.mk>