aboutsummaryrefslogtreecommitdiff
path: root/x11/xnodecor
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 07:08:14 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 07:08:14 +0000
commitf4d7b17dda6b5ca3c560ce3cb61cad523617b011 (patch)
treee222989de0256f9631663c2e926ef54c7b42f8c7 /x11/xnodecor
parent78707535206e8bbd4b3d29b2628f70e004ee9209 (diff)
downloadports-f4d7b17dda6b5ca3c560ce3cb61cad523617b011.tar.gz
ports-f4d7b17dda6b5ca3c560ce3cb61cad523617b011.zip
Notes
Diffstat (limited to 'x11/xnodecor')
-rw-r--r--x11/xnodecor/Makefile25
-rw-r--r--x11/xnodecor/distinfo1
-rw-r--r--x11/xnodecor/files/Makefile15
-rw-r--r--x11/xnodecor/files/patch-xnodecor.c12
-rw-r--r--x11/xnodecor/pkg-descr12
-rw-r--r--x11/xnodecor/pkg-plist1
6 files changed, 66 insertions, 0 deletions
diff --git a/x11/xnodecor/Makefile b/x11/xnodecor/Makefile
new file mode 100644
index 000000000000..f5694c3447c8
--- /dev/null
+++ b/x11/xnodecor/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: xnodecor
+# Date created: 15 November 2002
+# Whom: Katsura Matsumoto <katsura@cc.okayama-u.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xnodecor
+PORTVERSION= 0.1
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.42.org/pub/wmx/contrib/
+DISTFILES= xnodecor.c
+
+MAINTAINER= katsura@cc.okayama-u.ac.jp
+COMMENT= Utility to set override_redirect in XWindowAttributes to True
+
+NO_WRKSUBDIR= yes
+USE_X_PREFIX= yes
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} ${FILESDIR}/Makefile ${WRKDIR}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}
+
+.include <bsd.port.mk>
diff --git a/x11/xnodecor/distinfo b/x11/xnodecor/distinfo
new file mode 100644
index 000000000000..72c3216bea7a
--- /dev/null
+++ b/x11/xnodecor/distinfo
@@ -0,0 +1 @@
+MD5 (xnodecor.c) = 0ad4261c221a221afc173f264b979ea1
diff --git a/x11/xnodecor/files/Makefile b/x11/xnodecor/files/Makefile
new file mode 100644
index 000000000000..36716bb8b1c8
--- /dev/null
+++ b/x11/xnodecor/files/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+CFLAGS= -I${X11BASE}/include
+LDFLAGS= -L${X11BASE}/lib
+LIBS= -lX11
+
+all: xnodecor
+
+xnodecor:
+ $(CC) -o xnodecor xnodecor.c $(CFLAGS) $(LDFLAGS) $(LIBS)
+
+install:
+ ${BSD_INSTALL_PROGRAM} xnodecor ${X11BASE}/bin
+
+clean:
+ rm -f *.rej a.out core xnodecor
diff --git a/x11/xnodecor/files/patch-xnodecor.c b/x11/xnodecor/files/patch-xnodecor.c
new file mode 100644
index 000000000000..162e3b4e3b1b
--- /dev/null
+++ b/x11/xnodecor/files/patch-xnodecor.c
@@ -0,0 +1,12 @@
+--- xnodecor.c.orig Wed Jan 13 01:55:20 1999
++++ xnodecor.c Mon Nov 11 23:15:42 2002
+@@ -39,7 +39,8 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>
+-
++#include <unistd.h>
++
+ #define WAIT_DEFAULT 0
+ #define WAIT_TIMEOUT 15
+ #define VERBOSE_DEFAULT 0
diff --git a/x11/xnodecor/pkg-descr b/x11/xnodecor/pkg-descr
new file mode 100644
index 000000000000..0aca645c81cf
--- /dev/null
+++ b/x11/xnodecor/pkg-descr
@@ -0,0 +1,12 @@
+This program sets attribute "override_redirect" to True for any window
+you've specified (using window name). Window Managers should ignore
+such windows; it's useful, for example, if you're using wmx Window Manager,
+and want to have a clock on every virtual screen and without any
+borders. Just add the following string to your X-startfile (after
+starting watch app):
+
+ xnodecor -w watch
+
+(assuming that your watch application has a window named "watch")
+
+WWW: http://sb.123.org/xnodecor.html
diff --git a/x11/xnodecor/pkg-plist b/x11/xnodecor/pkg-plist
new file mode 100644
index 000000000000..4f5f18e94dbe
--- /dev/null
+++ b/x11/xnodecor/pkg-plist
@@ -0,0 +1 @@
+bin/xnodecor