aboutsummaryrefslogtreecommitdiff
path: root/x11/xpyb/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-25 05:38:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-25 05:38:09 +0000
commitf996e95548af698b569ac29005cc536236c2cccd (patch)
treee8bd4b87c7f00e063c69859c09945aacd4a7f77e /x11/xpyb/Makefile
parente560e4ac41b58058c81dea02639c78ed9b1a6c63 (diff)
downloadports-f996e95548af698b569ac29005cc536236c2cccd.tar.gz
ports-f996e95548af698b569ac29005cc536236c2cccd.zip
Notes
Diffstat (limited to 'x11/xpyb/Makefile')
-rw-r--r--x11/xpyb/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11/xpyb/Makefile b/x11/xpyb/Makefile
new file mode 100644
index 000000000000..2994a17bb82b
--- /dev/null
+++ b/x11/xpyb/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: xpyb
+# Date created: 2008-08-27
+# Whom: Ashish Shukla <wahjava@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xpyb
+PORTVERSION= 1.0
+CATEGORIES= x11 python
+MASTER_SITES= http://xcb.freedesktop.org/%SUBDIR%/
+MASTER_SITE_SUBDIR= dist
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wahjava@gmail.com
+COMMENT= Python bindings to access X Window System protocol via libxcb
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcb-proto.pc:${PORTSDIR}/x11/xcb-proto
+LIB_DEPENDS= xcb.1:${PORTSDIR}/x11/libxcb
+
+USE_BZIP2= yes
+USE_PYTHON= 2.5+
+USE_GNOME= gnomehack
+PORTDOCS= README
+
+GNU_CONFIGURE=yes
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-I${LOCALBASE}/lib"
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>