aboutsummaryrefslogtreecommitdiff
path: root/x11/xscreensaver-gnome/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-08-03 06:53:12 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-08-03 06:53:12 +0000
commitbc23de35a1ec09012b82efec75c485c2f5c5f59a (patch)
treed31699d0111c3e142a388c12bef5ae03b5bfa240 /x11/xscreensaver-gnome/Makefile
parentab266afbfe3cd53b9ca6e449e854326a69bc875a (diff)
downloadports-bc23de35a1ec09012b82efec75c485c2f5c5f59a.tar.gz
ports-bc23de35a1ec09012b82efec75c485c2f5c5f59a.zip
Notes
Diffstat (limited to 'x11/xscreensaver-gnome/Makefile')
-rw-r--r--x11/xscreensaver-gnome/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/x11/xscreensaver-gnome/Makefile b/x11/xscreensaver-gnome/Makefile
index bb0b4bbfb788..f0b7ae6ccfa7 100644
--- a/x11/xscreensaver-gnome/Makefile
+++ b/x11/xscreensaver-gnome/Makefile
@@ -37,7 +37,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
OPTIONS?= PAM "Pluggable Authentication Module support" on \
- KEYRING "Enable GnomeKeyring/PAM integration" on \
+ KEYRING "Enable GnomeKeyring integration (needs PAM)" on \
ALL_FORTUNES "Enable support for all fortunes" off \
SETUID_HACKS "Install sonar hack suid so it can ping" off
@@ -90,22 +90,20 @@ MAN6?= anemone.6 anemotaxis.6 antinspect.6 antmaze.6 antspotlight.6 \
CONFIGURE_ARGS+= --with-fortune="/usr/games/fortune -sa"
.endif
-.if defined(WITH_PAM)
+.if defined(WITH_PAM) || defined(WITH_KEYRING)
CONFIGURE_ARGS+= --with-pam
PLIST_SUB+= PAM=""
+.else
+CONFIGURE_ARGS+= --without-pam
+PLIST_SUB+= PAM="@comment "
+.endif
+
.if defined(WITH_KEYRING)
SUB_LIST+= PAM_KEYRING=
RUN_DEPENDS+= ${LOCALBASE}/lib/pam_gnome_keyring.so:${PORTSDIR}/security/gnome-keyring
.else
SUB_LIST+= PAM_KEYRING=\#
.endif
-.else
-CONFIGURE_ARGS+= --without-pam
-PLIST_SUB+= PAM="@comment "
-.if defined(WITH_KEYRING)
-.warning Option KEYRING needs PAM, but PAM is disabled.
-.endif
-.endif
.if defined(WITH_SETUID_HACKS)
CONFIGURE_ARGS+= --with-setuid-hacks