aboutsummaryrefslogtreecommitdiff
path: root/x11/xscreensaver/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2003-09-07 23:50:12 +0000
committerDoug Barton <dougb@FreeBSD.org>2003-09-07 23:50:12 +0000
commit9253f0cd315de165d18e52b2b54f137d7ca3ccd2 (patch)
treea166abfa8453a86f0c7002dbf75ccc23483ecb10 /x11/xscreensaver/Makefile
parent9d41f399e3057fbfd0e8e2bd2c96f23fede99885 (diff)
downloadports-9253f0cd315de165d18e52b2b54f137d7ca3ccd2.tar.gz
ports-9253f0cd315de165d18e52b2b54f137d7ca3ccd2.zip
Notes
Diffstat (limited to 'x11/xscreensaver/Makefile')
-rw-r--r--x11/xscreensaver/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index 17c03190136e..cab39b41bb80 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -12,7 +12,7 @@
#************************************************************************
PORTNAME= xscreensaver
-PORTVERSION= 4.10
+PORTVERSION= 4.12
CATEGORIES?= x11
MASTER_SITES= http://www.jwz.org/xscreensaver/
@@ -31,13 +31,17 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-pam --with-gl --with-gle --with-xpm --with-xml \
--with-hackdir=${PREFIX}/bin/xscreensaver-hacks/ \
--with-configdir=${PREFIX}/share/xscreensaver/config/ \
- --with-jpeg=${LOCALBASE} --without-gnome --without-kerberos
+ --with-jpeg=${LOCALBASE} --without-gnome --without-kerberos \
+ --without-motif
.include <bsd.port.pre.mk>
.if defined(XS_WITH_ALL_FORTUNES)
CONFIGURE_ARGS+= --with-fortune="/usr/games/fortune -sa"
.endif
+.if defined(XS_WITH_SETUID_HACKS)
+CONFIGURE_ARGS+= --with-setuid-hacks
+.endif
.undef HAVE_GNOME
@@ -67,7 +71,8 @@ MAN1= anemone.1 ant.1 apollonian.1 atlantis.1 attraction.1 blaster.1 \
xmatrix.1 xrayswarm.1 xspirograph.1 xsublim.1 xteevee.1 zoom.1 \
endgame.1 glblur.1 halftone.1 barcode.1 eruption.1 flurry.1 metaballs.1 \
atunnel.1 piecewise.1 bouncingcow.1 flyingtoasters.1 glslideshow.1 \
- jigglypuff.1 klein.1 \
+ jigglypuff.1 klein.1 cloudlife.1 hypertorus.1 glmatrix.1 cubestorm.1 \
+ glknots.1 blocktube.1 flipflop.1 antspotlight.1 polytopes.1 \
xscreensaver-command.1 xscreensaver-demo.1 \
xscreensaver-getimage-file.1 xscreensaver-getimage-video.1 \
xscreensaver-getimage.1 xscreensaver-gl-helper.1 xscreensaver.1
@@ -85,14 +90,8 @@ pre-fetch:
post-patch:
@ ${CP} ${WRKSRC}/configure ${WRKSRC}/configure.Patched
@ ${SED} -e 's#-lpthread#${PTHREAD_LIBS}#g' \
+ -e 's#malloc.h#stdlib.h#g' \
${WRKSRC}/configure.Patched > ${WRKSRC}/configure
-.for file in extrusion.c
- @ ${CP} ${WRKSRC}/hacks/glx/${file} ${WRKSRC}/hacks/glx/${file}.Dist
- @ ${SED} -e 's/malloc.h/stdlib.h/g' ${WRKSRC}/hacks/glx/${file}.Dist > \
- ${WRKSRC}/hacks/glx/${file}
-.endfor
- @ ${CP} ${WRKSRC}/hacks/glx/klein.c ${WRKSRC}/hacks/glx/klein.c.presed
- @ ${SED} -e 's# ##' ${WRKSRC}/hacks/glx/klein.c.presed > ${WRKSRC}/hacks/glx/klein.c
post-install:
@(if test -x ${X11BASE}/bin/xscreensaver-hacks/webcollage-helper; then \