aboutsummaryrefslogtreecommitdiff
path: root/x11/xscreensaver/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2008-08-18 23:01:07 +0000
committerDoug Barton <dougb@FreeBSD.org>2008-08-18 23:01:07 +0000
commit1c24ede509e61df1761bdab8974df43f478f5712 (patch)
treeca4114bc3b071f87150085a3307bfd52b27c75be /x11/xscreensaver/Makefile
parent4872e8e138fe2e98ead58f9a1e8135e96db445e4 (diff)
downloadports-1c24ede509e61df1761bdab8974df43f478f5712.tar.gz
ports-1c24ede509e61df1761bdab8974df43f478f5712.zip
Notes
Diffstat (limited to 'x11/xscreensaver/Makefile')
-rw-r--r--x11/xscreensaver/Makefile39
1 files changed, 36 insertions, 3 deletions
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index 9c58422ce6cc..3f6054e9bc93 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xscreensaver
-PORTVERSION= 5.06
+PORTVERSION= 5.07
CATEGORIES?= x11
MASTER_SITES= http://www.jwz.org/xscreensaver/ \
http://dougbarton.us/Downloads/
@@ -33,7 +33,15 @@ CONFIGURE_ARGS= --with-gtk --with-gl --with-gle --with-pixbuf --with-xpm \
OPTIONS= ALL_FORTUNES "Run fortune with -sa argument" off \
KERBEROS "Add support for kerberos" off \
PAM "Add support for pam authentication" off \
- SETUID_HACKS "Install sonar hack suid so it can ping" off
+ SETUID_HACKS "Install sonar hack suid so it can ping" off \
+ SHEEP "Add extra port x11/electricsheep" off \
+ FIREF "Add extra port x11/fireflies" off \
+ XAOS1 "Add extra port graphics/xaos" off \
+ XDALI "Add extra port x11-clocks/xdaliclock" off \
+ XURTH "Add extra port astro/xearth" off \
+ XMOUN "Add extra port graphics/xmountains" off \
+ XPLAN "Add extra port astro/xplanet" off \
+ XSNOW "Add extra port x11/xsnow" off
.include <bsd.port.pre.mk>
@@ -56,6 +64,31 @@ PLIST_SUB+= PAM="@comment not installed: "
CONFIGURE_ARGS+= --with-setuid-hacks
.endif
+.if defined(WITH_SHEEP)
+RUN_DEPENDS+= electricsheep:${PORTSDIR}/x11/electricsheep
+.endif
+.if defined(WITH_FIREF)
+RUN_DEPENDS+= ${X11BASE}/bin/xscreensaver-hacks/fireflies:${PORTSDIR}/x11/fireflies
+.endif
+.if defined(WITH_XAOS1)
+RUN_DEPENDS+= xaos:${PORTSDIR}/graphics/xaos
+.endif
+.if defined(WITH_XDALI)
+RUN_DEPENDS+= xdaliclock:${PORTSDIR}/x11-clocks/xdaliclock
+.endif
+.if defined(WITH_XURTH)
+RUN_DEPENDS+= xearth:${PORTSDIR}/astro/xearth
+.endif
+.if defined(WITH_XMOUN)
+RUN_DEPENDS+= xmountains:${PORTSDIR}/graphics/xmountains
+.endif
+.if defined(WITH_XPLAN)
+RUN_DEPENDS+= xplanet:${PORTSDIR}/astro/xplanet
+.endif
+.if defined(WITH_XSNOW)
+RUN_DEPENDS+= xsnow:${PORTSDIR}/x11/xsnow
+.endif
+
.undef HAVE_GNOME
CONFIGURE_ENV= X_CFLAGS=-I${LOCALBASE}/include/gnome-xml
@@ -115,7 +148,6 @@ pre-fetch:
@sleep 2
.endif
-USE_DOS2UNIX= hacks/glx/topblock.c
post-patch:
@ ${CP} ${WRKSRC}/configure ${WRKSRC}/configure.Patched
@ ${SED} -e 's#-lpthread#${PTHREAD_LIBS}#g' \
@@ -136,6 +168,7 @@ post-patch:
.endif
post-install:
+ ${INSTALL_DATA} ${FILESDIR}/*.xml ${DATADIR}/config/
@(if test -x ${LOCALBASE}/bin/xscreensaver-hacks/webcollage-helper; then \
${ECHO} "bin/xscreensaver-hacks/webcollage-helper" | \
${CAT} - ${TMPPLIST} > ${TMPPLIST}.cat && \