aboutsummaryrefslogtreecommitdiff
path: root/x11/xscreensaver/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2011-10-01 06:05:36 +0000
committerDoug Barton <dougb@FreeBSD.org>2011-10-01 06:05:36 +0000
commit03e84024306e13f4598db9880f8e150ace28ddfa (patch)
treee20a8665e569a8968dc00eeebc798cff645b63f1 /x11/xscreensaver/Makefile
parent97a3b067746388d841fef4af100c1d7a76395659 (diff)
downloadports-03e84024306e13f4598db9880f8e150ace28ddfa.tar.gz
ports-03e84024306e13f4598db9880f8e150ace28ddfa.zip
Notes
Diffstat (limited to 'x11/xscreensaver/Makefile')
-rw-r--r--x11/xscreensaver/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index 7889873ea03c..7df96997d421 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -1,12 +1,12 @@
-# New ports collection makefile for: xscreensaver
-# Date created: 10 July 1995
-# Whom: dom@myrddin.demon.co.uk
+# New ports collection makefile for: xscreensaver
+# Date created: 10 July 1995
+# Whom: dom@myrddin.demon.co.uk
#
# $FreeBSD$
#
PORTNAME= xscreensaver
-PORTVERSION= 5.14
+PORTVERSION= 5.15
CATEGORIES?= x11
MASTER_SITES= http://www.jwz.org/xscreensaver/ \
http://dougbarton.us/Downloads/
@@ -20,6 +20,9 @@ LIB_DEPENDS= gle.4:${PORTSDIR}/graphics/gle \
xml2.5:${PORTSDIR}/textproc/libxml2 \
glade-2.0.0:${PORTSDIR}/devel/libglade2
+RUN_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww \
+ giftopnm:${PORTSDIR}/graphics/netpbm
+
MAKE_JOBS_SAFE= yes
USE_XORG= xpm
@@ -126,6 +129,7 @@ MAN6= anemone.6 anemotaxis.6 antinspect.6 antmaze.6 antspotlight.6 \
xspirograph.6 zoom.6 cwaves.6 glcells.6 voronoi.6 \
abstractile.6 moebiusgears.6 lockward.6 cubicgrid.6 hypnowheel.6 \
lcdscrub.6 skytentacles.6 photopile.6 rubikblocks.6 surfaces.6 \
+ companioncube.6 hilbert.6 tronbit.6 \
xscreensaver-gl-helper.6
.if ${ARCH} == "amd64"
@@ -138,6 +142,9 @@ post-patch:
-e 's#malloc.h#stdlib.h#g' \
-e 's#/usr/X11R6#${LOCALBASE}#g' \
${WRKSRC}/configure.Patched > ${WRKSRC}/configure
+ @ ${CP} ${WRKSRC}/hacks/vidwhacker ${WRKSRC}/hacks/vidwhacker.presed
+ @ ${SED} -e '329s#.*# $$fn = "$$imagedir/$$fn";#' \
+ ${WRKSRC}/hacks/vidwhacker.presed > ${WRKSRC}/hacks/vidwhacker
.if defined(WITH_PAM)
.for f in driver/passwd-pam.c driver/xscreensaver.man
@ ${CP} ${WRKSRC}/${f} ${WRKSRC}/${f}.presed