aboutsummaryrefslogtreecommitdiff
path: root/x11/xscreensaver/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2007-12-11 20:03:07 +0000
committerDoug Barton <dougb@FreeBSD.org>2007-12-11 20:03:07 +0000
commit1122ef3c351e044318c58f789239027f94a0e59f (patch)
tree221d1e3aaefc9d401d13c5a46fb5bc57a89ffcfb /x11/xscreensaver/Makefile
parentb26a66bd2cf7900f1419a774a3595757887cfe1c (diff)
Update to version 5.04, which contains the usual combination of
a few new screesavers and miscellaneous bug fixes. For the port: 1. Update the CONFIGURE_ARGS for the new xorg and other options 2. Add an OPTION to add --with-kerberos 3. Add an OPTION for PAM support, and delete stuff that was designed to disable PAM. 4. Related to above, add a policy file for PAM that is relevant to FreeBSD, and simply copy that over the distribution's and allow the normal install method to work.
Notes
Notes: svn path=/head/; revision=202973
Diffstat (limited to 'x11/xscreensaver/Makefile')
-rw-r--r--x11/xscreensaver/Makefile32
1 files changed, 28 insertions, 4 deletions
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index 368b2eab367a..a0f535688909 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xscreensaver
-PORTVERSION= 5.03
+PORTVERSION= 5.04
CATEGORIES?= x11
MASTER_SITES= http://www.jwz.org/xscreensaver/ \
http://dougbarton.us/Downloads/
@@ -23,13 +23,16 @@ USE_XPM= yes
USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-pam --with-gl --with-gle --with-xpm --with-xml \
+CONFIGURE_ARGS= --with-gtk --with-gl --with-gle --with-pixbuf --with-xpm \
+ --with-jpeg=${LOCALBASE} --with-xshm-ext --with-xdbe-ext \
--with-hackdir=${PREFIX}/bin/xscreensaver-hacks/ \
--with-configdir=${PREFIX}/share/xscreensaver/config/ \
- --with-jpeg=${LOCALBASE} --without-gnome --without-kerberos \
- --without-motif
+ --with-dpms-ext --with-xinerama-ext --with-xf86vmode-ext \
+ --with-xf86gamma-ext --with-randr-ext --enable-locking
OPTIONS= ALL_FORTUNES "Run fortune with -sa argument" off \
+ KERBEROS "Add support for kerberos" off \
+ PAM "Add support for pam authentication" off \
SETUID_HACKS "Install sonar hack suid so it can ping" off
.include <bsd.port.pre.mk>
@@ -37,6 +40,18 @@ OPTIONS= ALL_FORTUNES "Run fortune with -sa argument" off \
.if defined(WITH_ALL_FORTUNES)
CONFIGURE_ARGS+= --with-fortune="/usr/games/fortune -sa"
.endif
+.if defined(WITH_KERBEROS)
+CONFIGURE_ARGS+= --with-kerberos
+.else
+CONFIGURE_ARGS+= --without-kerberos
+.endif
+.if defined(WITH_PAM)
+CONFIGURE_ARGS+= --with-pam
+PLIST_SUB+= PAM=""
+.else
+CONFIGURE_ARGS+= --without-pam
+PLIST_SUB+= PAM="@comment not installed: "
+.endif
.if defined(WITH_SETUID_HACKS)
CONFIGURE_ARGS+= --with-setuid-hacks
.endif
@@ -82,6 +97,7 @@ MAN6= anemone.6 anemotaxis.6 antinspect.6 antmaze.6 antspotlight.6 \
wander.6 webcollage.6 whirlwindwarp.6 whirlygig.6 worm.6 wormhole.6 \
xanalogtv.6 xflame.6 xjack.6 xlyap.6 xmatrix.6 xrayswarm.6 \
xspirograph.6 xsublim.6 zoom.6 cwaves.6 glcells.6 voronoi.6 \
+ abstractile.6 moebiusgears.6 lockward.6 \
xscreensaver-gl-helper.6
.if ${ARCH} == "amd64"
@@ -105,6 +121,14 @@ post-patch:
-e 's#malloc.h#stdlib.h#g' \
-e 's#/usr/X11R6#${LOCALBASE}#g' \
${WRKSRC}/configure.Patched > ${WRKSRC}/configure
+.if defined(WITH_PAM)
+.for f in driver/passwd-pam.c driver/xscreensaver.man
+ @ ${CP} ${WRKSRC}/${f} ${WRKSRC}/${f}.presed
+ @ ${SED} -e "s#/etc/pam.d#${PREFIX}/etc/pam.d#g" \
+ ${WRKSRC}/${f}.presed > ${WRKSRC}/${f}
+.endfor
+ @ ${CP} ${FILESDIR}/xscreensaver.pam ${WRKSRC}/driver/xscreensaver.pam
+.endif
post-install:
@(if test -x ${LOCALBASE}/bin/xscreensaver-hacks/webcollage-helper; then \