aboutsummaryrefslogtreecommitdiff
path: root/x11/xsel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-13 17:33:04 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-13 17:33:04 +0000
commit08cfab34a4dfa073e373f9de40bbb61e53da9638 (patch)
treec6711312bae3c56a2598c5641a5cc5315412210b /x11/xsel
parent9b7be7aab045781c3854ce74d9baa95bbf9cf9f2 (diff)
downloadports-08cfab34a4dfa073e373f9de40bbb61e53da9638.tar.gz
ports-08cfab34a4dfa073e373f9de40bbb61e53da9638.zip
Notes
Diffstat (limited to 'x11/xsel')
-rw-r--r--x11/xsel/Makefile36
-rw-r--r--x11/xsel/distinfo2
-rw-r--r--x11/xsel/pkg-comment1
-rw-r--r--x11/xsel/pkg-descr5
-rw-r--r--x11/xsel/pkg-plist1
5 files changed, 45 insertions, 0 deletions
diff --git a/x11/xsel/Makefile b/x11/xsel/Makefile
new file mode 100644
index 000000000000..078afaa293bd
--- /dev/null
+++ b/x11/xsel/Makefile
@@ -0,0 +1,36 @@
+# ex:ts=8
+# Ports collection makefile for: xsel
+# Date created: Jan 14, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xsel
+PORTVERSION= 0.04.1
+CATEGORIES= x11
+MASTER_SITES= http://www.niksula.cs.hut.fi/~vherva/xsel/
+DISTFILES= xsel.c xsel.man
+
+MAINTAINER= ports@FreeBSD.org
+
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKDIR}
+USE_XLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+NO_WRKSUBDIR= yes
+CFLAGS+= `${GTK_CONFIG} --cflags`
+LDFLAGS+= `${GTK_CONFIG} --libs` -lXt -lXaw
+
+MAN1= xsel.1
+
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} xsel.c -o xsel ${LDFLAGS})
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xsel ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xsel.man ${MAN1PREFIX}/man/man1/xsel.1
+
+.include <bsd.port.mk>
diff --git a/x11/xsel/distinfo b/x11/xsel/distinfo
new file mode 100644
index 000000000000..9819e4df6c77
--- /dev/null
+++ b/x11/xsel/distinfo
@@ -0,0 +1,2 @@
+MD5 (xsel.c) = 8d655ed634d3649cd6b7052a4e28ff9b
+MD5 (xsel.man) = 976e843b4900e626dd7d966e6723b543
diff --git a/x11/xsel/pkg-comment b/x11/xsel/pkg-comment
new file mode 100644
index 000000000000..312a366abf41
--- /dev/null
+++ b/x11/xsel/pkg-comment
@@ -0,0 +1 @@
+Access X selection from command line
diff --git a/x11/xsel/pkg-descr b/x11/xsel/pkg-descr
new file mode 100644
index 000000000000..a28700be1d62
--- /dev/null
+++ b/x11/xsel/pkg-descr
@@ -0,0 +1,5 @@
+xsel is a quick hack to give access to the X selection from the command line.
+You can paste stuff from the X selection to stdout and copy stuff from stdin
+to X selection.
+
+WWW: http://www.niksula.cs.hut.fi/~vherva/xsel/
diff --git a/x11/xsel/pkg-plist b/x11/xsel/pkg-plist
new file mode 100644
index 000000000000..f42e4ea51e66
--- /dev/null
+++ b/x11/xsel/pkg-plist
@@ -0,0 +1 @@
+bin/xsel