aboutsummaryrefslogtreecommitdiff
path: root/x11/xterm
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-01-23 08:43:08 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-01-23 08:43:08 +0000
commitd06f77a32aa04d5e8b57a5d7f0a64d0590567a26 (patch)
tree9077de7150a38c2c4bb4d624f862ac2190c401a1 /x11/xterm
parente2c9589d20e958af1e4bce813793a6c0db754c0d (diff)
downloadports-d06f77a32aa04d5e8b57a5d7f0a64d0590567a26.tar.gz
ports-d06f77a32aa04d5e8b57a5d7f0a64d0590567a26.zip
Notes
Diffstat (limited to 'x11/xterm')
-rw-r--r--x11/xterm/Makefile25
1 files changed, 14 insertions, 11 deletions
diff --git a/x11/xterm/Makefile b/x11/xterm/Makefile
index 8fd422782238..bb3f05a6bd43 100644
--- a/x11/xterm/Makefile
+++ b/x11/xterm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xterm
PORTVERSION= 301
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= ftp://invisible-island.net/xterm/:src1 \
CRITICAL:src1 CRITICAL:src2
@@ -15,7 +16,6 @@ COMMENT= Terminal emulator for the X Window System
CONFLICTS= x11iraf-[0-9]*
-USES= desktop-file-utils
USE_XORG= xaw xft
GNU_CONFIGURE= yes
@@ -26,7 +26,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
ICONVERSION= 1
-OPTIONS_DEFINE= WCHAR LUIT DECTERM PCRE DABBREV 256COLOR SIXEL
+OPTIONS_DEFINE= WCHAR LUIT DECTERM PCRE DABBREV 256COLOR SIXEL GNOME
DABBREV_DESC= Enable support for dabbrev-expand
DECTERM_DESC= Enable DECterm Locator support
@@ -38,14 +38,15 @@ WCHAR_DESC= Enable wide-character support
OPTIONS_DEFAULT=WCHAR LUIT 256COLOR
256COLOR_CONFIGURE_ENABLE= 256-color
-LUIT_BUILD_DEPENDS= luit:${PORTSDIR}/x11/luit
-LUIT_CONFIGURE_ENABLE= luit
-WCHAR_CONFIGURE_ENABLE= wide-chars
+LUIT_BUILD_DEPENDS= luit:${PORTSDIR}/x11/luit
+LUIT_CONFIGURE_ENABLE= luit
+WCHAR_CONFIGURE_ENABLE= wide-chars
DECTERM_CONFIGURE_ENABLE= dec-locator
-PCRE_CONFIGURE_WITH= pcre
-PCRE_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+PCRE_CONFIGURE_WITH= pcre
+PCRE_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
DABBREV_CONFIGURE_ENABLE= dabbrev
-SIXEL_CONFIGURE_ENABLE= sixel-graphics
+SIXEL_CONFIGURE_ENABLE= sixel-graphics
+GNOME_USES= desktop-file-utils
.include <bsd.port.options.mk>
@@ -54,14 +55,16 @@ LIB_DEPENDS+= utempter:${PORTSDIR}/sysutils/libutempter
.endif
post-extract:
- @${CP} ${WRKDIR}/bsd-xterm-icons-1/*.png ${WRKDIR}/bsd-xterm-icons-1/*.xpm \
- ${WRKSRC}/icons/
+ @${CP} ${WRKDIR}/bsd-xterm-icons-1/*.png \
+ ${WRKDIR}/bsd-xterm-icons-1/*.xpm \
+ ${WRKSRC}/icons/
post-install:
.for f in koi8rxterm resize uxterm xterm
@${CHMOD} ${BINMODE} ${STAGEDIR}${PREFIX}/bin/${f}
.endfor
- @${INSTALL_DATA} ${WRKSRC}/xterm.desktop ${STAGEDIR}${PREFIX}/share/applications/
+ @${INSTALL_DATA} ${WRKSRC}/xterm.desktop \
+ ${STAGEDIR}${PREFIX}/share/applications/
.if ${PORT_OPTIONS:MWCHAR}
@${CAT} ${PKGMESSAGE}