aboutsummaryrefslogtreecommitdiff
path: root/x11/xterm
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-06-20 20:28:34 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-06-20 20:28:34 +0000
commitf5391a19e9e2099d00809c4fc79b79c020f1abe8 (patch)
treebc922a3a0a7183a3bd93e30b6ed63eda529a5373 /x11/xterm
parent199d8b453191159a5ce25b64f22c31db335432a3 (diff)
downloadports-f5391a19e9e2099d00809c4fc79b79c020f1abe8.tar.gz
ports-f5391a19e9e2099d00809c4fc79b79c020f1abe8.zip
Notes
Diffstat (limited to 'x11/xterm')
-rw-r--r--x11/xterm/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/x11/xterm/Makefile b/x11/xterm/Makefile
index 0677d155b004..15ec9c7cb4b7 100644
--- a/x11/xterm/Makefile
+++ b/x11/xterm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xterm
PORTVERSION= 243
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= ftp://invisible-island.net/xterm/ \
http://voodoo.bawue.com/download/
@@ -24,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+=--with-utempter --enable-narrowproto
-.if defined(WITH_WIDE_CHARS)
+.if !defined(WITHOUT_WIDE_CHARS)
CONFIGURE_ARGS+= --enable-wide-chars --enable-luit
.endif
@@ -36,5 +37,22 @@ MAN1= resize.1 koi8rxterm.1 uxterm.1 xterm.1
post-install:
@${CHMOD} 4711 ${PREFIX}/bin/xterm
+.if !defined(WITHOUT_WIDE_CHARS)
+ @${ECHO_MSG}
+ @${ECHO_MSG} '********************************************************'
+ @${ECHO_MSG} ' NOTE: you installed xterm with wide chars support.'
+ @${ECHO_MSG} ' This introduces some limitations comparing to the'
+ @${ECHO_MSG} ' plain single chars version: this version of xterm'
+ @${ECHO_MSG} ' will use UTF-8 charset for selection buffers,'
+ @${ECHO_MSG} ' breaking 8-bit copy/paste support unless you are'
+ @${ECHO_MSG} ' using UTF-8 or ISO8859-1 locale. If you want'
+ @${ECHO_MSG} ' 8-bit charset selections to work as before, use'
+ @${ECHO_MSG} ' "eightBitSelectTypes" XTerm resource setting.'
+ @${ECHO_MSG}
+ @${ECHO_MSG} ' For further information refer to the SELECT/PASTE'
+ @${ECHO_MSG} ' section of xterm(1) manual page.'
+ @${ECHO_MSG} '********************************************************'
+ @${ECHO_MSG}
+.endif
.include <bsd.port.mk>