aboutsummaryrefslogtreecommitdiff
path: root/x11/xtermcontrol/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-12-25 08:28:21 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-12-25 08:28:21 +0000
commit90f1384bebcfa865cf91faa04a438bf01f17a8a1 (patch)
treef8a051a1fcb51f1b771442fa45daccf2ce3842f8 /x11/xtermcontrol/Makefile
parent342e4c1c46f9c9162918ff3765b518dbe5ce5d80 (diff)
downloadports-90f1384bebcfa865cf91faa04a438bf01f17a8a1.tar.gz
ports-90f1384bebcfa865cf91faa04a438bf01f17a8a1.zip
Notes
Diffstat (limited to 'x11/xtermcontrol/Makefile')
-rw-r--r--x11/xtermcontrol/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11/xtermcontrol/Makefile b/x11/xtermcontrol/Makefile
new file mode 100644
index 000000000000..f8ea7711a7e8
--- /dev/null
+++ b/x11/xtermcontrol/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: xtermcontrol
+# Date created: 23.12.2004
+# Whom: krion
+#
+# $FreeBSD$
+#
+
+PORTNAME= xtermcontrol
+PORTVERSION= 2.7
+CATEGORIES= x11
+MASTER_SITES= http://www.thrysoee.dk/xtermcontrol/
+
+MAINTAINER= krion@FreeBSD.org
+COMMENT= Tool for dynamic control of xterm properties
+
+RUN_DEPENDS= xterm-static:${PORTSDIR}/x11/xterm
+
+USE_X_PREFIX= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
+ LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
+
+PLIST_FILES= bin/xtermcontrol
+MAN1= ${PORTNAME}.1
+
+.include <bsd.port.mk>