aboutsummaryrefslogtreecommitdiff
path: root/x11/yad
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2012-10-03 22:23:20 +0000
committerRenato Botelho <garga@FreeBSD.org>2012-10-03 22:23:20 +0000
commit1d787fb70c8a1e836b35009d72770e078ca360eb (patch)
treee26a83a1b4ae1be7a0a94ebff9e77f0fea841d82 /x11/yad
parent2cdf43711c2ac861567bd5410bc3ff7e8a84ab2e (diff)
downloadports-1d787fb70c8a1e836b35009d72770e078ca360eb.tar.gz
ports-1d787fb70c8a1e836b35009d72770e078ca360eb.zip
Notes
Diffstat (limited to 'x11/yad')
-rw-r--r--x11/yad/Makefile54
-rw-r--r--x11/yad/distinfo2
-rw-r--r--x11/yad/files/patch-src__util.c12
-rw-r--r--x11/yad/files/patch-src__yad.h11
-rw-r--r--x11/yad/pkg-descr3
-rw-r--r--x11/yad/pkg-plist14
6 files changed, 96 insertions, 0 deletions
diff --git a/x11/yad/Makefile b/x11/yad/Makefile
new file mode 100644
index 000000000000..ad6c0e6fa46c
--- /dev/null
+++ b/x11/yad/Makefile
@@ -0,0 +1,54 @@
+# $FreeBSD$
+
+PORTNAME= yad
+PORTVERSION= 0.17.1.1
+CATEGORIES= x11 gnome
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= danilogondolfo@gmail.com
+COMMENT= Display GNOME dialogs from the command line
+
+USE_GMAKE= yes
+USE_XZ= yes
+GNU_CONFIGURE= yes
+INSTALLS_OMF= yes
+INSTALLS_ICONS= yes
+CONFIGURE_ENV+= DATADIRNAME=share
+
+MAKE_JOBS_SAFE= yes
+
+MAN1= yad.1
+
+OPTIONS_DEFINE= NLS
+
+OPTIONS_SINGLE= GTK
+OPTIONS_SINGLE_GTK= GTK2 GTK3
+
+OPTIONS_DEFAULT= GTK2
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
+.else
+PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+= --disable-nls
+.endif
+
+.if ${PORT_OPTIONS:MGTK3}
+USE_GNOME= gtk30
+CONFIGURE_ARGS+= --with-gtk=gtk3
+.endif
+
+.if ${PORT_OPTIONS:MGTK2}
+USE_GNOME= gtk20
+CONFIGURE_ARGS+= --with-gtk=gtk2
+.endif
+
+post-configure:
+.if empty(PORT_OPTIONS:MNLS)
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/ s/ po//' ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/yad/distinfo b/x11/yad/distinfo
new file mode 100644
index 000000000000..33744bcdb07b
--- /dev/null
+++ b/x11/yad/distinfo
@@ -0,0 +1,2 @@
+SHA256 (yad-0.17.1.1.tar.xz) = eeaef10438dfb7f0d8d76598cd63735ade6957e767d8d7648174c72010e099fe
+SIZE (yad-0.17.1.1.tar.xz) = 207032
diff --git a/x11/yad/files/patch-src__util.c b/x11/yad/files/patch-src__util.c
new file mode 100644
index 000000000000..932923c40e06
--- /dev/null
+++ b/x11/yad/files/patch-src__util.c
@@ -0,0 +1,12 @@
+--- ../yad-0.17.1.1-a/src/util.c 2012-02-28 07:18:06.000000000 -0300
++++ src/util.c 2012-10-01 17:09:25.640983063 -0300
+@@ -187,7 +187,7 @@
+ return pb;
+ }
+
+-inline void
++void
+ strip_new_line (gchar *str)
+ {
+ gint nl = strlen (str) - 1;
+diff -ruN ../yad-0.17.1.1-a/src/yad.h src/yad.h
diff --git a/x11/yad/files/patch-src__yad.h b/x11/yad/files/patch-src__yad.h
new file mode 100644
index 000000000000..d97359043a69
--- /dev/null
+++ b/x11/yad/files/patch-src__yad.h
@@ -0,0 +1,11 @@
+--- ../yad-0.17.1.1-a/src/yad.h 2012-02-28 07:09:00.000000000 -0300
++++ src/yad.h 2012-10-01 17:09:46.007019884 -0300
+@@ -395,7 +395,7 @@
+
+ GdkPixbuf * get_pixbuf (gchar *name, YadIconSize size);
+
+-inline void strip_new_line (gchar *str);
++void strip_new_line (gchar *str);
+ gchar **split_arg (const gchar *str);
+
+ char *escape_markup (char *str);
diff --git a/x11/yad/pkg-descr b/x11/yad/pkg-descr
new file mode 100644
index 000000000000..5f377dba89f8
--- /dev/null
+++ b/x11/yad/pkg-descr
@@ -0,0 +1,3 @@
+Yad (yet another dialog) is a fork of Zenity with
+many improvements, such as custom buttons, additional
+dialogs, pop-up menu in notification icon and more.
diff --git a/x11/yad/pkg-plist b/x11/yad/pkg-plist
new file mode 100644
index 000000000000..615e34df67a2
--- /dev/null
+++ b/x11/yad/pkg-plist
@@ -0,0 +1,14 @@
+bin/yad
+share/aclocal/yad.m4
+share/icons/hicolor/128x128/apps/yad.png
+share/icons/hicolor/16x16/apps/yad.png
+share/icons/hicolor/24x24/apps/yad.png
+share/icons/hicolor/32x32/apps/yad.png
+share/icons/hicolor/48x48/apps/yad.png
+share/icons/hicolor/96x96/apps/yad.png
+%%NLS%%share/locale/de/LC_MESSAGES/yad.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/yad.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/yad.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/yad.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/yad.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/yad.mo