aboutsummaryrefslogtreecommitdiff
path: root/x11/yeahconsole
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-02 19:20:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-02 19:20:41 +0000
commit64987044a46612ef63d3b1d482d01e0d3cb0a3e9 (patch)
tree5b5c7be33dbb566ebb0d36105d8c6a6b9a2082b2 /x11/yeahconsole
parent52a7c00fea05659ae8688749763932a4056ba8b0 (diff)
downloadports-64987044a46612ef63d3b1d482d01e0d3cb0a3e9.tar.gz
ports-64987044a46612ef63d3b1d482d01e0d3cb0a3e9.zip
YeahConsole turns an xterm into a gamelike console.
This means it will slide down from top of your screen if you hit a shortcut key. WWW: http://phrat.de/yeahtools.html PR: ports/123252 Submitted by: Dmitry Klimov <lazyklimm@gmail.com>
Notes
Notes: svn path=/head/; revision=212491
Diffstat (limited to 'x11/yeahconsole')
-rw-r--r--x11/yeahconsole/Makefile20
-rw-r--r--x11/yeahconsole/distinfo3
-rw-r--r--x11/yeahconsole/files/patch-Makefile37
-rw-r--r--x11/yeahconsole/pkg-descr5
4 files changed, 65 insertions, 0 deletions
diff --git a/x11/yeahconsole/Makefile b/x11/yeahconsole/Makefile
new file mode 100644
index 000000000000..18da92308940
--- /dev/null
+++ b/x11/yeahconsole/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: yeahconsole
+# Date created: 30 April 2008
+# Whom: asami
+#
+# $FreeBSD$
+#
+
+PORTNAME= yeahconsole
+PORTVERSION= 0.3.4
+CATEGORIES= x11
+MASTER_SITES= http://phrat.de/
+
+MAINTAINER= lazyklimm@gmail.com
+COMMENT= quake console-like extension for X terminals
+
+USE_XORG= x11
+
+PLIST_FILES= bin/yeahconsole
+
+.include <bsd.port.mk>
diff --git a/x11/yeahconsole/distinfo b/x11/yeahconsole/distinfo
new file mode 100644
index 000000000000..98faa43c408e
--- /dev/null
+++ b/x11/yeahconsole/distinfo
@@ -0,0 +1,3 @@
+MD5 (yeahconsole-0.3.4.tar.gz) = 83a2367f9b4857fed02464b0e8a6595a
+SHA256 (yeahconsole-0.3.4.tar.gz) = fcf3481f78a263a70f1cb5163630fc22e78bb0915013eb05689c6f4aeb0583ef
+SIZE (yeahconsole-0.3.4.tar.gz) = 12281
diff --git a/x11/yeahconsole/files/patch-Makefile b/x11/yeahconsole/files/patch-Makefile
new file mode 100644
index 000000000000..6df806381d5a
--- /dev/null
+++ b/x11/yeahconsole/files/patch-Makefile
@@ -0,0 +1,37 @@
+--- Makefile.orig 2006-01-14 18:54:05.000000000 +0300
++++ Makefile 2008-04-30 12:23:01.000000000 +0400
+@@ -5,26 +5,26 @@
+
+ PREFIX = /usr/local
+
+-LIBS = -lX11
+-INCLUDES = -I/usr/X11R6/include
+-LIB_DIRS = -L/usr/X11R6/lib
+-FLAGS = -Os -Wall
++LIBS = -lX11
++INCLUDES = -I/usr/local/include
++LIB_DIRS = -L/usr/local/lib
++CFLAGS? = -Os -Wall
+
+ OBJECTS := yeahconsole.o
+ SOURCES := yeahconsole.c
+
+ $(TARGET): $(OBJECTS)
+- $(CC) $(DEFINES) $(INCLUDES) $(LIB_DIRS) $(LIBS) -o $@ $<
++ $(CC) $(DEFINES) $(INCLUDES) $(LIB_DIRS) $(LIBS) -o $@ $(SOURCES)
+ strip $@
+
+ $(OBJECTS): $(SOURCES)
+- $(CC) $(FLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
+-
++ $(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $(SOURCES)
++all: $(TARGET)
+ clean:
+ rm -rf $(TARGET) $(OBJECTS)
+
+ install: $(TARGET) $(MAN)
+- $(INSTALL) -o root -g root -m 0755 $(TARGET) $(PREFIX)/bin
++ $(INSTALL) -o root -g wheel -m 0755 $(TARGET) $(PREFIX)/bin
+
+
+ uninstall:
diff --git a/x11/yeahconsole/pkg-descr b/x11/yeahconsole/pkg-descr
new file mode 100644
index 000000000000..5bbd42af3dfd
--- /dev/null
+++ b/x11/yeahconsole/pkg-descr
@@ -0,0 +1,5 @@
+YeahConsole turns an xterm into a gamelike console.
+This means it will slide down from top of your screen
+if you hit a shortcut key.
+
+WWW: http://phrat.de/yeahtools.html