aboutsummaryrefslogtreecommitdiff
path: root/x11/zenity/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-03-02 04:50:08 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-03-02 04:50:08 +0000
commit12368b9d5cfd66bfa2f57a3bbd1c91bda1a8f167 (patch)
treed332f46b5d5eb96633de17b7d5a06b0532bfd2e3 /x11/zenity/Makefile
parent49eac03ebbee20b2ca2d9116766ffc862d9cf722 (diff)
Notes
Diffstat (limited to 'x11/zenity/Makefile')
-rw-r--r--x11/zenity/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11/zenity/Makefile b/x11/zenity/Makefile
new file mode 100644
index 000000000000..e57ffe4345c1
--- /dev/null
+++ b/x11/zenity/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: zenity
+# Date created: 01 Mar 2003
+# Whom: Franz Klammer <klammer@webonaut.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zenity
+PORTVERSION= 1.0
+CATEGORIES= x11 gnome
+MASTER_SITES= http://ftp.acc.umu.se/pub/GNOME/sources/zenity/1.0/
+
+MAINTAINER= klammer@webonaut.com
+COMMENT= Display GNOME dialogs from the command line
+
+LIB_DEPEND= gconf-2:${PORTSDIR}/devel/gconf2 \
+ gnomecanvas-2.200:${PORTSDIR}/graphics/libgnomecanvas \
+ popt.0:${PORTSDIR}/devel/popt
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+
+pre-configure:
+ @${FIND} ${WRKSRC} -name Makefile.in | xargs ${REINPLACE_CMD} 's|@DATADIRNAME@|share|'
+
+.include <bsd.port.mk>