aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorEric Turgeon <ericbsd@FreeBSD.org>2018-10-18 18:52:17 +0000
committerEric Turgeon <ericbsd@FreeBSD.org>2018-10-18 18:52:17 +0000
commit452dedbc6ce70bd466a1fcd7f72d67acac5c7c06 (patch)
treec8e877e4581675ae12e35e98a21382e2c56f28ab /x11
parent75a030f67617d2fe2dbae487124443095138ea62 (diff)
downloadports-452dedbc6ce70bd466a1fcd7f72d67acac5c7c06.tar.gz
ports-452dedbc6ce70bd466a1fcd7f72d67acac5c7c06.zip
add port x11/py-xcffib
xcffib is intended to be a (mostly) drop-in replacement for xpyb. xpyb has an inactive upstream, several memory leaks, is python2 only and doesn't have pypy support. xcffib is a binding which uses cffi, which mitigates some of the issues described above. xcffib also builds bindings for 27 of the 29 (xprint and xkb are missing) X extensions in 1.10. Approved by: wg (mentor)
Notes
Notes: svn path=/head/; revision=482351
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/py-xcffib/Makefile25
-rw-r--r--x11/py-xcffib/distinfo3
-rw-r--r--x11/py-xcffib/pkg-descr7
4 files changed, 36 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 43f9833d067f..570320aaf469 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -279,6 +279,7 @@
SUBDIR += py-pyvirtualdisplay
SUBDIR += py-qt4-opengl
SUBDIR += py-qt5-opengl
+ SUBDIR += py-xcffib
SUBDIR += py-xdot
SUBDIR += py-xdot06
SUBDIR += qimageblitz
diff --git a/x11/py-xcffib/Makefile b/x11/py-xcffib/Makefile
new file mode 100644
index 000000000000..01f8b05f63c8
--- /dev/null
+++ b/x11/py-xcffib/Makefile
@@ -0,0 +1,25 @@
+# Created by: Eric Turgeon <ericbsd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= xcffib
+PORTVERSION= 0.6.0
+CATEGORIES= x11 python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ericbsd@FreeBSD.org
+COMMENT= Xcffib is a replacement for xpyb, also is a XCB python binding
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libxcb.so:x11/libxcb
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.1.0:devel/py-cffi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/x11/py-xcffib/distinfo b/x11/py-xcffib/distinfo
new file mode 100644
index 000000000000..9e3349ea51cb
--- /dev/null
+++ b/x11/py-xcffib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539873693
+SHA256 (xcffib-0.6.0.tar.gz) = 36142cb72535933e8e1ed39ff2c45559fa7038823bd6be6961ef8ee5bb0f6912
+SIZE (xcffib-0.6.0.tar.gz) = 84360
diff --git a/x11/py-xcffib/pkg-descr b/x11/py-xcffib/pkg-descr
new file mode 100644
index 000000000000..d69e1a258809
--- /dev/null
+++ b/x11/py-xcffib/pkg-descr
@@ -0,0 +1,7 @@
+xcffib is intended to be a (mostly) drop-in replacement for xpyb. xpyb has
+an inactive upstream, several memory leaks, is python2 only and doesn't have
+pypy support. xcffib is a binding which uses cffi, which mitigates some of
+the issues described above. xcffib also builds bindings for 27 of the 29
+(xprint and xkb are missing) X extensions in 1.10.
+
+WWW: https://github.com/tych0/xcffib