aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2000-03-31 18:28:30 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2000-03-31 18:28:30 +0000
commit5754f0ce52a623024d4df860fb8a85d65da3099c (patch)
tree93ef44b080474a99366e196a43ec0725e7b8f1c8 /x11
parent079dddae7a137687602cd6a8558bacb91fce040c (diff)
downloadports-5754f0ce52a623024d4df860fb8a85d65da3099c.tar.gz
ports-5754f0ce52a623024d4df860fb8a85d65da3099c.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/efancylauncher/Makefile27
-rw-r--r--x11/efancylauncher/distinfo1
-rw-r--r--x11/efancylauncher/files/patch-aa32
-rw-r--r--x11/efancylauncher/pkg-comment1
-rw-r--r--x11/efancylauncher/pkg-descr7
-rw-r--r--x11/efancylauncher/pkg-plist16
6 files changed, 84 insertions, 0 deletions
diff --git a/x11/efancylauncher/Makefile b/x11/efancylauncher/Makefile
new file mode 100644
index 000000000000..a39b91f9a45e
--- /dev/null
+++ b/x11/efancylauncher/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: E-FancyLauncher
+# Version required: 0.7
+# Date created: 30 March 2000
+# Whom: jhb
+#
+# $FreeBSD$
+
+DISTNAME= E-FancyLauncher-0.7
+CATEGORIES= x11
+MASTER_SITES= http://www.docs.uu.se/~adavid/Epplets/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jhb@FreeBSD.org
+
+LIB_DEPENDS= epplet.1:${PORTSDIR}/x11-wm/epplets
+
+WRKSRC= ${WRKDIR}/E-FancyLauncher
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+ALL_TARGET= clean all
+
+post-patch:
+ ( cd ${WRKSRC} ; ${MV} makefile Makefile )
+
+.include <bsd.port.mk>
diff --git a/x11/efancylauncher/distinfo b/x11/efancylauncher/distinfo
new file mode 100644
index 000000000000..568942bf8959
--- /dev/null
+++ b/x11/efancylauncher/distinfo
@@ -0,0 +1 @@
+MD5 (E-FancyLauncher-0.7.tgz) = 06ff7a00bcb53e67d06a6e8c50d23ba6
diff --git a/x11/efancylauncher/files/patch-aa b/x11/efancylauncher/files/patch-aa
new file mode 100644
index 000000000000..451076f6128e
--- /dev/null
+++ b/x11/efancylauncher/files/patch-aa
@@ -0,0 +1,32 @@
+--- makefile.orig Sat Mar 11 12:05:21 2000
++++ makefile Fri Mar 31 09:45:06 2000
+@@ -5,6 +5,8 @@
+ DOC = $(NAME).ABOUT
+ DATA = 1.gif 2.gif 3.gif
+ DOC_OR_DATA = 1
++EBIN = ${PREFIX}/bin
++EROOT = ${PREFIX}/share/enlightenment
+ DATAPATH = ${EROOT}/epplet_data/$(NAME)
+
+ all: $(EPPLET)
+@@ -13,10 +15,7 @@
+ @make -i -s pack
+
+ %.epplet: %.c
+- @echo Compiling $@
+- @gcc -Wall -O2 -I/usr/X11R6/include -o $@ $< -lepplet
+- @strip $@;
+- @if [ ! -z "`which sstrip`" ]; then sstrip $@; fi;
++ ${CC} ${CFLAGS} -I${PREFIX}/include -o $@ $< -L${PREFIX}/lib -lepplet
+
+ install: $(EPPLET)
+ @if [ -z "${EROOT}" -o -z "${EBIN}" ]; then\
+@@ -52,7 +51,7 @@
+ @echo $(NAME) "uninstalled :("
+
+ clean:
+- rm $(EPPLET) *~
++ rm $(EPPLET)
+
+ pack: $(EPPLET)
+ rm *~
diff --git a/x11/efancylauncher/pkg-comment b/x11/efancylauncher/pkg-comment
new file mode 100644
index 000000000000..cfa2da85603e
--- /dev/null
+++ b/x11/efancylauncher/pkg-comment
@@ -0,0 +1 @@
+A flexible and easily configurable button bar for Enlightenment
diff --git a/x11/efancylauncher/pkg-descr b/x11/efancylauncher/pkg-descr
new file mode 100644
index 000000000000..bf2d4d7e15dd
--- /dev/null
+++ b/x11/efancylauncher/pkg-descr
@@ -0,0 +1,7 @@
+E-FancyLauncher is an epplet for Enlightenment that serves as a button bar
+used to launch other applications.
+
+WWW: http://www.docs.uu.se/~adavid/Epplets/
+
+- John
+jhb@FreeBSD.org
diff --git a/x11/efancylauncher/pkg-plist b/x11/efancylauncher/pkg-plist
new file mode 100644
index 000000000000..3f1dfe7c58a8
--- /dev/null
+++ b/x11/efancylauncher/pkg-plist
@@ -0,0 +1,16 @@
+bin/E-FancyLauncher.epplet
+share/enlightenment/epplet_data/E-FancyLauncher/1.gif
+share/enlightenment/epplet_data/E-FancyLauncher/2.gif
+share/enlightenment/epplet_data/E-FancyLauncher/3.gif
+share/enlightenment/epplet_data/E-FancyLauncher/E-FancyLauncher.ABOUT/E-FancyLauncher.h2.png
+share/enlightenment/epplet_data/E-FancyLauncher/E-FancyLauncher.ABOUT/E-FancyLauncher.s3.png
+share/enlightenment/epplet_data/E-FancyLauncher/E-FancyLauncher.ABOUT/E-FancyLauncher.v1.png
+share/enlightenment/epplet_data/E-FancyLauncher/E-FancyLauncher.ABOUT/E-FancyLauncher.v1t.png
+share/enlightenment/epplet_data/E-FancyLauncher/E-FancyLauncher.ABOUT/E-FancyLauncher.v1ttip.png
+share/enlightenment/epplet_data/E-FancyLauncher/E-FancyLauncher.ABOUT/MAIN
+share/enlightenment/epplet_data/E-FancyLauncher/E-FancyLauncher.ABOUT/bg.jpg
+share/enlightenment/epplet_data/E-FancyLauncher/E-FancyLauncher.ABOUT/config_window.png
+share/enlightenment/epplet_data/E-FancyLauncher/E-FancyLauncher.ABOUT/verdana.ttf
+@dirrm share/enlightenment/epplet_data/E-FancyLauncher/E-FancyLauncher.ABOUT
+@dirrm share/enlightenment/epplet_data/E-FancyLauncher
+share/enlightenment/epplet_icons/E-FancyLauncher.icon