aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2010-06-24 01:45:39 +0000
committerWesley Shields <wxs@FreeBSD.org>2010-06-24 01:45:39 +0000
commit706aeb62a798850a93e9e87adc81e67f2df0bd25 (patch)
tree60978dc487e9878c46fc63156620b910b591130d /x11
parentb36af0fe96255bcb26b389f12ee8426f6aa77bed (diff)
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/keynav/Makefile14
-rw-r--r--x11/keynav/distinfo6
-rw-r--r--x11/keynav/files/patch-Makefile16
-rw-r--r--x11/keynav/files/patch-keynav.c19
4 files changed, 29 insertions, 26 deletions
diff --git a/x11/keynav/Makefile b/x11/keynav/Makefile
index 147fde603ae8..e30f55d4230b 100644
--- a/x11/keynav/Makefile
+++ b/x11/keynav/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= keynav
-DISTVERSION= 0.20100302.2713
-PORTREVISION= 1
+DISTVERSION= 0.20100601.2912
PORTEPOCH= 1
CATEGORIES= x11
MASTER_SITES= http://semicomplete.googlecode.com/files/
@@ -15,7 +14,8 @@ MASTER_SITES= http://semicomplete.googlecode.com/files/
MAINTAINER= wxs@FreeBSD.org
COMMENT= Quickly select a portion of the screen using minimal keystrokes
-LIB_DEPENDS= xdo.2:${PORTSDIR}/x11/xdotool
+LIB_DEPENDS= xdo.2:${PORTSDIR}/x11/xdotool \
+ cairo.2:${PORTSDIR}/graphics/cairo
USE_GNOME= glib20
USE_XORG= xtst x11 xinerama
@@ -25,6 +25,12 @@ PLIST_FILES= bin/keynav
PORTEXAMPLES= keynavrc
MAKE_JOBS_SAFE= yes
+.include <bsd.port.pre.mk>
+
+.if (${OSVERSION} <= 700000)
+IGNORE= does not build on 6.x
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/keynav ${PREFIX}/bin
.if !defined(NOPORTEXAMPLES)
@@ -32,4 +38,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/keynavrc ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/keynav/distinfo b/x11/keynav/distinfo
index 1de9bddd61d9..beb2850ffaec 100644
--- a/x11/keynav/distinfo
+++ b/x11/keynav/distinfo
@@ -1,3 +1,3 @@
-MD5 (keynav-0.20100302.2713.tar.gz) = b361d4765e8a08edf3016bcb7456e509
-SHA256 (keynav-0.20100302.2713.tar.gz) = eb3ec887a50d2e07eaa1ea779ff3459eb97e03f022f5e040c75772205ca21f4c
-SIZE (keynav-0.20100302.2713.tar.gz) = 48221
+MD5 (keynav-0.20100601.2912.tar.gz) = 2b1113d2337d7bef5742a7f3ab04cf23
+SHA256 (keynav-0.20100601.2912.tar.gz) = 8ebfcbe7d33d57f8112fd62bebf937bfd8880d64e151659d7b816021567d0906
+SIZE (keynav-0.20100601.2912.tar.gz) = 68511
diff --git a/x11/keynav/files/patch-Makefile b/x11/keynav/files/patch-Makefile
new file mode 100644
index 000000000000..a9484db4c9e8
--- /dev/null
+++ b/x11/keynav/files/patch-Makefile
@@ -0,0 +1,16 @@
+--- ./Makefile.orig 2010-06-23 21:15:42.699032618 -0400
++++ ./Makefile 2010-06-23 21:15:55.756990939 -0400
+@@ -31,12 +31,7 @@
+ # We'll try to detect 'libxdo' and use it if we find it.
+ # otherwise, build monolithic.
+ keynav: keynav.o
+- @set -x; \
+- if $(LD) -o /dev/null -lxdo > /dev/null 2>&1 ; then \
+- $(CC) keynav.o -o $@ $(LDFLAGS) -lxdo; \
+- else \
+- $(MAKE) keynav.static; \
+- fi
++ $(CC) keynav.o -o $@ $(LDFLAGS) -lxdo; \
+
+ .PHONY: keynav.static
+ keynav.static: keynav.o xdo.o
diff --git a/x11/keynav/files/patch-keynav.c b/x11/keynav/files/patch-keynav.c
deleted file mode 100644
index f372590570f8..000000000000
--- a/x11/keynav/files/patch-keynav.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- ./keynav.c.orig 2010-05-30 11:20:37.002333962 -0400
-+++ ./keynav.c 2010-05-30 11:20:57.051721006 -0400
-@@ -881,14 +881,14 @@
- xdo_mouseup(xdo, CURRENTWINDOW, button);
- } else { /* Start dragging */
- appstate.dragging = True;
-- xdo_keysequence_down(xdo, 0, drag_modkeys);
-+ xdo_keysequence_down(xdo, 0, drag_modkeys, 0);
- xdo_mousedown(xdo, CURRENTWINDOW, button);
-
- /* Sometimes we need to move a little to tell the app we're dragging */
- /* TODO(sissel): Make this a 'mousewiggle' command */
- xdo_mousemove_relative(xdo, 1, 0);
- xdo_mousemove_relative(xdo, -1, 0);
-- xdo_keysequence_up(xdo, 0, drag_modkeys);
-+ xdo_keysequence_up(xdo, 0, drag_modkeys, 0);
- }
- }
-