aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-09-09 17:50:06 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-09-09 17:50:06 +0000
commit977160571a47a182dd0859903fbdc0c502a72fe1 (patch)
tree764b864b9e8e65263c78981c4b399025e471ac0d /x11
parent7668605620b397193aaf436e2b8914169f22564b (diff)
downloadports-977160571a47a182dd0859903fbdc0c502a72fe1.tar.gz
ports-977160571a47a182dd0859903fbdc0c502a72fe1.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/nxcomp/Makefile29
-rw-r--r--x11/nxcomp/distinfo2
-rw-r--r--x11/nxcomp/files/patch-Types.h52
-rw-r--r--x11/nxcomp/pkg-descr4
-rw-r--r--x11/nxcomp/pkg-plist13
6 files changed, 101 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index b80882f2b71e..788155842e37 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -224,6 +224,7 @@
SUBDIR += nvidia-driver-96
SUBDIR += nvidia-settings
SUBDIR += nvidia-xconfig
+ SUBDIR += nxcomp
SUBDIR += ooxcb
SUBDIR += p5-Clipboard
SUBDIR += p5-X11-GUITest
diff --git a/x11/nxcomp/Makefile b/x11/nxcomp/Makefile
new file mode 100644
index 000000000000..5d0cb6e4807d
--- /dev/null
+++ b/x11/nxcomp/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= nxcomp
+PORTVERSION= 3.5.0.27
+MASTER_SITES= http://code.x2go.org/releases/source/nx-libs/
+CATEGORIES= x11 devel
+DISTNAME= nx-libs-${PORTVERSION}-lite
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= NX X11 protocol compression libraries
+
+WRKSRC= ${WRKDIR}/nx-libs-${PORTVERSION}/${PORTNAME}
+
+USE_AUTOTOOLS= autoconf
+USE_XORG= xproto
+GNU_CONFIGURE= yes
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,libdir}/nx,libdir},g" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|/usr/NX/bin:/opt/NX/bin:/usr/local/NX|${PREFIX}|" \
+ ${WRKSRC}/Children.cpp
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libXcomp.so.3.5*
+
+.include <bsd.port.mk>
+
diff --git a/x11/nxcomp/distinfo b/x11/nxcomp/distinfo
new file mode 100644
index 000000000000..511b3f6c17a7
--- /dev/null
+++ b/x11/nxcomp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nx-libs-3.5.0.27-lite.tar.gz) = efbf6eed02b5eb2892828e2237dff4591442e96d0ac83f3d75c62a15101d6a27
+SIZE (nx-libs-3.5.0.27-lite.tar.gz) = 513262
diff --git a/x11/nxcomp/files/patch-Types.h b/x11/nxcomp/files/patch-Types.h
new file mode 100644
index 000000000000..6e6cf884d60d
--- /dev/null
+++ b/x11/nxcomp/files/patch-Types.h
@@ -0,0 +1,52 @@
+Description: In Types.h, don't use STL internals on libc++.
+Author: Clemens Lang <cal@macports.org>
+Abstract:
+ The nx-libs-lite package does not compile on OS X Mavericks because
+ Apple's clang compilers now default to compiling against the libc++ STL
+ rather than (their outdated copy of) libstdc++.
+ .
+ While the compiler still allows changing that, we should not rely on
+ this being possible forever.
+ .
+ The compiler chokes in Types.h, specifically the clear() methods in
+ subclasses of vectors that use implementation details of the GNU STL.
+ The attached patch fixes these compilation issues by not overriding the
+ clear() method when compiling against libc++, since the libc++ headers
+ seem to do essentially the same as the overriden method.
+--- Types.h 2013-11-05 01:35:22.000000000 +0100
++++ Types.h 2013-11-05 01:37:30.000000000 +0100
+@@ -55,6 +55,9 @@
+ return &*(vector < unsigned char >::begin());
+ }
+
++ // Avoid overriding clear() when using libc++. Fiddling with STL internals
++ // doesn't really seem like a good idea to me anyway.
++ #ifndef _LIBCPP_VECTOR
+ void clear()
+ {
+ #if defined(__STL_USE_STD_ALLOCATORS) || defined(__GLIBCPP_INTERNAL_VECTOR_H)
+@@ -95,12 +98,16 @@
+
+ #endif /* #if defined(__STL_USE_STD_ALLOCATORS) || defined(__GLIBCPP_INTERNAL_VECTOR_H) */
+ }
++ #endif /* #ifdef _LIBCPP_VECTOR */
+ };
+
+ class T_messages : public vector < Message * >
+ {
+ public:
+
++ // Avoid overriding clear() when using libc++. Fiddling with STL internals
++ // doesn't really seem like a good idea to me anyway.
++ #ifndef _LIBCPP_VECTOR
+ void clear()
+ {
+ #if defined(__STL_USE_STD_ALLOCATORS) || defined(__GLIBCPP_INTERNAL_VECTOR_H)
+@@ -141,6 +148,7 @@
+
+ #endif /* #if defined(__STL_USE_STD_ALLOCATORS) || defined(__GLIBCPP_INTERNAL_VECTOR_H) */
+ }
++ #endif /* #ifndef _LIBCPP_VECTOR */
+ };
+
+ typedef md5_byte_t * T_checksum;
diff --git a/x11/nxcomp/pkg-descr b/x11/nxcomp/pkg-descr
new file mode 100644
index 000000000000..4d52e19f17e6
--- /dev/null
+++ b/x11/nxcomp/pkg-descr
@@ -0,0 +1,4 @@
+nxcomp is a library compressing X commands to be passed over network
+for use with x2go.
+
+WWW: http://wiki.x2go.org/
diff --git a/x11/nxcomp/pkg-plist b/x11/nxcomp/pkg-plist
new file mode 100644
index 000000000000..dbfe12518bff
--- /dev/null
+++ b/x11/nxcomp/pkg-plist
@@ -0,0 +1,13 @@
+include/nx/MD5.h
+include/nx/NX.h
+include/nx/NXalert.h
+include/nx/NXmitshm.h
+include/nx/NXpack.h
+include/nx/NXproto.h
+include/nx/NXrender.h
+include/nx/NXvars.h
+lib/libXcomp.a
+lib/libXcomp.so
+lib/libXcomp.so.3
+lib/libXcomp.so.3.5.0
+@dirrmtry include/nx