aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-10-23 09:21:19 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-10-23 09:21:19 +0000
commitc1a8181ed93d586b821d3ec0d64941a64e08c838 (patch)
tree381ecddee9f8ea128c040c8ef36372e43aead8a4 /x11
parent654f385c2a7b243c672d9a3ac24bf481f040f92a (diff)
downloadports-c1a8181ed93d586b821d3ec0d64941a64e08c838.tar.gz
ports-c1a8181ed93d586b821d3ec0d64941a64e08c838.zip
- Specify LICENSE
- Normalize patch
Notes
Notes: svn path=/head/; revision=482821
Diffstat (limited to 'x11')
-rw-r--r--x11/thinglaunch/Makefile4
-rw-r--r--x11/thinglaunch/files/patch-thinglaunch.c18
2 files changed, 12 insertions, 10 deletions
diff --git a/x11/thinglaunch/Makefile b/x11/thinglaunch/Makefile
index 0a3aba214174..e24adbed6326 100644
--- a/x11/thinglaunch/Makefile
+++ b/x11/thinglaunch/Makefile
@@ -3,13 +3,15 @@
PORTNAME= thinglaunch
PORTVERSION= 1.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= LOCAL/ehaupt
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Very fast launcher program for X
+LICENSE= MIT
+
USE_XORG= x11 xorgproto
CPPFLAGS+= -I${LOCALBASE}/include -lX11
diff --git a/x11/thinglaunch/files/patch-thinglaunch.c b/x11/thinglaunch/files/patch-thinglaunch.c
index 917c3b6cdf2e..9e9c55acb82e 100644
--- a/x11/thinglaunch/files/patch-thinglaunch.c
+++ b/x11/thinglaunch/files/patch-thinglaunch.c
@@ -1,5 +1,5 @@
---- thinglaunch.c.orig 2004-09-20 16:27:56.000000000 +0200
-+++ thinglaunch.c 2009-09-01 22:11:10.000000000 +0200
+--- thinglaunch.c.orig 2004-09-20 14:27:56 UTC
++++ thinglaunch.c
@@ -19,10 +19,14 @@
*/
#include <X11/Xlib.h>
@@ -15,7 +15,7 @@
static void createWindow();
static void setupGC();
-@@ -50,10 +54,13 @@
+@@ -50,10 +54,13 @@ unsigned long black, white;
/* the actual commandline */
char command[MAXCMD+1];
@@ -29,7 +29,7 @@
createWindow();
setupGC();
-@@ -209,15 +216,15 @@
+@@ -209,15 +216,15 @@ static void redraw() {
int font_height;
int textwidth;
@@ -49,7 +49,7 @@
XFlush(display);
-@@ -229,22 +236,36 @@
+@@ -229,22 +236,36 @@ static void keypress(XKeyEvent * keyeven
#define KEYBUFLEN 20
char buffer[KEYBUFLEN+1];
KeySym key_symbol;
@@ -74,7 +74,8 @@
+ if (cursor_pos)
+ for (tmp_pos = --cursor_pos; tmp_pos <= len; tmp_pos++)
+ command[tmp_pos] = command[tmp_pos+1];
-+ break;
+ break;
+- case 0xff0d: /* enter */
+ case XK_Left:
+ if (cursor_pos)
+ cursor_pos--;
@@ -88,13 +89,12 @@
+ break;
+ case XK_End:
+ cursor_pos = len;
- break;
-- case 0xff0d: /* enter */
++ break;
+ case XK_Return:
execcmd();
break;
default:
-@@ -253,10 +274,11 @@
+@@ -253,10 +274,11 @@ static void keypress(XKeyEvent * keyeven
/* normal printable chars */
if (key_symbol >= 0x20 && key_symbol <= 0x7e) {