aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-12-13 06:04:15 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-12-13 06:04:15 +0000
commitd490a984093cc104899ddfafc504f586cd991958 (patch)
tree65f90a8bf2a38a9baf2956e6f084680e4e6fd3c8 /x11
parent0c1334ba2e75b1b008707f00418c48adba7c4331 (diff)
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/dmenu/Makefile13
-rw-r--r--x11/dmenu/files/patch-Makefile33
-rw-r--r--x11/dmenu/files/patch-config.mk19
3 files changed, 4 insertions, 61 deletions
diff --git a/x11/dmenu/Makefile b/x11/dmenu/Makefile
index 5a1401d450bd..995c02457cdd 100644
--- a/x11/dmenu/Makefile
+++ b/x11/dmenu/Makefile
@@ -23,21 +23,14 @@ OPTIONS_DEFINE= XINERAMA
OPTIONS_DEFAULT= XINERAMA
USE_XORG= x11 xft
+MAKE_ARGS= CC="${CC}" PREFIX="${PREFIX}" MANPREFIX="${MANPREFIX}/man" \
+ X11INC="${LOCALBASE}/include" X11LIB="${LOCALBASE}/lib"
PLIST_FILES= bin/dmenu bin/dmenu_path bin/dmenu_run bin/stest \
man/man1/dmenu.1.gz man/man1/stest.1.gz
XINERAMA_USE= XORG=xinerama
-
-post-patch:
- @${GREP} -Rl '%%[[:alpha:]]\+%%' ${WRKSRC}|${XARGS} ${REINPLACE_CMD} \
- -e "s,%%PREFIX%%,${PREFIX},g" \
- -e "s,%%LOCALBASE%%,${LOCALBASE},g" \
- -e "s,%%MANPREFIX%%,${MANPREFIX},g"
-
-post-patch-XINERAMA-off:
- @${REINPLACE_CMD} -e 's,$${XINERAMALIBS},,g' \
- -e 's,$${XINERAMAFLAGS},,g' ${WRKSRC}/config.mk
+XINERAMA_MAKE_ARGS_OFF= XINERAMAFLAGS= XINERAMALIBS=
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/dmenu \
diff --git a/x11/dmenu/files/patch-Makefile b/x11/dmenu/files/patch-Makefile
deleted file mode 100644
index 5f939b4a15ad..000000000000
--- a/x11/dmenu/files/patch-Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
---- Makefile.orig 2015-11-08 22:42:21 UTC
-+++ Makefile
-@@ -54,12 +54,12 @@ install: all
- @chmod 755 ${DESTDIR}${PREFIX}/bin/dmenu_path
- @chmod 755 ${DESTDIR}${PREFIX}/bin/dmenu_run
- @chmod 755 ${DESTDIR}${PREFIX}/bin/stest
-- @echo installing manual pages to ${DESTDIR}${MANPREFIX}/man1
-- @mkdir -p ${DESTDIR}${MANPREFIX}/man1
-- @sed "s/VERSION/${VERSION}/g" < dmenu.1 > ${DESTDIR}${MANPREFIX}/man1/dmenu.1
-- @sed "s/VERSION/${VERSION}/g" < stest.1 > ${DESTDIR}${MANPREFIX}/man1/stest.1
-- @chmod 644 ${DESTDIR}${MANPREFIX}/man1/dmenu.1
-- @chmod 644 ${DESTDIR}${MANPREFIX}/man1/stest.1
-+ @echo installing manual pages to ${DESTDIR}${MANPREFIX}/man/man1
-+ @mkdir -p ${DESTDIR}${MANPREFIX}/man/man1
-+ @sed "s/VERSION/${VERSION}/g" < dmenu.1 > ${DESTDIR}${MANPREFIX}/man/man1/dmenu.1
-+ @sed "s/VERSION/${VERSION}/g" < stest.1 > ${DESTDIR}${MANPREFIX}/man/man1/stest.1
-+ @chmod 644 ${DESTDIR}${MANPREFIX}/man/man1/dmenu.1
-+ @chmod 644 ${DESTDIR}${MANPREFIX}/man/man1/stest.1
-
- uninstall:
- @echo removing executables from ${DESTDIR}${PREFIX}/bin
-@@ -67,8 +67,8 @@ uninstall:
- @rm -f ${DESTDIR}${PREFIX}/bin/dmenu_path
- @rm -f ${DESTDIR}${PREFIX}/bin/dmenu_run
- @rm -f ${DESTDIR}${PREFIX}/bin/stest
-- @echo removing manual page from ${DESTDIR}${MANPREFIX}/man1
-- @rm -f ${DESTDIR}${MANPREFIX}/man1/dmenu.1
-- @rm -f ${DESTDIR}${MANPREFIX}/man1/stest.1
-+ @echo removing manual page from ${DESTDIR}${MANPREFIX}/man/man1
-+ @rm -f ${DESTDIR}${MANPREFIX}/man/man1/dmenu.1
-+ @rm -f ${DESTDIR}${MANPREFIX}/man/man1/stest.1
-
- .PHONY: all options clean dist install uninstall
diff --git a/x11/dmenu/files/patch-config.mk b/x11/dmenu/files/patch-config.mk
index e210f9ff9e5d..a1b083febddb 100644
--- a/x11/dmenu/files/patch-config.mk
+++ b/x11/dmenu/files/patch-config.mk
@@ -1,21 +1,5 @@
--- config.mk.orig 2015-11-08 22:42:21 UTC
+++ config.mk
-@@ -2,11 +2,11 @@
- VERSION = 4.6
-
- # paths
--PREFIX = /usr/local
--MANPREFIX = ${PREFIX}/share/man
-+PREFIX = %%PREFIX%%
-+MANPREFIX = %%MANPREFIX%%
-
--X11INC = /usr/X11R6/include
--X11LIB = /usr/X11R6/lib
-+X11INC = %%LOCALBASE%%/include
-+X11LIB = %%LOCALBASE%%/lib
-
- # Xinerama, comment if you don't want it
- XINERAMALIBS = -lXinerama
@@ -23,9 +23,9 @@ INCS = -I${X11INC} -I${FREETYPEINC}
LIBS = -L${X11LIB} -lX11 ${XINERAMALIBS} ${FREETYPELIBS}
@@ -28,5 +12,4 @@
+LDFLAGS += ${LIBS}
# compiler and linker
--CC = cc
-+CC?= cc
+ CC = cc