aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-01-05 22:57:40 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-01-05 22:57:40 +0000
commitc3c2e7cbffdd95c50e4e51af6ed725f080579b27 (patch)
tree4a30b690095b7c3b36754f571aeca80a710febd6 /x11
parentb3b45538b98420f9d8207e45ca713cd7aafafc23 (diff)
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/pixman/Makefile13
-rw-r--r--x11/xdm/Makefile10
-rw-r--r--x11/xorg-apps/Makefile15
3 files changed, 13 insertions, 25 deletions
diff --git a/x11/pixman/Makefile b/x11/pixman/Makefile
index 33f83dc90612..4d57c990c40a 100644
--- a/x11/pixman/Makefile
+++ b/x11/pixman/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: pixman
-# Date Created: Aug 9 2003
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= pixman
PORTVERSION= 0.24.2
@@ -18,11 +13,11 @@ USE_PERL5_BUILD=yes
USE_GNOME= ltverhack:9
CONFIGURE_ARGS= --disable-gtk
-OPTIONS= SIMD "Enable SIMD features autodetection (MMX, SSE2, VMX)" off
+OPTIONS_DEFINE= SIMD
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_SIMD)
+.if !${PORT_OPTIONS:MSIMD}
CONFIGURE_ARGS= --disable-vmx --disable-arm-simd
. if ! ${MACHINE_CPU:Mmmx}
CONFIGURE_ARGS+= --disable-mmx
@@ -32,4 +27,4 @@ CONFIGURE_ARGS+= --disable-sse2
. endif
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/xdm/Makefile b/x11/xdm/Makefile
index 66f4539a1973..862050b5cdff 100644
--- a/x11/xdm/Makefile
+++ b/x11/xdm/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: xdm
-# Date Created: 17 Feb 2006
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= xdm
PORTVERSION= 1.1.11
@@ -24,11 +19,12 @@ MAN1= xdm.1
CFFILES= GiveConsole TakeConsole Xaccess Xreset Xresources \
Xservers Xsession Xsetup_0 Xstartup Xwilling xdm-config
-OPTIONS= XDMSHELL "Install xdmshell" off
+OPTIONS_DEFINE= XDMSHELL
+XDMSHELL_DESC= Install xdmshell
.include <bsd.port.options.mk>
-.if defined(WITH_XDMSHELL)
+.if ${PORT_OPTIONS:MXDMSHELL}
CONFIGURE_ARGS+=--enable-xdmshell
MAN1+= xdmshell.1
PLIST_SUB+= XDMSHELL=""
diff --git a/x11/xorg-apps/Makefile b/x11/xorg-apps/Makefile
index c9443e1a8aa7..8a65207e42e3 100644
--- a/x11/xorg-apps/Makefile
+++ b/x11/xorg-apps/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: xorg-apps
-# Date created: Jun 22 2006
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= xorg-apps
PORTVERSION= 7.5.2
@@ -35,13 +30,15 @@ do-install:
${TOUCH} ${PREFIX}/libdata/xorg/apps
.for comp in ${COMPONENTS}
-OPTIONS+= ${comp:C/:.*//:C/.*\///:U} "Install ${comp:C/:.*//:C/.*\///} application" on
+OPTIONS_DEFINE+= ${comp:C/:.*//:C/.*\///:U}
+OPTIONS_DEFAULT+= ${comp:C/:.*//:C/.*\///:U}
+${comp:C/:.*//:C/.*\///:U}_DESC= Install ${comp:C/:.*//:C/.*\///} application
.endfor
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.for comp in ${COMPONENTS}
-. if !defined(WITHOUT_${comp:C/:.*//:C/.*\///:U})
+. if ! ${PORT_OPTIONS:M${comp:C/:.*//:C/.*\///:U}}
. if ${comp:M:}==""
port=${comp}
check=${comp:C/.*\///} # doesn't work
@@ -56,4 +53,4 @@ RUN_DEPENDS:= ${RUN_DEPENDS} ${check}:${PORTSDIR}/${port}
. endif
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>