aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-06 04:41:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-06 04:41:48 +0000
commitcedbe303a3d39d9998680d8007ad25f999cda8f3 (patch)
tree55f34dca62b35c829d3c17d5ac1727049b8bb550 /x11
parent6b0329cd7e7dd5c51c5100d71d258b6b1d803bb4 (diff)
downloadports-cedbe303a3d39d9998680d8007ad25f999cda8f3.tar.gz
ports-cedbe303a3d39d9998680d8007ad25f999cda8f3.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/XFree86-4-libraries/Makefile4
-rw-r--r--x11/XFree86-4-libraries/Makefile.inc8
2 files changed, 8 insertions, 4 deletions
diff --git a/x11/XFree86-4-libraries/Makefile b/x11/XFree86-4-libraries/Makefile
index bea7ad98e301..c160d8298569 100644
--- a/x11/XFree86-4-libraries/Makefile
+++ b/x11/XFree86-4-libraries/Makefile
@@ -29,7 +29,6 @@ LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
USE_X_PREFIX= no
-USE_REINPLACE= yes
PREFIX?= ${X11BASE}
MTREE_FILE= /etc/mtree/BSD.x11-4.dist
INSTALLS_SHLIB= yes
@@ -82,9 +81,6 @@ post-extract:
post-patch:
${CP} ${MASTERDIR}/files/nls::Compose::microsoft-cp1251 ${WRKSRC}/nls/Compose/microsoft-cp1251
- @${REINPLACE_CMD} -e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|g ; \
- s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/config/cf/FreeBSD.cf
post-install:
${INSTALL_DATA} ${WRKSRC}/programs/proxymngr/PM.h \
diff --git a/x11/XFree86-4-libraries/Makefile.inc b/x11/XFree86-4-libraries/Makefile.inc
index afb4f5852f50..a742bd95013f 100644
--- a/x11/XFree86-4-libraries/Makefile.inc
+++ b/x11/XFree86-4-libraries/Makefile.inc
@@ -15,6 +15,7 @@
DIST_SUBDIR= xc
WRKSRC?= ${WRKDIR}/xc
USE_IMAKE= YES
+USE_REINPLACE= yes
XFREE86_HTML_MAN= yes
PATCHDIR?= ${.CURDIR}/../../x11/XFree86-4-libraries/files
SCRIPTS_ENV+= CC="${CC}" \
@@ -32,6 +33,13 @@ pre-everything::
${FALSE}; \
fi;
+.if !target(pre-configure)
+pre-configure:
+ @${REINPLACE_CMD} -e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|g ; \
+ s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/config/cf/FreeBSD.cf
+.endif
+
.if !target(do-configure)
do-configure:
@cp ${X11BASE}/lib/X11/config/version.def ${WRKSRC}/config/cf