aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-24 07:54:12 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-24 07:54:12 +0000
commit7b7db2ff12edbda5ac9b1a83363f1d53e19ce087 (patch)
treedab93d190866bb19633d6c316ea4f9187796b31c /x11
parent56d11586e58a3279049e4a38ef7f738be003f74e (diff)
downloadports-7b7db2ff12edbda5ac9b1a83363f1d53e19ce087.tar.gz
ports-7b7db2ff12edbda5ac9b1a83363f1d53e19ce087.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/xkeyboard-config/Makefile9
-rw-r--r--x11/xkeyboard-config/files/etersoft-patch-symbols-typo26
2 files changed, 32 insertions, 3 deletions
diff --git a/x11/xkeyboard-config/Makefile b/x11/xkeyboard-config/Makefile
index c0ed58ee1617..ab3721acfc43 100644
--- a/x11/xkeyboard-config/Makefile
+++ b/x11/xkeyboard-config/Makefile
@@ -3,19 +3,18 @@
PORTNAME= xkeyboard-config
PORTVERSION= 2.11
CATEGORIES= x11
+MASTER_SITE_SUBDIR= individual/${XORG_CAT}/${PORTNAME}
MAINTAINER= x11@FreeBSD.org
COMMENT= X Keyboard Configuration Database
-MASTER_SITE_SUBDIR= individual/${XORG_CAT}/${PORTNAME}
LICENSE= MIT
BUILD_DEPENDS= xkbcomp:${PORTSDIR}/x11/xkbcomp
XORG_CAT= data
-USE_BZIP2= yes
+USES= gmake pathfix perl5 tar:bzip2
USE_GNOME= intlhack libxslt:build
-USES= gmake pathfix perl5
USE_PERL5= build
GNU_CONFIGURE= yes
@@ -24,6 +23,10 @@ CONFIGURE_ARGS= --with-xkb-base=${PREFIX}/share/X11/xkb \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= ETERSOFT
+ETERSOFT_DESC= Add pre-1918 Russian letters to typographic layout
+ETERSOFT_EXTRA_PATCHES= ${FILESDIR}/etersoft-patch-symbols-typo
+
.include <bsd.port.options.mk>
# !nls case doesn't work correctly, comment it out.
diff --git a/x11/xkeyboard-config/files/etersoft-patch-symbols-typo b/x11/xkeyboard-config/files/etersoft-patch-symbols-typo
new file mode 100644
index 000000000000..cf04abcf75bd
--- /dev/null
+++ b/x11/xkeyboard-config/files/etersoft-patch-symbols-typo
@@ -0,0 +1,26 @@
+Etersoft version of typographic keyboard layout. It removes Yen symbol `¥'
+(can be easily inserted via "Compose Y =") and adds four letters of Russian
+orthography that were removed during the reform of 1917-1918.
+
+Original upstream bugzilla request:
+
+ http://bugs.etersoft.ru/show_bug.cgi?id=5466
+
+Description (in Russian) and the picture of keyboard layout:
+
+ http://kb.etersoft.ru/Типографская_раскладка_Etersoft
+
+--- symbols/typo.orig
++++ symbols/typo
+@@ -29,7 +29,10 @@
+ key <AD03> { [NoSymbol, NoSymbol, EuroSign] }; // "e"
+ key <AD04> { [NoSymbol, NoSymbol, registered] }; // "r"
+ key <AD05> { [NoSymbol, NoSymbol, trademark] }; // "t"
+- key <AD06> { [NoSymbol, NoSymbol, yen] }; // "y"
++ key <AD06> { [NoSymbol, NoSymbol, U0463, U0462] };
++ key <AD07> { [NoSymbol, NoSymbol, U0475, U0474] };
++ key <AD08> { [NoSymbol, NoSymbol, U0456, U0406] };
++ key <AD09> { [NoSymbol, NoSymbol, U0473, U0472] };
+ key <AD10> { [NoSymbol, NoSymbol, acute, doubleacute] }; // "p"
+ key <AD11> { [NoSymbol, NoSymbol, bracketleft, braceleft] }; // [
+ key <AD12> { [NoSymbol, NoSymbol, bracketright, braceright] }; // ]