aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-15 00:46:22 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-15 00:46:22 +0000
commit9f8c6ab2cef9a63cf751759caf6d3a2c2ab74224 (patch)
treee0053aa3a56f2ff8a7e151a448db7c2219b9268a /x11
parentd780ccf8fbf8e9ec1d823feb4a39489269aa7cc5 (diff)
downloadports-9f8c6ab2cef9a63cf751759caf6d3a2c2ab74224.tar.gz
ports-9f8c6ab2cef9a63cf751759caf6d3a2c2ab74224.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/xorg-minimal/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/x11/xorg-minimal/Makefile b/x11/xorg-minimal/Makefile
index fc6635cc321a..92648b9f0186 100644
--- a/x11/xorg-minimal/Makefile
+++ b/x11/xorg-minimal/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xorg
PORTVERSION= 7.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 x11-servers
MASTER_SITES= # none
PKGNAMESUFFIX= -minimal
@@ -19,12 +19,14 @@ COMMENT= X.Org minimal distribution metaport
NO_BUILD= yes
+VIDEO_DRIVER?= vesa
+
RUN_DEPENDS+= ${LOCALBASE}/bin/Xorg:${PORTSDIR}/x11-servers/xorg-server \
- ${LOCALBASE}/lib/xorg/modules/drivers/vesa_drv.so:${PORTSDIR}/x11-drivers/xf86-video-vesa \
+ ${LOCALBASE}/lib/xorg/modules/drivers/${VIDEO_DRIVER}_drv.so:${PORTSDIR}/x11-drivers/xf86-video-${VIDEO_DRIVER} \
${LOCALBASE}/lib/xorg/modules/input/mouse_drv.so:${PORTSDIR}/x11-drivers/xf86-input-mouse \
${LOCALBASE}/lib/xorg/modules/input/kbd_drv.so:${PORTSDIR}/x11-drivers/xf86-input-keyboard \
- xinit:${PORTSDIR}/x11/xinit \
- xauth:${PORTSDIR}/x11/xauth \
+ ${LOCALBASE}/bin/xinit:${PORTSDIR}/x11/xinit \
+ ${LOCALBASE}/bin/xauth:${PORTSDIR}/x11/xauth \
${LOCALBASE}/lib/X11/fonts/misc/fonts.alias:${PORTSDIR}/x11-fonts/font-alias \
${LOCALBASE}/lib/X11/fonts/misc/cursor.pcf.gz:${PORTSDIR}/x11-fonts/font-cursor-misc \
${LOCALBASE}/lib/X11/fonts/misc/10x20.pcf.gz:${PORTSDIR}/x11-fonts/font-misc-misc
@@ -35,6 +37,10 @@ pre-everything::
@${ECHO_MSG} "This is a meta-port, meaning that it just depends on its subparts of the port."
@${ECHO_MSG} "It won't build and install all the parts until you have typed make install"
@${ECHO_MSG} "This port does not ensure things are upgraded; use portmaster if you want to"
- @${ECHO_MSG} "upgrade X.Org."
+ @${ECHO_MSG} "upgrade X.Org. The \"vesa\" driver is installed by default. You can choose a"
+ @${ECHO_MSG} "different one by means of the VIDEO_DRIVER parameter. For example:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " make install VIDEO_DRIVER=intel"
+ @${ECHO_MSG} ""
.include <bsd.port.mk>