aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-02-27 21:55:55 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-02-27 21:55:55 +0000
commit2ed98e249634eec9b7362f4d7d5793421aa9706a (patch)
tree5f186dab46f40df0aa893e996341f0f1c63b9c0f /x11
parentf2e7afb7aa248de02ba3036fc3cbbe6a222330e6 (diff)
downloadports-2ed98e249634eec9b7362f4d7d5793421aa9706a.tar.gz
ports-2ed98e249634eec9b7362f4d7d5793421aa9706a.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/idesk/Makefile32
-rw-r--r--x11/idesk/distinfo1
-rw-r--r--x11/idesk/pkg-descr4
-rw-r--r--x11/idesk/pkg-message8
-rw-r--r--x11/idesk/pkg-plist4
6 files changed, 50 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index bd9631679af8..11dd132b6f24 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -57,6 +57,7 @@
SUBDIR += gvid
SUBDIR += gxset
SUBDIR += gyroscope
+ SUBDIR += idesk
SUBDIR += imwheel
SUBDIR += kb2mb2
SUBDIR += kde3
diff --git a/x11/idesk/Makefile b/x11/idesk/Makefile
new file mode 100644
index 000000000000..7a97f96f67af
--- /dev/null
+++ b/x11/idesk/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: idesk
+# Date created: 16 February 2003
+# Whom: Sascha Holzleiter <sascha@root-login.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= idesk
+PORTVERSION= 0.3.5
+CATEGORIES= x11
+MASTER_SITES= http://linuxhelp.hn.org/
+
+MAINTAINER= sascha@root-login.org
+COMMENT= Place launch icons directly on your desktop
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= imlib
+
+CXXFLAGS+= `imlib-config --cflags` `freetype-config --cflags`
+MAKE_ARGS= cc="${CXX}" cflags="${CXXFLAGS}"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/idesk ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/x11/idesk/distinfo b/x11/idesk/distinfo
new file mode 100644
index 000000000000..c538cca34e3d
--- /dev/null
+++ b/x11/idesk/distinfo
@@ -0,0 +1 @@
+MD5 (idesk-0.3.5.tar.gz) = 4c87edbc3d7db462df576b7e26a04161
diff --git a/x11/idesk/pkg-descr b/x11/idesk/pkg-descr
new file mode 100644
index 000000000000..608667b2779c
--- /dev/null
+++ b/x11/idesk/pkg-descr
@@ -0,0 +1,4 @@
+iDesk lets you put launch icons directly on the
+root window of your X.
+
+WWW: http://linuxhelp.hn.org/idesk.php
diff --git a/x11/idesk/pkg-message b/x11/idesk/pkg-message
new file mode 100644
index 000000000000..86366780949c
--- /dev/null
+++ b/x11/idesk/pkg-message
@@ -0,0 +1,8 @@
++-----------------------------------------------------------------
+
+You need to configure idesk before you can use it.
+A detailed explanation can be found in the README file which
+resides in ${PREFIX}/share/doc/idesk unless you have chosen not
+to install it ;)
+
+-----------------------------------------------------------------+
diff --git a/x11/idesk/pkg-plist b/x11/idesk/pkg-plist
new file mode 100644
index 000000000000..34c27214f519
--- /dev/null
+++ b/x11/idesk/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+bin/idesk
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%